"erreur" après suppression définitive d'un post ?

Forum de support pour les questions concernant l'utilisation de phpBB 3.3, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Re: "erreur" après suppression définitive d'un post ?

Messagepar On Stage » 11 Aoû 2020 à 08:13

Salut
Je suppose que ce problème tu ne l'avais pas avec la version 3.3.0 ?
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 727
Enregistré le: 19 Mar 2018 à 16:04

Re: "erreur" après suppression définitive d'un post ?

Messagepar R0ch » 11 Aoû 2020 à 09:30

Sur la 3.3.0 rien de spécial, sauf le bug connu concernant la suppression des messages privés que j'avais patché comme recommandé. En passant en 3.3.1 j'ai eu d'autres soucis mineurs liés à deux extensions. Mais pour ce message d'erreur, je ne comprends vraiment pas d'où ça peut venir. Je n'ai eu aucun souci particulier lors de la MAJ.

Au fait, pour mes prochaines MAJ tu me conseilles donc systématiquement le protocole donné plus haut ?
R0ch
Posteur néophyte
Posteur néophyte
 
Messages: 22
Enregistré le: 06 Fév 2020 à 06:06
Localisation: Hyères

Re: "erreur" après suppression définitive d'un post ?

Messagepar On Stage » 11 Aoû 2020 à 10:25

Salut
Pour le protocole de mise à jour sans changer de branche, oui. Par contre je n'ai pas les années de bouteille de certains quidam de ce forum d'entraide à ce niveau là ! :)

Pour ton problème, si tu ne l'avais pas remarqué avec la version 3.3.0, possible que cela vienne de la mise à jour en 3.3.1.

Tu n'as jamais fait des modifications dans les fichiers système ?
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 727
Enregistré le: 19 Mar 2018 à 16:04

Re: "erreur" après suppression définitive d'un post ?

Messagepar Steph » 11 Aoû 2020 à 12:47

Je viens de mettre à jour 2 forums et je n'arrive pas à reproduire cette erreur en agissant comme indiqué (ni même par d'autres méthodes).

R0ch a écrit:Au fait, pour mes prochaines MAJ tu me conseilles donc systématiquement le protocole donné plus haut ?


La méthode qui tend a devenir celle utilisée à terme est cell-ci : Mise à niveau de phpBB 3.2.x vers 3.3.x

Pourquoi ? (non exhaustif)

  1. Cela t'assure d'avoir exactement les bons fichiers
  2. Cela évite certaines erreurs liées au temps d'exécution des scripts
  3. Plus besoin de comparer les fichiers

D'ailleurs je te suggère de faire les points 6 à 10 en supprimant également le répertoire install du pack (selon point 8) puisque ta base semble déjà à jour, tu ne perdras rien de la base de données et cela permet de s'assurer d'avoir les bons fichiers.

Après cela, supprime le répertoire cache/production et tout son contenu.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20574
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: "erreur" après suppression définitive d'un post ?

Messagepar On Stage » 11 Aoû 2020 à 12:55

Pour information personnelle Steph
Cette méthode que je donne ici est possible ou je fais erreur ?
J'ai mis à jour 1 forum ce week end avec cette méthode sans rencontrer de problème.
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 727
Enregistré le: 19 Mar 2018 à 16:04

Re: "erreur" après suppression définitive d'un post ?

Messagepar Steph » 11 Aoû 2020 à 13:30

En fait c'est presque la même chose, mais moins étoffé pour les explications et aussi il n'est pas du tout conseillé d'écraser les fichiers, c'est préférable de les supprimer pour remettre les nouveaux (c'est mon avis), car en fait parfois les utilisateurs peuvent ne pas se rendre compte qu'un fichier n'a pas été remplacé (en cochant par exemple certaines options d'action dans la configuration de Filezilla ou autre logiciel client FTP). Exemple : suivant réglage, Filezilla peut décidé qu'un fichier de taille identique n'est pas nouveau et ne le remplacera pas.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20574
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: "erreur" après suppression définitive d'un post ?

Messagepar R0ch » 11 Aoû 2020 à 15:45

Merci pour votre aide les mecs :).

On Stage a écrit:Tu n'as jamais fait des modifications dans les fichiers système ?


Pour être honnête j'ai quand même un mini doute... D'où l'intérêt de la méthode "complète" proposée par Steph du coup, ça évite d'oublier même un détail. Bon, je vais voir si j'ai le temps de refaire ça bientôt, je vous tiens au courant :wink:.
R0ch
Posteur néophyte
Posteur néophyte
 
Messages: 22
Enregistré le: 06 Fév 2020 à 06:06
Localisation: Hyères

Re: "erreur" après suppression définitive d'un post ?

Messagepar On Stage » 11 Aoû 2020 à 17:50

Hum... si tu as un mini doute c'est peut être un signe
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 727
Enregistré le: 19 Mar 2018 à 16:04

Re: "erreur" après suppression définitive d'un post ?

Messagepar R0ch » 13 Aoû 2020 à 04:21

J'avais un doute car je me rappelle avoir modifié pas mal de trucs mais après vérification, ça ne concernait que des fichiers relatifs à mon style hérité (prosilver), le patching officiel dont je parle plus haut et le .htaccess de la racine. Du coup j'ai tout vérifié, en désactivant mon style perso, en faisant les étapes 6 à 10 de la MAJ tel que conseillé par Steph, avec le .htaccess non modifié. Rien ni fait, rien a changé... ça reste un mystère :|.
R0ch
Posteur néophyte
Posteur néophyte
 
Messages: 22
Enregistré le: 06 Fév 2020 à 06:06
Localisation: Hyères

Re: "erreur" après suppression définitive d'un post ?

Messagepar On Stage » 13 Aoû 2020 à 07:00

Salut
Dans PCA/Paramètres du serveur "Activer la réécriture d'URL" et "Forcer les paramètres d'URL du serveur" sont cochés sur OUI ?
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 727
Enregistré le: 19 Mar 2018 à 16:04

Re: "erreur" après suppression définitive d'un post ?

Messagepar R0ch » 13 Aoû 2020 à 07:31

Salut OnStage :),

Les deux sont sur NON.
R0ch
Posteur néophyte
Posteur néophyte
 
Messages: 22
Enregistré le: 06 Fév 2020 à 06:06
Localisation: Hyères

Re: "erreur" après suppression définitive d'un post ?

Messagepar On Stage » 13 Aoû 2020 à 07:33

Tu peux tenter de passer les deux paramètres a OUI et retenter une suppression de post, sans grande conviction mais c'est à essayer.
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 727
Enregistré le: 19 Mar 2018 à 16:04

Re: "erreur" après suppression définitive d'un post ?

Messagepar Steph » 13 Aoû 2020 à 07:44

Afin d'essayer de reproduire, peux tu préciser en détails les actions que tu fais depuis la page d'accueil du forum jusqu'à l'apparition du message ?

Est ce que cela arrive avec un autre compte que le tient avec les mêmes permissions ?
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20574
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: "erreur" après suppression définitive d'un post ?

Messagepar R0ch » 13 Aoû 2020 à 08:05

On Stage a écrit:Tu peux tenter de passer les deux paramètres a OUI et retenter une suppression de post, sans grande conviction mais c'est à essayer.


J'ai passé uniquement "Forcer les paramètres d'URL du serveur" sur oui pour tester et ça m'a tout fait foirer alors je ne vais pas aller dans cette direction. Plus moyen de me connecter à mon compte etc... Pour l'autre option y'a un avertissement de dingue en plus alors ça me fait un peu peur. D'autant que je n'ai jamais activé ces deux options sous 3.3.0 et je n'avais pas ce message d'erreur.

Steph a écrit:peux tu préciser en détails les actions


Je vais sur un topic existant, je poste une réponse que je supprime juste après en appuyant sur l'icône "x" (toujours depuis le topic). Ensuite, je ne rempli pas le champ ni ne coche "Supprimer définitivement" et je clique sur "Oui". De retour sur le topic je clique sur "Afficher ce message" (celui qui vient d'être supprimé) → "Supprimer" → je ne rempli pas le champ et je clique sur "Oui" (pour supprimer définitivement) → apparition de l'erreur "Vous avez tenté de rediriger vers une URL potentiellement dangereuse". C'est pareil si d'autres membres suppriment leur message eux-mêmes et que je le supprime définitivement en passant par le topic.

Steph a écrit:Est ce que cela arrive avec un autre compte que le tient avec les mêmes permissions ?


Pas d'autre compte de ce type pour le moment.

EDIT : je viens de créer un compte avec permissions similaires et même résultat qu'avec le mien.
R0ch
Posteur néophyte
Posteur néophyte
 
Messages: 22
Enregistré le: 06 Fév 2020 à 06:06
Localisation: Hyères

Précédente

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : CapLSS et 1 invité