[Réglé] le formulaire envoyé n'est pas valide

Forum de support pour les questions concernant l'utilisation de phpBB 3.3, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Re: le formulaire envoyé n'est pas valide

Messagepar BernieG » 23 Mar 2020 à 11:40

Sylveretour a écrit:Si tu ne veut pas suivre ce que je te recommande, ne pas t'étonner de te retrouver avec des erreurs.
Aucun message ici depuis des mois ne recommande d'utiliser un pack de mise à jour au lieu du pack complet, en tout cas pas depuis le passage en 3.3.0

Édit :
Ton message précédent comporte une erreur parlant de l'extension "thanksforposts" qui n'est plus du tout compatible phpBB 3.3.0
Ne pas tout mélanger !


Attends, attends.... Il y a confusion ici. J'ai suivi EXACTEMENT ce que tu recommandes. Je me cites " j'ai utilisé le pack de mise à jour, à l'époque PARCE QUE C'EST CE QUI EST RECOMMANDE!". Note le "A l'EPOQUE"

J'ai ensuite cité ce que j'avais suivi "A l'EPOQUE"

Situation actuelle:

Après avoir suivi pas à pas les indications et installé à nouveau phpBB 3.3.0 AVEC LE PACK COMPLET, puis avoir désactivé TOUTES les extensions depuis la base de données ET effacé toutes les données du cache, je n'arrive toujours pas à me connecter, et j'ai ceci dans le journal d'erreurs:

[Mon Mar 23 10:23:55.108609 2020]
[php7:error] [pid 6963] [client 108.162.229.47:53902]
PHP Fatal error: Uncaught Symfony\\Component\\DependencyInjection\\Exception\\ServiceNotFoundException: You have requested a non-existent service "gfksx.thanksforposts.notification.type.thanks". in /var/www/html/lebearcnc.com/public_html/forums/vendor/symfony/dependency-injection/Container.php:348
Stack trace:\n#0 /var/www/html/lebearcnc.com/public_html/forums/phpbb/notification/manager.php(883): Symfony\\Component\\DependencyInjection\\Container->get('gfksx.thanksfor...')
#1 /var/www/html/lebearcnc.com/public_html/forums/phpbb/notification/manager.php(857): phpbb\\notification\\manager->load_object('gfksx.thanksfor...')
#2 /var/www/html/lebearcnc.com/public_html/forums/phpbb/notification/method/board.php(229): phpbb\\notification\\manager->get_item_type_class('gfksx.thanksfor...', Array)
#3 /var/www/html/lebearcnc.com/public_html/forums/phpbb/notification/manager.php(123): phpbb\\notification\\method\\board->load_notifications(Array)
#4 /var/www/html/lebearcnc.com/public_html/forums/includes/functions.php(4101): phpbb\\notification\\manager- in /var/www/html/lebearcnc.com/public_html/forums/vendor/symfony/dependency-injection/Container.php on line 348, referer: https://lebearcnc.com/forums/ucp.php?mo ... d95ce02424

Je n'arrive pas à comprendre comment l'extension "ThanksforPost" est invoquée et génère une erreur alors qu'elle est désactivée. Je doit préciser que j'utilise 5 navigateurs différents pour éviter le problème potentiel lié au cache du navigateur (Chrome, Opéra, FireFox, Brave et Edge)
BernieG
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 21 Mar 2020 à 13:40

Re: le formulaire envoyé n'est pas valide

Messagepar On Stage » 23 Mar 2020 à 12:02

Salut
Si une erreur demeure avec cette extension c'est qu'elle n'est pas désactivée.
Regarde ce lien pour désactiver les extensions depuis la BDD : support-mises-a-jour-conversions-phpbb33/sujet213695.html#p1670126

Ensuite refait la mise à jour du forum
Avatar de l’utilisateur
On Stage
Maître-posteur
Maître-posteur
 
Messages: 492
Enregistré le: 19 Mar 2018 à 17:04

Re: le formulaire envoyé n'est pas valide

Messagepar BernieG » 23 Mar 2020 à 12:19

Bon, ben, j'ai compris, et je ne vous dirais pas merci pour la NON aide et les leçons de morale déplacées

il se trouve que l'extension ThanksForPosts ajoute des lignes à la table phpbb_notification_types. Supprimer ces lignes résoud le problème. Voici donc la solution, pour ceux qui auraient le même problème:

Code: Tout sélectionner
update bearforum.phpbb_notification_types
set notification_type_enabled = 0
where
	notification_type_name = "gfksx.thanksforposts.notification.type.thanks"
or
	notification_type_name = "gfksx.thanksforposts.notification.type.thanks_remove";
BernieG
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 21 Mar 2020 à 13:40

Re: le formulaire envoyé n'est pas valide

Messagepar BernieG » 23 Mar 2020 à 12:20

On Stage a écrit:Salut
Si une erreur demeure avec cette extension c'est qu'elle n'est pas désactivée.
Regarde ce lien pour désactiver les extensions depuis la BDD : support-mises-a-jour-conversions-phpbb33/sujet213695.html#p1670126

Ensuite refait la mise à jour du forum


Dans le cas particulier, c'est FAUX! C'est bien de vouloir aider, mais c'est mieux de ne pas faire de généralités et de savoir VRAIMENT de quoi on parle.... cf message précédent.
BernieG
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 21 Mar 2020 à 13:40

Re: le formulaire envoyé n'est pas valide

Messagepar On Stage » 23 Mar 2020 à 12:21

Re
Suivant ton message précédent cela prouve que ta mise à jour vers 3.3.0 n'a pas été faites correctement
Avatar de l’utilisateur
On Stage
Maître-posteur
Maître-posteur
 
Messages: 492
Enregistré le: 19 Mar 2018 à 17:04

Re: le formulaire envoyé n'est pas valide

Messagepar Steph » 23 Mar 2020 à 12:33

S'il y a un souci avec quiconque cela se passe par MP. Aussi BernieG je t'invite à respecter les règles de relance de sujet : Merci de ne faire des UPs que toutes les 24 heures minimum ! (le fait de poster deux messages l'un à la suite de l'autre sans qu'il y est eu réponse d'un autre membre entre temps ou qu'il se soit passé 24h)

@ BernieG > Merci d'avoir donné la solution qui n'était pas évidente :wink:

Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20283
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: le formulaire envoyé n'est pas valide

Messagepar BernieG » 23 Mar 2020 à 13:07

On Stage a écrit:Re
Suivant ton message précédent cela prouve que ta mise à jour vers 3.3.0 n'a pas été faites correctement


En théorie, théorie et pratique sont la même chose. En pratique, c'est une autre histoire.

PS: J'aimerais que tu m"explique ce que tu veux dire....
BernieG
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 21 Mar 2020 à 13:40

Précédente

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités

cron