[Réglé] Le formulaire envoyé n’est pas valide. Essayez à nouveau.

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Le formulaire envoyé n’est pas valide. Essayez à nouveau.

Messagepar GBed » 26 Nov 2019 à 12:24

Bonjour,
Revoilà ce message qui m'apparaît de temps en temps, après installation de 3.2.8 : « Le formulaire envoyé n’est pas valide. Essayez à nouveau. » Et il faut reremplir identifiant et mot de passe.

Comme ça n'arrive qu'à moi et pas aux autres utilisateurs, en tout cas aux modos que j'ai contactés, j'ai essayé de reproduire l'apparition du machin chez moi. Et je pense avoir une piste.

  • Je me connecte normalement, ça baigne, je me promène dans le forum, je me déconnecte.
  • L'adresse est maintenant http://finale-logiciel-aide-gravure-mus ... a9df3674b2, avec l'id. de la session en paramètre.
  • Je fais autre chose un bon moment, pendant environ 1 heure, par exemple.
  • Je reviens à l'onglet, remplis pseudo et mot de passe et bingo ! « Le formulaire envoyé n’est pas valide. Essayez à nouveau. »
  • Si je reviens en arrière d'une page et que là j'efface ?id=e1... etc., là, ça marche.
Ce n'est pas très gênant, on peut contourner facilement la chose, mais je tenais à vous le signaler.
Modifié en dernier par GBed le 29 Nov 2019 à 21:15, modifié 1 fois.
GBed
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 26 Mar 2011 à 11:12

Re: Le formulaire envoyé n’est pas valide. Essayez à nouveau.

Messagepar Sylveretour » 27 Nov 2019 à 21:23

Bonjour,

Cela est tout à fait normal.
Pour la sécurité dans les sessions, des valeurs sont ajoutées dans le formulaire de connexion :
Code: Tout sélectionner
<input type="hidden" name="creation_time" value="1574882358">
<input type="hidden" name="form_token" value="77ef15530d9a72131fbfac0b4695b173893db0bf">

Il y a donc une valeur de temps, si tu te connecte avec un onglet inactif depuis une heure, il est normal que la valeur de temps soit dépassée et donc que les données du formulaire ne sont plus valides.

Il suffit alors tout simplement de recharger la page avant de te reconnecter.
Avatar de l’utilisateur
Sylveretour
Floodeur mature
Floodeur mature
 
Messages: 1517
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Le formulaire envoyé n’est pas valide. Essayez à nouveau.

Messagepar GBed » 29 Nov 2019 à 21:07

Merci !
Je m'en doutais un peu, mais je trouve ça un peu étrange quand même, puisqu'on remet identifiant et mot de passe.
GBed
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 26 Mar 2011 à 11:12


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Google [Bot] et 2 invités