[Demande de support] /phpbb/posting.php erreur

Le forum de support pour les questions concernant l'utilisation de phpBB2, les problèmes rencontrés au cours de telle ou telle manipulation du forum, ou les changements que vous souhaiteriez effectuer.

Modérateur: Equipe

Règles du forum
A lire impérativement sur notre page : Règlement

Pensez à effectuer une recherche et à prendre connaissance du forum de documentation, la réponse à votre question a de grandes chances de s'y trouver.

- Plus aucun support n'est délivré pour phpBB2 depuis le 1er janvier 2009

[Demande de support] /phpbb/posting.php erreur

Messagepar didelite » 02 Oct 2007 à 00:21

Formulaire a écrit:phpBB-fr : Demande de support

Bonsoir ,

Version de phpBB utilisée: phpbb2
Nom de votre hébergeur: http://www.ironie.org
Liste des mods installés: beaucaup, je peux pas du tout vous les dire car je me souviens plus mais ca fait un moment que je n en ai pas installer (d apres moi , le mod rentre pas dans mon probleme)
Adresse de votre forum: http://www.liguelfique.ironie.org/phpbb/
Identifiant du compte test: auncun

Voici mes problemes. Le principal, c est que je ne peux plus du tout poster et idem chez tous les utilisateurs du forum. Le forum me redirige sur le 1er message d erreur (/phpbb/posting.php). Et mon second probleme est que les utilisateurs qui peuvent poster (euh, c est un bien grand mot ^^. Car a chaque fois, ils arrivent sur le 2eme message d erreur), ont une erreur avec des mots interdits. Je n ai pas modifié mon forum depuis plus de 2 mois au moins. Cette erreur est survenu du jour au lendemain...


Ma question:
Que dois je faire pour pouvoir reposter et de ne pas avoir les mots interdits?


Message d'erreur complet:

1er message d erreur:
http://www.liguelfique.ironie.org/phpbb/posting.php
Forbidden
You don't have permission to access /phpbb/posting.php on this server.

2eme message d erreur:
Could not insert new word
DEBUG MODE
INSERT IGNORE INTO phpbb_search_wordlist (word_text, word_common) VALUES ('test', 0), ('exemple', 0)
Line : 234
File : functions_search.php


Merci beaucoup et à bientôt.
didelite
Posteur néophyte
Posteur néophyte
 
Messages: 9
Enregistré le: 24 Fév 2007 à 23:30

Messagepar Oyo » 02 Oct 2007 à 06:59

Salut,

Il faudrait un compte de test pour pouvoir regarder de plus près ;)
Ancien Administrateur de phpBB-fr - R.I.P Oyo 2006~2009

PrestaShop | PrestaStore
Avatar de l’utilisateur
Oyo
Inoubliable administrateur
 
Messages: 15307
Enregistré le: 12 Fév 2003 à 19:02
Localisation: Paris

Messagepar didelite » 02 Oct 2007 à 11:14

Re,

Voici un compte pr tester:

Pseudo: testeurphpbb
MdP: 123456

Merci...
didelite
Posteur néophyte
Posteur néophyte
 
Messages: 9
Enregistré le: 24 Fév 2007 à 23:30

Messagepar Rukkia » 02 Oct 2007 à 11:29

Bonjour,

la premiere chose à faire est de vous rendre dans votre gestionnaire de base de donnée (phpmyadmin),de cocher la table phpbb_search_wordmatch et de choisir l'option "réparer cette table" .

@+
Infographiste & Webdesigner : 2086 Studios
Styliste, mode Fashion & Urbaine : Project X Paris
Avatar de l’utilisateur
Rukkia
Maître des floodeurs
Maître des floodeurs
 
Messages: 2451
Enregistré le: 12 Aoû 2006 à 23:26
Localisation: Au coeur de Photoshop

Messagepar didelite » 02 Oct 2007 à 15:47

Voila, operation effectuer:

Table : db_....phpbb_search_wordmatch
Op : repair
Msg_type : status
Msg_text : OK

Mais j ai toujours les mêmes messages d erreurs. Mais j ai remarqué que si j ecris un texte court, c est le message d erreur 2. Et pour un long post, c est le message d erreur 1. :cry:
didelite
Posteur néophyte
Posteur néophyte
 
Messages: 9
Enregistré le: 24 Fév 2007 à 23:30

Messagepar didelite » 05 Oct 2007 à 01:20

up le probleme est toujours la :(
didelite
Posteur néophyte
Posteur néophyte
 
Messages: 9
Enregistré le: 24 Fév 2007 à 23:30

Messagepar Oyo » 05 Oct 2007 à 06:55

Salut,

J'arrive a poster normalement, le problème c'est pour répondre :s
J'ai une solution mais c'est assez "crade"

Code: Tout sélectionner
#
# [ OPEN ] ----
#
includes/functions_post.php

#
# [ FIND ] ----
#
	add_search_words('single', $post_id, stripslashes($post_message), stripslashes($post_subject));

#
# [ REMPLACE WITH ] ----
#
	//~ `HARD` FIX by Oyo
	//~ add_search_words('single', $post_id, stripslashes($post_message), stripslashes($post_subject));
Ancien Administrateur de phpBB-fr - R.I.P Oyo 2006~2009

PrestaShop | PrestaStore
Avatar de l’utilisateur
Oyo
Inoubliable administrateur
 
Messages: 15307
Enregistré le: 12 Fév 2003 à 19:02
Localisation: Paris

Messagepar didelite » 05 Oct 2007 à 22:42

Rebonsoir,

Je viens de testé, et ça ne fonction pas plus. Mais pour ma part, moi je n arrive pas a poster et d autres n arrivent pas a repondre au post.
Si tu as le temps de tester quelque chose pour moi, Oyo. Ca sert cool. Comme ca tu vas voir que l on ne peut pas tout poster:

titre du post:
Code: Tout sélectionner
Coeur de destructeur


post:
Code: Tout sélectionner
[size=16]Type de farm:[/size] Solo

[size=16]Ville:[/size] Chambre de Transfert principal

[size=16]Profession:[/size] El/M ou G/Rt

[size=16]Temps:[/size] El/M: 6min30 (max) / G/Rt: 8min (max)



[size=16]Cas 1:[/size] El/M

Build: OgNFgUus2oXzXtUI91G8wloIReA

    * Aura de Chair de pierre
    * Armure de la Terre
    * Rénovation
    * Esprit de Balthazar
    * Glyphe de rapidité
    * Chair d'obsidienne
    * Armure d'éclats
    * Cristaux de Teinai

Les Points :
    * Magie de la Terre : 15
    * Conservation d'énergie :11
    * Prière de Guérison : 8
    * Prière de Chatiment : 3

Arme: baton recast et 20% enchantement
[url=http://fdg.guild-heberg.fr/index.php?2007/09/20/480-farm-le-defit-de-brill-en-el-m-gwen]L i e n s[/url]


[size=16]Cas 2:[/size] G/Rt

Le Build :

    * Khanhei était revanchard
    * Défense de Bonetti
    * "Je vous vengerai !"
    * Air de Supériorité
    * Lumière de Delrimor
    * L'Acide Alchimique d'Alkar
    * Résistance à la douleur
    * Sceau de constitution

Les Points :
    * Force : 9
    * Tactique : 12
    * Magie de la Restauration : 12

[url=http://fdg.guild-heberg.fr/index.php?2007/10/01/498-farm-defit-de-brill-en-g-en-gwen]L i e n s[/url]


Et si tu peux me confirmé que toi aussi tu ne peux pas le posté.
Merci pour le temps que vous passez a m aider :D
didelite
Posteur néophyte
Posteur néophyte
 
Messages: 9
Enregistré le: 24 Fév 2007 à 23:30

Messagepar Oyo » 06 Oct 2007 à 08:34

Salut,

Essai d'installer ce mod pour voir plus d'ou peut venir l'erreur sur l'insert dans la base ;)
http://www.phpbb.com/community/viewtopic.php?t=233542

Normalement, avec mon fix tu ne devrais plus avoir d'erreur vu qu'il n'est appeler qu'une fois :s

As-tu installer de mod qui toucher au posting.php ?
Ancien Administrateur de phpBB-fr - R.I.P Oyo 2006~2009

PrestaShop | PrestaStore
Avatar de l’utilisateur
Oyo
Inoubliable administrateur
 
Messages: 15307
Enregistré le: 12 Fév 2003 à 19:02
Localisation: Paris

Messagepar didelite » 06 Oct 2007 à 16:19

Re,

Je viens d installé le Mod, et cela ne change rien. Je l ai laisser si tu veux testé. Sinon pour ta question, non je n ai pas installé de Mod qui touche au posting.php (sauf le tiens :p )...
didelite
Posteur néophyte
Posteur néophyte
 
Messages: 9
Enregistré le: 24 Fév 2007 à 23:30

Messagepar Oyo » 06 Oct 2007 à 17:57

Salut,

Peux-tu m'envoyer tes pass FTP via MP ou alors mettre tes fichiers au format txt que je regarde de plus près oO
Ancien Administrateur de phpBB-fr - R.I.P Oyo 2006~2009

PrestaShop | PrestaStore
Avatar de l’utilisateur
Oyo
Inoubliable administrateur
 
Messages: 15307
Enregistré le: 12 Fév 2003 à 19:02
Localisation: Paris

Messagepar didelite » 06 Oct 2007 à 19:53

Voila je fais ca de suite ;)
didelite
Posteur néophyte
Posteur néophyte
 
Messages: 9
Enregistré le: 24 Fév 2007 à 23:30

Messagepar Oyo » 06 Oct 2007 à 21:32

Pour les messages d'erreurs quand on poste c'est réglé

Pour la 2eme erreur ça vient du % il n'aime pas je ne sais pas pourquoi :s

Si tu n'a pas de mod d'installer, tu devrais faire la mise à jour de 2.0.20 à 2.0.22 ;)
Ancien Administrateur de phpBB-fr - R.I.P Oyo 2006~2009

PrestaShop | PrestaStore
Avatar de l’utilisateur
Oyo
Inoubliable administrateur
 
Messages: 15307
Enregistré le: 12 Fév 2003 à 19:02
Localisation: Paris

Messagepar Cheval-furtif » 08 Oct 2007 à 09:05

Code: Tout sélectionner
http://www.liguelfique.ironie.org/phpbb/posting.php
Forbidden
You don't have permission to access /phpbb/posting.php on this server.

J'ai eu le même soucis avec Infomaniak, cela vennait d'une protection qu'ils avaient mis en place sur leur serveur pour stopper le spam de robots sur les forums phpBB. Il avait fait une modification pour que l'accès au fichier posting.php soit interdit lorsque le referer n'est pas le site. Or comme certains antivirus (Norton) suppriment le referer, le serveur nous identifiait comme des spammeur et nous refusait l'accès au fichier.
J'ai dû renommer le fichier posting.php et changer pas mal de trucs dans le code pour que phpBB n'utilise plus posting.php ...
Alec ;)
Avatar de l’utilisateur
Cheval-furtif
Dieu des floodeurs
Dieu des floodeurs
 
Messages: 6703
Enregistré le: 12 Jan 2004 à 09:07
Localisation: France

Messagepar didelite » 08 Oct 2007 à 16:12

Coucou a tous,

Je viens de mettre a jour phpbb 2.0.20 a 2.0.22. Et le probleme est toujours la. Cheval furtif, d apres toi ca viendrai de mon hebergeur? Me dit pas ca j ai envis de me pendre. Ca fait plus d une semaine que je me creuse la tete a regler ce probleme. Et j ai pas envis de me faire de la ligne de code a gogo :'''''( (je vais contacté mon hebergeur pour voir s ils ont changé quelque chose).
Si quelqu un a une autre idee?

Merci.
didelite
Posteur néophyte
Posteur néophyte
 
Messages: 9
Enregistré le: 24 Fév 2007 à 23:30

Suivante

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 7 invités

cron