À l'aide Urgent plus de smiles dans BDD

Le forum de support pour les questions concernant l'utilisation de phpBB2, les problèmes rencontrés au cours de telle ou telle manipulation du forum, ou les changements que vous souhaiteriez effectuer.

Modérateur: Equipe

Règles du forum
A lire impérativement sur notre page : Règlement

Pensez à effectuer une recherche et à prendre connaissance du forum de documentation, la réponse à votre question a de grandes chances de s'y trouver.

- Plus aucun support n'est délivré pour phpBB2 depuis le 1er janvier 2009

À l'aide Urgent plus de smiles dans BDD

Messagepar catx » 26 Mai 2006 à 23:48

Bpnjour,

J'ai effacer les smiles à partir de ma BDD et là je ne peux plus en ajouter.
Que dois-je faire???

Couldn't insert new smiley

DEBUG MODE

SQL Error : 1136 Column count doesn't match value count at row 1

INSERT INTO phpbb_smilies (code, smile_url, emoticon, smilies_order, cat_id) VALUES (':am0:', 'am_0_1x1.gif', '', 1)

Line : 605
File : admin_smilies.php


Urgent SVP je n'ai plus aucun smiles sur mon forum!
Merci de m'aider
catx
Posteur habitué
Posteur habitué
 
Messages: 220
Enregistré le: 18 Oct 2005 à 05:10

Messagepar catx » 27 Mai 2006 à 01:01

Bon bien personne :(

Plus d'infos :
J'ai installé ces 2 MODS juste avant
-smilies_order-1_0_0
-Categorized_Smilies_FR_v1.0.1

Pour faire de l'ordre j'ai voulu remmettre de nouveaux smilies donc j'ai effacé ceux que j'avais avant.
Avoir su :cry: Là je ne peux plus mettre mes nouveaux.

J'ai lu et fait des recherches je ne vois rien à ce sujet :roll:

Je suis vraiment dans l'impasse car je ne connais pas assez la base de donnée.

Ca l'air fou sur le forum plus de smilies juste les codes dans tous les messages.

Peut-on revenir comme avant sur la base de donnée?

Merci à celui ou celle qui me dépannera!
:wink:
catx
Posteur habitué
Posteur habitué
 
Messages: 220
Enregistré le: 18 Oct 2005 à 05:10

Messagepar mortimer2 » 27 Mai 2006 à 01:02

Tu as un problème dans admin_smilies.php. La requête est normalement la suivante :
Code: Tout sélectionner
$sql = "INSERT INTO " . SMILIES_TABLE . " (code, smile_url, emoticon)

Il n'y a ni smilies_order ni cat_id.

Tu as un mod à moitié installé qui met la zizanie.

Salut
mortimer2
Dieu des floodeurs
Dieu des floodeurs
 
Messages: 7023
Enregistré le: 18 Mai 2005 à 01:09

Messagepar catx » 27 Mai 2006 à 01:05

Merci ouf!

Mais que dois-je faire?
Faire cette requête dans mon phpadmin?

Le dernier Mod que j'ai mis est "Order"

#-----[ SQL ]------------------------------------------
#
ALTER TABLE phpbb_smilies ADD smilies_order INT( 5 ) NOT NULL;

#
#-----[ SQL ]------------------------------------------
#
INSERT INTO phpbb_config VALUES ('smilies_insert', 1);

C'est touT ce qu'il demande et je les ai fait!
catx
Posteur habitué
Posteur habitué
 
Messages: 220
Enregistré le: 18 Oct 2005 à 05:10

Messagepar catx » 27 Mai 2006 à 01:24

OK ici y'a quelque chose qui m'a fais hésiter:
Pouvez vous m'expliquer?

#-----[ IN-LINE FIND ]------------------------------------------
#
$smile_data[1]) . "'

#
#-----[ IN-LINE AFTER, ADD ]------------------------------------------
#
, $order_extreme

#
#-----[ AFTER, ADD ]------------------------------------------
# NOTE: This line is to be the next full line after the line just edited
#
$order_extreme = $order_extreme + $shift_it;


Voici ce que j'ai fais:
VALUES('" . str_replace("\'", "''", $smile_data[$j]) . "', '" . str_replace("\'", "''", $smile_data[0]) . "', '" . str_replace("\'", "''", $smile_data[1]) . "', $order_extreme)";
$order_extreme = $order_extreme + $shift_it;
}


Y'a t-il une erreur?
Merci à vous
catx
Posteur habitué
Posteur habitué
 
Messages: 220
Enregistré le: 18 Oct 2005 à 05:10

OK

Messagepar catx » 27 Mai 2006 à 02:08

Bon bien finallement j'ai enlevé le MOD "smilies_order-1_0_0 ".
Là tout fonctionne!

Cela fait plusieurs MOD que j'installe et c'est assez rare que ca ne marche pas!

Pour moi il y a quelque chose qui cloche avec ce mod. Il ne doit pas aller avec l'autre MOD "category"ou ???

Ou si ce n'est pas ce MOD c'est peut-être la manoeuvre qu'il dise de faire à la fin de cette page ici: http://forums.phpbb-fr.com/viewtopic_48147_pd0_poasc_s285.html

Pouvez-vous me dire si cette manoeuvre est OK?
Je réessayerais une autre fois !

Je ne comprends pas car tout marchais avant que j'efface des Smiles de ma base.
"Mod Order fonctionnait" bizarre???

Merci pour vos réponses afin de m'expliquer le tout !!!
catx
Posteur habitué
Posteur habitué
 
Messages: 220
Enregistré le: 18 Oct 2005 à 05:10


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 4 invités