mise à jour de phpbb 3.2.2 vers 3.3.0

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.3.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.3

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

mise à jour de phpbb 3.2.2 vers 3.3.0

Messagepar pit » 06 Avr 2020 à 23:34

Bonsoir.
Je suis un novice complet sur phpbb et sur les logiciels des sites web, mais suite à la disparition du fondateur concepteur d'un petit forum, je dois prendre en main l'admin de façon poussée, jusqu'à présent je faisais de l'admin du quotidien mais je ne m'étais jamais plongé dans les arcanes d'un forum (manque de temps !).
Récemment après en avoir discuté avec un autre admin, j'ai vu que nous avions beaucoup de version en retard et qu'il serait plus sécuritaire de faire les mises à jour.
Comme j'en suis, pour le moment, incapable, j'ai demandé à l'hébergeur de faire la mise à jour : il a dit pas de problème, moyennant 30 €. Il a fait ça très vite (une heure avec un logiciel spécialisé du nom de softaculous), en uogradant au passage certaines extensions, et PHP vers la v7.1.33, et aussi, si j'ai bien compris, la base données mySQL
Il a dû désactiver une extension qui causait une fatal error
Code: Tout sélectionner
[03-Apr-2020 18:12:03 UTC] PHP Fatal error:  Uncaught Symfony\Component\Routing\Exception\RouteNotFoundException: Unable to generate a URL for the named route "vse_abbc3_bbcode_wizard" as such route does not exist. in /home2/hva/public_html/forum/cache/production/url_generator.php:53

Mais à part ça le forum marchait.
On a juste constaté que les actions des BBcode de message n'étaient plus sous forme d'icone mais en texte anglais, et aussi qu'il n'était plus possible d'intégrer directement une vidéo dans un message.
Cela ne m'a pas trop gêné, je me suis dit que j'aurai un peu de temps pour solutionner ces soucis.
Par contre, le lendemain je me suis aperçu que je ne pouvais plus accéder via le PCA aux données d'un utilisateur et ça c'est, à mon avis, un gros problème, à régler rapidement.
Le message d'erreur qui sort est "erreur d'encodage du contenu - Une erreur est survenue pendant une connexion à escapades-nature-camping-car.fr. - Veuillez contacter les propriétaires du site web pour les informer de ce problème."
Du coup, j'ai regardé quelles sont les extensions qui traitent des données utilisateurs et j'ai trouvé celle là:
User details avec un numéro de version2.1.1-rc1
J'ai recherché et vu que c'était une création de david63 et qu'il avait sorti une version compatible 3.3 fin Janvier 2020;
Sur le fichier disponible sur le forum US j'ai été incapable de trouver le numéro de version.
Par contre pour cette nouvelle version le langage fr n'est apparemment pas disponible.
Mes questions de novice :
cette extension non compatible et/ou avec le langage français manquant pourrait-elle provoquer le message 'erreur d'encodage' ?
Si oui, je vais la désactiver.
Sinon, vers où faut-il chercher ?

Merci pour l'aide que vous pourrez apporter à un débutant.
Désolé pour ce long message.
pit
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 15 Déc 2015 à 23:25

Re: mise à jour de phpbb 3.2.2 vers 3.3.0

Messagepar pit » 07 Avr 2020 à 10:17

Bonjour
Mon hébergeur a trouvé cette nuit sur le forum US un post qui parlait de "content decoding" (--> https://www.phpbb.com/community/viewtopic.php?t=2236746
Vu que ça parlait de gzip, j'ai été voir où ça se paramétrait, l'usage de gzip, bien que je ne voyais pas ce que la compression avait à faire ici (affichage d'un écran, léger, sur le PC).
J'ai trouvé ça dans les paramètres du serveur et j'ai compris avec le message ci-dessous :
Activer la compression GZip :
Le contenu généré sera compressé avant d’être envoyé à l’utilisateur. Cela peut réduire le trafic mais également augmenter l’utilisation du CPU à la fois du côté serveur et client. Cela nécessite que l’extension PHP zlib soit chargée.


Donc désactivation et ça marche, l'écran s'affiche et en français ! Me voilà plus rassuré sur la santé du forum.
:D
Cependant, il reste une anomalie : la fiche de l'utilisateur s'affiche mais avec en première ligne en haut de l'écran le message :
Code: Tout sélectionner
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/language/language.php on line 313: vsprintf(): Too few arguments

Quels paramètres peuvent-il manquer ?

En plus de ça, il me reste à trouver le souci avec le "vse_abbc3_bbcode_wizard" (affichage d'icônes dans les actions bbcode des messages, et aussi le fait que l'intégration de vidéos youtube ne marche plus (et que les vidéos intégrées auparavant ne s'affichent pas !).

Je pense qu'il doit y avoir la possibilité d'activer un mode debug dans php bb, je vais rechercher ça, peut-être cela me fera avancer pour résoudre le souci.
Le confinement me laisse du temps libre, petit à petit je vais me plonger dans php bb et tous ses copains.
Prenez soin de vous.
Si je ne trouve pas, je ferai appel au forum.
pit
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 15 Déc 2015 à 23:25

Re: mise à jour de phpbb 3.2.2 vers 3.3.0

Messagepar Sylveretour » 07 Avr 2020 à 11:01

Bonjour,

La compression gzip est très importante pour contribuer à réduire le temps de chargement des pages, à activer quand tout sera réparé.

Ton hébergeur qui prend cher pour une mise à jour est aussi un incapable.
Il n'a tout simplement pas mis à jour la langue Française restée en 3.2, l'erreur renvoyée en est l'illustration.
Au vu de cela, je te conseille de renvoyer la totalité des fichiers du core de phpbb, voir ici -> documentation/mise-a-jour/mise-a-niveau-de-phpbb-32x-vers-33x-a248-view.html
Exécute les actions du point 6 au point 10 en n'envoyant pas le dossier install/
Une fois ceci fait, tu aura bien tous les fichiers de la version 3.3.0

Pour activer le debug en 3.3.x, j'ai fait un sujet dans mon centre de doc -> https://breizhcode.com/viewtopic.php?f=10&t=116

Tu a d'autres erreurs, mais dues à des extensions non à jour ou non compatibles 3.3 (va t'enregistrer chez toi -> https://www.escapades-nature-camping-ca ... e=register)
Tu voit que l'extension derky/sortablescaptcha Créée un bug, elle doit être mise à jour.

Pour voir si tes extensions sont bien compatibles 3.3, installe cette extension -> https://www.phpbb.com/community/viewtopic.php?t=2528456
Elle t'indique quelles sont les petites corrections à apporter aux extensions pour les rendre compatibles.
Attention, les problèmes avec les extensions doivent faire l'objet de sujets dans le forum des extensions et non ici.
Avatar de l’utilisateur
Sylveretour
Apprenti-floodeur
Apprenti-floodeur
 
Messages: 1427
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: mise à jour de phpbb 3.2.2 vers 3.3.0

Messagepar Steph » 07 Avr 2020 à 11:02

Salut,

Si je comprends bien, tu as payé 30 € à ton hébergeur pour qu'il fasse la mise à jour en utilisant softaculous, génial c'est un excellent hébergeur, mai surtout un profiteur, qui plus est laisse un nombre de soucis impensables venant de lui, mais cela n'engage que moi personnellement.

Sinon, comme un grand nombre de forums nous avons un règlement, le fait pour un même membre de poster 2 messages l'un à la suite de l'autre sans qu'il y ait eu de réponses entre temps ou qu'il se soit passé 24h est considéré comme une relance de sujet. Merci de ne faire des UPs que toutes les 24 heures minimum !

Je constate plusieurs demandes dans ton sujet, toujours dans notre règlement nous indiquons fonctionner sur la base d'un sujet = une demande = un auteur donc même si tu dois ouvrir une centaine de sujets ce n'est pas un souci.

Donc là actuellement, ton forum est-il en version 3.3.0 ?
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20171
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: mise à jour de phpbb 3.2.2 vers 3.3.0

Messagepar pit » 07 Avr 2020 à 12:32

Bonjour
Merci à tous les deux pour les réponses, ça va m'aider, je vais digérer tout ça aujourd'hui, je vais apprendre des choses.
@Sylveretour : comment vois-tu que la langue française est restée en 3.2 ?

Pour ce qui est de la remarque sur le Up, je voulais juste montrer que j'avais avancé un peu par rapport à mon 1er message, de manière et que vous ayez l'évolution de la situation : ce n'était pas fait pour relancer le sujet.
Pour ce qui est de faire des messages différents selon le sujet c'est bien mon intention, mais dans le 1er msg je voulais surtout mettre le focus sur l'accès au panneau d'admin tout en montrant la totalité du panorama au cas où il pourrait y avoir des relations entre les différents soucis.
Merci pour votre jugement sur l'hébergeur, il avait dit qu'il ne connaissait pas php bb mais qu'il pouvait le faire et comme je n'ai aucune idée du prix du marché ..... C'est quoi, d'ailleurs le prix du marché ?

Pour répondre à la question de Steph : oui le forum est en 3.3.0 si j'en crois ce que vois dans le PCA onglet General (PHP étant en 7.1.33 et MySQL en 5.7.29-log-cli-lve)
pit
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 15 Déc 2015 à 23:25

Re: mise à jour de phpbb 3.2.2 vers 3.3.0

Messagepar Steph » 07 Avr 2020 à 13:48

Commence déjà par supprimer le répertoire production qui se trouve dans cache sur le FTP et vois s'il y a une amélioration ou non.

Il se peut que les extensions ne soient pas compatibles avec phpBB 3.3.0

Pour ce qui est du cout idéal demandé par l'hébergeur, chacun est libre de connaitre sa limite, cependant s'il fait payer une prestation, la moindre des choses est de vérifier que tout fonctionne bien au moment où c'est fait.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20171
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: mise à jour de phpbb 3.2.2 vers 3.3.0

Messagepar Sylveretour » 07 Avr 2020 à 15:13

comment vois-tu que la langue française est restée en 3.2 ?

Pour savoir si la langue fr n'est pas en 3.3.0, les 2 liens tout en bas de ton forum non traduits et le message d'erreur suivant sur la page d'enregistrement :
Code: Tout sélectionner
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/language/language.php on line 313: vsprintf(): Too few arguments

Est un message d'erreur typique de langue non mise à jour après un passage de 3.2.x vers 3.3.x

Puis, dans l'administration, quelle version de phpBB est indiquée ?
Avatar de l’utilisateur
Sylveretour
Apprenti-floodeur
Apprenti-floodeur
 
Messages: 1427
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: mise à jour de phpbb 3.2.2 vers 3.3.0

Messagepar pit » 07 Avr 2020 à 17:01

OK, merci Sylveretour

Comme répondu à Steph plus haut :
" oui le forum est en 3.3.0 si j'en crois ce que vois dans le PCA onglet General (PHP étant en 7.1.33 et MySQL en 5.7.29-log-cli-lve)"
pit
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 15 Déc 2015 à 23:25


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité