[REGLE]Failure while aqcuiring locks

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.3.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[REGLE]Failure while aqcuiring locks

Messagepar Choco » 07 Mai 2020 à 00:34

Bonjour ,
Tout semblait bien se passer, base de données infos diverses oK puis blocage voir image :
malgré le blocage, j'ai lancé le site pour voir ce qui se passerait.

Image

par contre pour la connection à l'administration j'ai : l'image-cidessous
Image

Puis j'ai fermé la page err 500 et recommencer et là j'ai pu me connecté sur le forum !

Image

A l'installation page des mail SMPT etc.. j'ai mis 'PLAIN' sans savoir si c'était le bon paramètrre.

Merci pour l'aide
Modifié en dernier par Choco le 07 Mai 2020 à 12:36, modifié 2 fois.
Choco
Posteur néophyte
Posteur néophyte
 
Messages: 33
Enregistré le: 17 Mai 2018 à 19:31

Re: Plantage à l'installation

Messagepar Choco » 07 Mai 2020 à 03:27

je viens de lire que la version php est la 7.13 et j'ai sur mon serveur : 7.2 ou 7.3 ou 7.4
je vais donc désinstaller et réinstaller la version phpbb 3.29 qui supporte php 7.3
Choco
Posteur néophyte
Posteur néophyte
 
Messages: 33
Enregistré le: 17 Mai 2018 à 19:31

Re: Failure while aqcuiring locks

Messagepar Steph » 07 Mai 2020 à 07:44

Salut,

Tu as fait un mauvais choix d'installer une version 3.2.9, cette version s'arrête en juillet : Pensez à mettre à jour vos forums en version phpBB 3.3.x avant juillet 2020

D'ailleurs phpBB 3.2.9 n'est pas pleinement fonctionnel avec PHP 7.3, c'est même déconseillé et cela ne sera vraiment pas étonnant que tu te retrouves avec quelques soucis que tu ne vois pas encore.

Précision, phpBB 3.3.0 à besoin de PHP à partir de la version PHP 7.1.3.

L'erreur Failure while aqcuiring locks se corrige de cette manière : https://www.phpbb.com/community/viewtop ... #p15409856

PS : "Plantage à l'installation" n'est pas du tout un titre explicite, d'aillleurs lors de recherches par d'autres membres il ne sera pas utile ainsi, c’est pourquoi j'ai modifié en "Failure while aqcuiring locks" qui est beaucoup plus parlant en lisant la liste des sujets du forum. Merci de ne faire des UPs que toutes les 24 heures minimum !
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20177
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Failure while aqcuiring locks

Messagepar Choco » 07 Mai 2020 à 10:34

Bonjour,
je viens de lire votre réponse et le lien pour résoudre mon problème !
mais les réponses apportées (dans ce lien), sont pour moi, imprécises et confuse , j'ai mis la traduction google qui semble correcte,mais ce sont les explications des intervants qui semblent être des 'pros' , et moi ce n'est pas mon cas !

Perso à la lecture de ce lien, le problème vient aprés une mise à jour , et moi ce n'est pas le cas j'ai installé la version 3.3 directement !

Et après lecture de ce lien, je ne comprend pas comment réparer.
Choco
Posteur néophyte
Posteur néophyte
 
Messages: 33
Enregistré le: 17 Mai 2018 à 19:31

Re: Failure while aqcuiring locks

Messagepar Steph » 07 Mai 2020 à 10:38

Les fichiers de la mise à jour sont les mêmes que pour la version complète donc le souci peut tout à fait être pareil. Je ne sais pas si cela va résoudre le souci, mais j'ai déjà utilisé cette astuce pour un autre forum avec succès.

En traduit

Ouvrir phpbb/lock/flock.php

Chercher

Code: Tout sélectionner
if (!@flock($this->lock_fp, LOCK_EX))


Remplacer par

Code: Tout sélectionner
if (!@flock($this->lock_fp, $mode == 'wb' ? LOCK_EX : LOCK_SH))


Mais vu que tu es en version 3.2.9 : Mise à niveau de phpBB 3.2.x vers 3.3.x
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20177
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Failure while aqcuiring locks

Messagepar Choco » 07 Mai 2020 à 11:51

Mille fois merci :D
J'ai réinstalllé la version 3.3 et j'ai fait les modif que vous m'avez indiqué ci-dessus et le forum fonctionne ainsi que j'ai pu me connecté à l'admin.
Je n'ai plus qu'à travailler sur son 'loock'.
Vous êtes super sympa. :wink:
Choco
Posteur néophyte
Posteur néophyte
 
Messages: 33
Enregistré le: 17 Mai 2018 à 19:31

Re: Failure while aqcuiring locks

Messagepar Steph » 07 Mai 2020 à 12:05

Content que tu ais réussi ton installation :wink:

Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20177
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité