Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Support pour n'importe quelle extension non présente dans notre base de données
Aucune demande de personnalisation des extensions n'est autorisée.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support des extensions de phpBB-fr.com

Merci de mettre le nom de l'extension ainsi que sa version entre crochets, et un titre explicite afin de faciliter la recherche.
Exemple : [nom de l'extension + numéro de version] Titre explicite résumant le problème

Le lien de téléchargement de l'extension est demandé pour toute demande de support.

Aucune demande de personnalisation des extensions n'est autorisée.

Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar Darloup » 23 Fév 2021 à 06:15

Bonjour,

Je viens s'installer l'extension "Contact Admin" (https://www.phpbb.com/customise/db/exte ... act_admin/) qui m'a été recommandée ici... Elle est supposée être compatible avec phpBB 3.3.3.

Malheureusement, lorsque j'essaie de l'activer, j'obtiens tout simplement une page blanche à l'écran et rien ne se passe.

Je me demande si se problème ne serait pas lié à un récent problème sur mon forum que j'ai mentionné ici : support-utilisation-phpbb33/sujet214563.html

Par avance, je vous remercie de votre aide !

Cordialement,

Henry
Avatar de l’utilisateur
Darloup
Traducteur
Traducteur
 
Messages: 613
Enregistré le: 14 Mar 2009 à 20:49
Localisation: Barranquilla (Colombie)

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar On Stage » 23 Fév 2021 à 09:09

Salut Henry
Je te confirme que la version 1.3.7 est bien compatible avec la version 3.3.3 de phpBB, et la version 8.0 de php
Version de phpBB : 3.3.3
Version de php : 8.0.2
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 888
Enregistré le: 19 Mar 2018 à 16:04

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar Steph » 23 Fév 2021 à 09:14

Salut,

Je confirme que la version 1.3.7 de contact admin fonctionne avec phpBB 3.3.3, je l'ai sur plusieurs forums.

As-tu modifié les fichiers de langue par hasard ? Si oui cela peut venir de là, ou effectivement lier au souci dont tu donnes le lien.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20825
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar Darloup » 25 Fév 2021 à 02:26

Bonjour On Stage et Steph,

Merci à vous deux de m'avoir confirmé que la version 1.3.7 de Contact Admin fonctionne bien avec phpBB 3.3.3.

Non, je n'avais pas (encore) modifié les fichiers de langue. J'installe toujours les extensions avec leurs fichiers originaux de langue et je m'assure ensuite qu'elle fonctionne correctement avant d'ajouter mes propres fichiers de langue.

Mais comme le problème est peut-être lié au message d'erreur que j'ai actuellement sur mon PCA (default_charset), je vais résoudre ce problème avant le la réinstaller.
Avatar de l’utilisateur
Darloup
Traducteur
Traducteur
 
Messages: 613
Enregistré le: 14 Mar 2009 à 20:49
Localisation: Barranquilla (Colombie)

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar On Stage » 25 Fév 2021 à 08:15

Salut
Pourquoi vouloir modifier les fichiers de langue alors que la traduction française est ici : https://www.phpbb.com/customise/db/exte ... 91#p789491

Et oui une traduction mal faite peut causer un bogue de l'extension.
Version de phpBB : 3.3.3
Version de php : 8.0.2
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 888
Enregistré le: 19 Mar 2018 à 16:04

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar stone23 » 25 Fév 2021 à 13:02

Salut,
Tout à fait d'accord, On Stage, ça peut même amener certains bogues sur le forum lui-même, j'ai déjà eu le cas...
Forum d'enCreuse.net
Version forum : 3.3.3
Version php : 8.0.2
Avatar de l’utilisateur
stone23
Maître-posteur
Maître-posteur
 
Messages: 453
Enregistré le: 31 Mai 2008 à 12:50
Localisation: Entre la chaise et le clavier

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar Darloup » 25 Fév 2021 à 14:27

Bonjour,
On Stage a écrit:Pourquoi vouloir modifier les fichiers de langue alors que la traduction française est ici : https://www.phpbb.com/customise/db/exte ... 91#p789491

Par ce que ce n'est pas uniquement le français dont j'ai besoin !
Avatar de l’utilisateur
Darloup
Traducteur
Traducteur
 
Messages: 613
Enregistré le: 14 Mar 2009 à 20:49
Localisation: Barranquilla (Colombie)

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar On Stage » 25 Fév 2021 à 15:28

C'est vrai, regarde dans la discussion tu y trouveras plusieurs fichiers de traductions, notamment l'espagnol.
Version de phpBB : 3.3.3
Version de php : 8.0.2
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 888
Enregistré le: 19 Mar 2018 à 16:04

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar Darloup » 25 Fév 2021 à 17:18

Je n'utilise pas l'espagnol castillan (castellano), mais la version de l'espagnol tel que parlé en Colombie qui est très différente du castillan. D'où le besoin de faire mes propres traductions.
Avatar de l’utilisateur
Darloup
Traducteur
Traducteur
 
Messages: 613
Enregistré le: 14 Mar 2009 à 20:49
Localisation: Barranquilla (Colombie)

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar Steph » 25 Fév 2021 à 17:29

Salut,

Cela commence a tourné vers le hors sujet, je me permets donc de signaler que nous ne sommes plus sur le but initial de celui-ci. On Stage merci de ne pas dévier sur ce qui n'est pas demandé, à la limite si cela peut aider, mais alors inutile d'insister, si nous demandons un sujet par demande différente et par auteur c'est aussi pour éviter de se retrouver avec un sujet fourre-tout.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20825
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar stone23 » 25 Fév 2021 à 18:33

Salut,
C'est l'extension de phpBB.com que tu essaye d'activer ?
Apparemment il y a eu des fichiers modifiés récemment ici : https://github.com/rmcgirr83/contactadmin
Forum d'enCreuse.net
Version forum : 3.3.3
Version php : 8.0.2
Avatar de l’utilisateur
stone23
Maître-posteur
Maître-posteur
 
Messages: 453
Enregistré le: 31 Mai 2008 à 12:50
Localisation: Entre la chaise et le clavier

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar Darloup » 27 Fév 2021 à 03:14

Hola stone23,

stone23 a écrit:C'est l'extension de phpBB.com que tu essaye d'activer ?
Apparemment il y a eu des fichiers modifiés récemment ici : https://github.com/rmcgirr83/contactadmin

Merci pour le tuyau !

J'ai vérifié les modifs sur GitHub et il semblerait qu'ils soit pour la version 1.3.7 qui a maintenant été mise à disposition.

Par contre, je l'ai installée et je viens d'essayer de l'activer, et j'ai toujours un message d'erreur (bien que différent cette fois-ci) :

Un problème a été rencontré durant l’opération de mise à jour de la base de données. Les modifications déjà appliquées ont été annulées du mieux possible, veuillez vérifier que votre forum ne comporte pas d’erreur.

Un module porte déjà ce nom : ACP_CAT_CONTACTADMIN

Retourner à la liste des extensions


Est-ce dû au fait que cette extension est pour phpBB 3.3.2 et non pas 3.3.3 (que j'utilise) ?

Est-ce dû au fait que j'avais déjà essayé d'installer cette extension il y a quelques semaines ?

Est-ce un autre problème ?

J'ai également signalé ce message d'erreur sur phpBB.com : https://www.phpbb.com/customise/db/exte ... 21#p799921
Avatar de l’utilisateur
Darloup
Traducteur
Traducteur
 
Messages: 613
Enregistré le: 14 Mar 2009 à 20:49
Localisation: Barranquilla (Colombie)

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar On Stage » 27 Fév 2021 à 09:15

Salut
Sauf à devoir répéter, cette extension en version 1.3.7 est bien compatible phpBB 3.3.3

Tout d'abord fait une sauvegarde de ta BDD
Ensuite via phpMyAdmin il faut aller supprimer cette ligne ACP_CAT_CONTACTADMIN dans la table phpbb_modules (remplacer phpbb_ par ton préfixe de table)

Ensuite vider le cache et installer l'extension.
Version de phpBB : 3.3.3
Version de php : 8.0.2
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 888
Enregistré le: 19 Mar 2018 à 16:04

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar stone23 » 27 Fév 2021 à 11:21

Salut,
J'ajouterai que, personnellement, j'ai désactivé la page de contact du forum (onglet général/paramètres de la page de contact). Mais je crois que quand l'extension est activée, cela annule ces paramètres... :roll:
Forum d'enCreuse.net
Version forum : 3.3.3
Version php : 8.0.2
Avatar de l’utilisateur
stone23
Maître-posteur
Maître-posteur
 
Messages: 453
Enregistré le: 31 Mai 2008 à 12:50
Localisation: Entre la chaise et le clavier

Re: Contact Admin version 1.3.7 Je n'arrive pas à activer l'extension

Messagepar On Stage » 27 Fév 2021 à 11:24

Oui l'extension prend le dessus sur la page de contact en natif dans phpBB.
Version de phpBB : 3.3.3
Version de php : 8.0.2
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 888
Enregistré le: 19 Mar 2018 à 16:04

Suivante

Retourner vers Support des extensions non présentes dans notre base de données

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité