[Réglé] déconnection continuel

Forum de support pour les questions concernant l'utilisation de phpBB 3.3, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] déconnection continuel

Messagepar Manoeuvre » 18 Fév 2021 à 15:55

Bonjour a tous,

Ce n'est pas le 1er forum que je créé (j'en ai créé quelques uns pour des copains) et là j'en fait un pour Bibi et c'est la cata.

L'install c'est (bien) passé.

1) impossible de s'inscrire sur le forum, message d'erreur :

Fatal error: Uncaught ValueError: The arguments array must contain 2 items, 1 given in /homepages/15/d322242026/htdocs/clickandbuilds/phpBB/Passionnement/phpbb/language/language.php:313 Stack trace: #0 /homepages/15/d322242026/htdocs/clickandbuilds/phpBB/Passionnement/phpbb/language/language.php(313): vsprintf('Doit \xC3\xAAtre comp...', Array) #1 /homepages/15/d322242026/htdocs/clickandbuilds/phpBB/Passionnement/phpbb/language/language.php(245): phpbb\language\language->lang_array('PASS_TYPE_ANY_E...', Array) #2 [internal function]: phpbb\language\language->lang('PASS_TYPE_ANY_E...', '6 caract\xC3\xA8res') #3 /homepages/15/d322242026/htdocs/clickandbuilds/phpBB/Passionnement/phpbb/user.php(462): call_user_func_array(Array, Array) #4 /homepages/15/d322242026/htdocs/clickandbuilds/phpBB/Passionnement/includes/ucp/ucp_register.php(644): phpbb\user->lang('PASS_TYPE_ANY_E...', '6 caract\xC3\xA8res') #5 /homepages/15/d322242026/htdocs/clickandbuilds/phpBB/Passionnement/includes/functions_module.php(676): ucp_register->main('register', NULL) #6 /homepages/15/d322242026/htdocs/clickandbuilds/phpBB/Passionnement/includes/functions_module.php(1006): p_master->load_active(false) #7 /homepages/15/d322242026/htdocs/clickandbuilds/phpBB/Passionnement/ucp.php(78): p_master->load('ucp', 'ucp_register') #8 {main} thrown in /homepages/15/d322242026/htdocs/clickandbuilds/phpBB/Passionnement/phpbb/language/language.php on line 313


Ensuite, en tant qu'admin, déconnection continuel. impossible de faire quoi que ce soit sur le PA je suis déconnecté tout le temps.

Cela ne viens pas du navigateur, je suis sur Mac avec Safari et j'ai testé sur un pc Windows avec IE et firefox même problème.

Un amis a essayé de s'inscrire, nada.

Je sèche.



Le lien du forum (ne pas rire sur l'adresse stp) http://docs.lyly45.fr

Hébergeur Ionos, pour l'installation j'ai utilisé le logiciel fournis par Ionos snon installation impossible.

Les gâteaux américain :

domaine ".lyly45.fr"
noms "phpbb3_kesib"
Chemin "/"
sécurité "désactivé"
Notice "désactivé"

Merci d'avance pour votre aide.
Modifié en dernier par Manoeuvre le 19 Fév 2021 à 13:50, modifié 2 fois.
Manoeuvre
Posteur néophyte
Posteur néophyte
 
Messages: 13
Enregistré le: 01 Jan 2021 à 12:02

Re: Que de problèmes avec phpBB

Messagepar On Stage » 18 Fév 2021 à 16:07

Salut
Ton problème vient de là : "pour l'installation j'ai utilisé le logiciel fournis par Ionos snon installation impossible."

Le mieux est de remplacer tous les fichiers et dossier du core de phpBB en utilisant ceux du pack complet disponible sur la page de téléchargement de ce forum.

Le seul fichier qu'il faut absolument conserver est le fichier config.php
Avant de faire le remplacement de fichiers met ton forum en maintenance.
Version de phpBB : 3.3.3
Version de php : 8.0.2
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 871
Enregistré le: 19 Mar 2018 à 16:04

Re: Que de problèmes avec phpBB

Messagepar Manoeuvre » 18 Fév 2021 à 16:11

Merci, je test et je .... reviens.
Manoeuvre
Posteur néophyte
Posteur néophyte
 
Messages: 13
Enregistré le: 01 Jan 2021 à 12:02

Re: Merci de modifier le titre du sujet afin qu'il soit plus explicite.

Messagepar Steph » 18 Fév 2021 à 16:32

Salut,

Merci de mettre un titre de sujet explicite et en adéquation avec la demande, les titres fourre-tout n'aident pas à comprendre le sujet ni même les recherches futures.

Partant du principe de la demande, toutes les questions sont potentiellement des "problèmes" donc inutile de l'indiquer en titre de sujet, ce n'est pas explicite, mais un constat.

Aussi c'est un sujet par demande différente et par auteur.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20815
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: déconnection continuel

Messagepar Manoeuvre » 18 Fév 2021 à 17:05

Oups désolé.

J'ai fait ce qui m'a été conseillé.

le forum paraît plus rapide, mais j'ai toujours ce problème de déconnection après 30 ou 40 s environs. Ce qui fait que pour paramétrer quelque chose dans le PA c'est la galère.

Pour les inscriptions mon amis a réussi la sienne. C'est donc bon de ce coté là.
Manoeuvre
Posteur néophyte
Posteur néophyte
 
Messages: 13
Enregistré le: 01 Jan 2021 à 12:02

Re: déconnection continuel

Messagepar Steph » 18 Fév 2021 à 17:06

Cela semble être un souci lié aux cookies.

À lire et à tester : message1675550.html?hilit=cookies#p1675550

Pour ton cookie, le domaine doit être .docs.lyly45.fr (pour ton cas)

Ensuite il faut supprimer le répertoire production qui se trouve dans cache sur le FTP. Le répertoire production se recréeras tout seul et c'est normal.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20815
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: déconnection continuel

Messagepar Manoeuvre » 18 Fév 2021 à 17:39

Donc, j'ai fait cela et effectivement le dossier c'est re créé tout seul.

Toujours le même problème.

J'ai essayé avec firefox et là impossible de se connecter au forum (formulaire non valide).

alors que mon amis lui passe tranquille.

phpBB serait anti Fibre ou Freebox ??? mdr

Non, sans blague. C'est la première fois que je galère ainsi.
Manoeuvre
Posteur néophyte
Posteur néophyte
 
Messages: 13
Enregistré le: 01 Jan 2021 à 12:02

Re: déconnection continuel

Messagepar Steph » 18 Fév 2021 à 18:00

Tu as bien modifié le nom du cookie ? Si c'est le même, cela ne forcera pas la nouvelle connexion.

Et en vidant la table session ?

Dans phpMyAdmin (phpbb_ à remplacer par ce que tu as mis)

Code: Tout sélectionner
TRUNCATE phpbb_sessions


Vide le cache du forum comme précédemment et réessaie.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20815
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: déconnection continuel

Messagepar On Stage » 18 Fév 2021 à 18:22

Tente de te connecter au forum avec un autre navigateur, ou alors avec Firefox mais en connexion privée
Version de phpBB : 3.3.3
Version de php : 8.0.2
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 871
Enregistré le: 19 Mar 2018 à 16:04

Re: déconnection continuel

Messagepar Manoeuvre » 19 Fév 2021 à 08:21

Bonjour a tous.

Alors voilà le topo, restez assis ça vaut son pesant de cacahouètes.

Hier soir, involontairement, j'ai laissé la page de navigation sur le forum ouverte et mis le Mac en veille.

Ce matin, je lis vos message ici, me dit ok j'ai du taff et je vais sur l'onglet du forum. Et là, tout se passe bien, plus de déconnection.

Je me dit yess, il c'est passé un truc cette nuit.

Tout content, je part au boulot.

Sur l'iMac du boulot, je me connecte au forum (pour voir) et là plouf ça recommence à déconnecter. Je laisse la page du forum ouverte et je passe a autre chose pendant 10 mn et je reviens sur le forum. Et là, tiens, pas de déconnection.

Mon temps de connexion au PA serait-il en relation avec le temps passé connecté sur le forum ?

Pour répondre a Steph :

J'ai bien changé le noms du cookies comme tu me l'avais dit (sinon ce n'est pas la peine de demander de l'aide si on ne fait pas ce qui est demandé :D )

Je n'ai pas encore fait les deux derniers conseils (ceux de 18h00 et 18h22).

:roll:
Manoeuvre
Posteur néophyte
Posteur néophyte
 
Messages: 13
Enregistré le: 01 Jan 2021 à 12:02

Re: déconnection continuel

Messagepar Manoeuvre » 19 Fév 2021 à 13:50

Re-bonjour a tous.

Le problème est revenu ce matin en force.

3 déconnections par minutes.

Un vrais galère.

J'ai appelé un copain, qui comme moies chez Ionos et avec Free comme opérateur. Et le constat est tombé. Il n'a jamais réussi a avoir quelques chose de stable chez Ionos.

Il a appelé la hot line plusieurs fois et c'est toujours resté problématique.

Je vais donc laisser tomber phpBB sur Ionos pour installer phpBB sur mon serveur perso.

Je vous remercie tous pour le temps que vous avez passé a essayer de me trouver une solution.

A Bientôt.
Manoeuvre
Posteur néophyte
Posteur néophyte
 
Messages: 13
Enregistré le: 01 Jan 2021 à 12:02

Re: déconnection continuel

Messagepar On Stage » 19 Fév 2021 à 14:54

Salut
À toutes fins utiles, j'ai un forum hébergé chez IONOS et je peut te certifier que je ne rencontre pas de genre de problème.
Ton problème vient probablement de ta configuration des cookies, comme Steph le dit. De plus chez IONOS tu peux utiliser sans problème une configuration HTTPS
Version de phpBB : 3.3.3
Version de php : 8.0.2
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 871
Enregistré le: 19 Mar 2018 à 16:04

Re: déconnection continuel

Messagepar Manoeuvre » 19 Fév 2021 à 15:46

J'ai un abonnement PRO (comme mon pote) et la sécurité pour les sites web ainsi que pour les boites mail est plus fort que pour les abonnements privé.

Peut être est-ce là que ça beug.

Là j'ai refait l'installation sur mon serveur perso, et comme d'ab, ça fonctionne a merveille du premier coup. Un vrais bonheur.
Manoeuvre
Posteur néophyte
Posteur néophyte
 
Messages: 13
Enregistré le: 01 Jan 2021 à 12:02

Re: déconnection continuel

Messagepar On Stage » 19 Fév 2021 à 16:14

Si tu es ravi c'est bien là le principal.
Version de phpBB : 3.3.3
Version de php : 8.0.2
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 871
Enregistré le: 19 Mar 2018 à 16:04

Re: déconnection continuel

Messagepar Steph » 19 Fév 2021 à 16:30

Merci de ne faire des UPs que toutes les 24 heures minimum !

Vu que tu as un accès HTTPS, le souci peut aussi venir de là, il faut alors forcer le forum en HTTPS, regarde ici : support-utilisation-phpbb33/sujet214328.html#p1674711
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20815
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France


Retourner vers Utilisation

Qui est en ligne

Utilisateurs parcourant ce forum : cocooncrash et 1 invité