Modification du .htaccess ne fonctionne pas pour passer en https://

Forum de support pour les questions concernant l'utilisation de phpBB 3.3, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Re: Modification du .htaccess ne fonctionne pas pour passer en https://

Messagepar Steph » 28 Déc 2020 à 22:09

Plusieurs choses,

  • Ton forum devrait effectivement se trouver à la racine, donc http://sas.raf38group.org/ et non http://sas.raf38group.org/forum/, à moins d'avoir un site a la base. Pour le transférer c'est assez simple, mais ce n'est pas le sujet
  • Sur ce forum il faut être patient et ne pas répondre à un sujet en moins de 24 h sauf si un autre membre à répondu entre temps. Dans le cas contraire il faut utiliser le bouton "Modifier" au lieu de "Répondre". Merci de ne faire des UPs que toutes les 24 heures minimum !
  • Je confirme que la redirection htaccess doit se trouver à la racine et non dans forum, cependant plusieurs htaccess (en fonction de leurs contenus) peuvent être problématique et source de conflit
  • Le code donné par OnStage est faux (surement un mauvais copié collé)

    Il faut mettre (a la racine)

    Code: Tout sélectionner
    RewriteEngine On
    RewriteCond %{HTTP:HTTPS} !on
    RewriteRule (.*) https://%{SERVER_NAME}/$1 [QSA,L,R=301]
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20685
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Modification du .htaccess ne fonctionne pas pour passer en https://

Messagepar NobruL » 28 Déc 2020 à 23:08

Steph a écrit:Pour le transférer c'est assez simple, mais ce n'est pas le sujet

:arrow: Non, c'est simple pour toi ! Tout le monde ne sait pas le faire. C'est pourquoi on vient ici !

J'ai vu la page pour transférer un forum chez un autre hébergeur mais je voudrais savoir si ce sont les mêmes manips pour transférer d'un sous-domaine à un domaine vu que je ne changerai pas d'hébergeur.
Ca résoudrait le problème des 2 fichiers htaccess.
S'il le faut j'ouvrirai un autre sujet sur le transfert.
Merci d'avance.
NobruL
Posteur néophyte
Posteur néophyte
 
Messages: 9
Enregistré le: 27 Déc 2020 à 11:25

Re: Modification du .htaccess ne fonctionne pas pour passer en https://

Messagepar Steph » 28 Déc 2020 à 23:27

Autre demande, autre sujet, mais c'est pareil que dans la doc
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20685
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Modification du .htaccess ne fonctionne pas pour passer en https://

Messagepar On Stage » 29 Déc 2020 à 15:25

Salut Steph
Non pas d'erreur c'est ce que préconise l'hébergeur.

Mais à ce sujet, y'a t-il vraiment une règle pour une redirection HTTPS ?
Sur mon forum, dans le .htaccess je situe cette ligne :
Code: Tout sélectionner
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]


Et je colle à la suite ceci :
Code: Tout sélectionner
# Redirect to HTTPS
RewriteCond %{HTTPS} off
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]


Et avec l'URL en HTTP on arrive bien sur le forum en HTTPS
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 758
Enregistré le: 19 Mar 2018 à 16:04

Re: Modification du .htaccess ne fonctionne pas pour passer en https://

Messagepar Steph » 29 Déc 2020 à 16:09

C'est pas dramatique, mais regarde bien ton message ici le code indiqué est pour l'inverse de ce qui est voulu : support-utilisation-phpbb33/sujet214439.html?#p1675484
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20685
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Modification du .htaccess ne fonctionne pas pour passer en https://

Messagepar On Stage » 29 Déc 2020 à 16:13

Arf oui !
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 758
Enregistré le: 19 Mar 2018 à 16:04

Re: Modification du .htaccess ne fonctionne pas pour passer en https://

Messagepar Steph » 29 Déc 2020 à 16:15

:mrgreen: cela m'arrive aussi, t'inquiète.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20685
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Précédente

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité