bug d'inscription apres une nouvelle installation

Forum de support pour les questions concernant l'utilisation de phpBB 3.3, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

bug d'inscription apres une nouvelle installation

Messagepar zimeau » 09 Avr 2020 à 15:00

Bonjour,

J'utilise phpbb3.3.0 qui fonctionne correctement pour ma communauté et souhaitant faire des test, j'ai installé une version test dans un autre dossier sur le même serveur (web et bdd avec un prefix différent pour ce forum de test). j'ai fait une installation avec la version de phpbb de base, aucune modification, seulement une installation et lorsque j'essaye d'inscrire un nouvel utilisateur, lorsque j'essaye d'accepter les terme d'utilisation, la page des terme recharge et je n'arrive pas à aller plus loin. seul le sid dans l'url de la page change. si je refuse les terme, je reviens sur la page principal du forum.
je ne peu plus non plus me logger avec le seul identifiant creer à l'installation, j'ai le message "The submitted form was invalid. Try submitting again."
qu'est ce qui peut provoquer ce problème? est ce que l'installation sur un serveur qui possède déjà un phpbb, même si c'est dans un autre dossier et avec un autre prefix dans la bdd poserais le problème? je dois malheureusement travailler sur le même serveur, avec la même base de donnée pour mes test... est ce que c'est possible?
j'ai pourtant 3 phpbb différent sur mon serveur local sans que ça pose de soucis...
Modifié en dernier par zimeau le 09 Avr 2020 à 16:28, modifié 1 fois.
zimeau
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 15 Mai 2013 à 00:58

Re: bug d'inscription apres une nouvelle installation

Messagepar On Stage » 09 Avr 2020 à 16:08

Salut
Si tu veux vraiment faire des tests le mieux est de les faire en local avec Wamp
Avatar de l’utilisateur
On Stage
Maître-posteur
Maître-posteur
 
Messages: 455
Enregistré le: 19 Mar 2018 à 17:04

Re: bug d'inscription apres une nouvelle installation

Messagepar zimeau » 09 Avr 2020 à 16:41

bon j'ai trouvé mon probleme en fait : les cookies. par défaut, les Cookie sécurisé sont activé, en les desactivant je n'ai plus eu le problème. faudrait que je comprenne pourquoi ça marche pas en sécurisé mais je verrais ça plus tard.

EDIT : je viens de me rendre compte qu'en fait, ce n'est pas la configuration des cookies le problème. j'ai réussis à me reconnecter et à faire une inscription en ouvrant une nouvelle session sur mon navigateur (j'utilise multi-account container pour firefox, mais ça reviens un peu a ouvrir une fenêtre de navigation privé dans ma situation). et dans cette nouvelle session, j'arrive à me connecter ou à creer un nouvel utilisateur (je reste pas bloqué sur la page des terme d'utilisation). du coup je sais pas encore ce qui pose le probleme sur ma session... mais changer de session permet de reprendre la main.
On Stage a écrit:Salut
Si tu veux vraiment faire des tests le mieux est de les faire en local avec Wamp

c'est ce que je fait habituellement. mais là j'ai un soucis sur un plugin qui ne se produit que sur le serveur de production, pas sur mon serveur local malgré que ce soit exactement les mêmes fichiers, la même base de données (enfin des copies de sauvegarde évidement) et la même version de php. du coup vu que j'ai exactement tout identique sur mon serveur de prod et mon serveur de test, je suppose que seul le serveur peut être la cause du problème, faut que j'essaye de voir d'ou vient le problème sur le serveur de prod, mais dans un dossier de test et sur des tables de test. le soucis est que lorsque j'installe une version neuve de phpbb dans le dossier de test avec ce plugin, ça semble fonctionner. je dois donc chercher d'ou fient le problème, si c'est un problème de template, un problème de données, etc...
j'ai posté le problème directement au createur du plugin du coup je post pas ici mais si il y en a des personnes qui veulent creuser, c'est avec le pulgin kalendar (ou calendar en anglais) 1.0.3, lorsqu'un evenement est ajouté dans le calendrier et que quelqu'un s'inscrit à l'evenement, rien ne se passe (pas de message d'erreur, rien, juste la page qui reload). sur mon serveur local, aucun soucis, les utilisateurs peuvent s'inscrire à l'evenement. mais bon maintenant que j'ai un serveur de test fonctionnel, je vais creuser pour trouver d'ou vient le probleme ^^ mais vos suggestion sont bienvenue.
zimeau
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 15 Mai 2013 à 00:58

Re: bug d'inscription apres une nouvelle installation

Messagepar SpyFlash » 10 Avr 2020 à 18:30

J'ai un soucis quasiment identique à savoir que moi je peux accéder aux champs pour s'enregistré mais quand je submit l'envoie des données je retourne sur la page de validation des conditions d'utilisation au lieu d'accéder à la page m'indiquant que l'utilisateur a bien été enregistré et qu'un mail a été envoyé à celui-ci.

J'ai vérifié l'intégralité de la configuration pbpBB et ça ne viendrait pas de là, je penche également pour un pb côté serveur/hebergeur notamment pour le dossier sessions ou php.ini (genre chez free de mémoire faut créer le dossier sessions à la racine par exemple)
SpyFlash
Posteur néophyte
Posteur néophyte
 
Messages: 4
Enregistré le: 10 Avr 2020 à 18:19

Re: bug d'inscription apres une nouvelle installation

Messagepar cocooncrash » 11 Avr 2020 à 08:20

Spyflash,
Merci d'ouvrir votre propre sujet.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 8119
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité