[Réglé] Lenteur index du forum

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Lenteur index du forum

Messagepar thierry92 » 18 Avr 2020 à 10:59

Bonjour a tous,

Sur le forum http://www.patrol-gr.fr je rencontre des problèmes de lenteur depuis pas mal de temps et cela va de moins en moins bien.

Lorsque je j'ouvre la page d'index, que je sois sur sur n’importe quel navigateur et que je sois en "se souvenir de moi" ou pas, la page s'ouvre mais ou bout d'un temps .... Vérifiez par vous même.

Une fois la page d'index du forum ouverte la navigation est plutôt rapide. En revanche dès que l'on veut revenir sur la page de l'index du forum ça recommence.

Le forum était en version V3.2.0 lorsque cela a commencé. J'ai doc mis a jour avec la version V3.2.9 => mais le problème persiste.

J'ai aussi désactivé toutes les extensions et tous les styles => mais le problème persiste. (actuellement en Prosilver)

J'ai demandé a notre hébergeur de changer la mémoire qui semblait montrer des signes de fatigue => mais le problème persiste.

J'ai installé un autre forum en // pour tester si cela venait du serveur http://www.patrol-gr.fr/PatrolTest/inde ... ad8ff53443 Ce site fonctionne correctement => mais le problème persiste.

Il y aussi un autre forum sur ce serveur ou il n'y a pas de problème de lenteur http://www.bivouac4x4.net (qui n'est pas jour)

J'avoue que je ne sais plus quoi faire !!!!!

Merci pour votre aide

Thierry
Modifié en dernier par thierry92 le 19 Avr 2020 à 17:24, modifié 1 fois.
thierry92
Apprenti-posteur
Apprenti-posteur
 
Messages: 157
Enregistré le: 06 Mar 2015 à 00:24

Re: Lenteur index du forum

Messagepar pierredu » 19 Avr 2020 à 08:02

On dirait que le forum recalcule le cache dans son intégralité.
Tu as bien des droits d'écriture sur ce dossier ?
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1420
Enregistré le: 29 Mai 2011 à 05:49
Localisation: Paris

Re: Lenteur index du forum

Messagepar thierry92 » 19 Avr 2020 à 10:16

Merci pour ton aide

Le répertoire "cache" => 0777

Dans le répertoire "cache"
Les répertoires "installer" - "production" et "twing" => 0755

La plus part des fichiers sont en 0666
sauf quelques uns comme "index.htm" => 0644

Je peux détailler si besoin
thierry92
Apprenti-posteur
Apprenti-posteur
 
Messages: 157
Enregistré le: 06 Mar 2015 à 00:24

Re: Lenteur index du forum

Messagepar Skouat » 19 Avr 2020 à 10:37

Bonjour,

Dans le répertoire cache supprimez tous les fichiers et répertoire présents SAUF .htaccess et index.htm.

Si vous voyez à nouveau des fichiers se créer à la racine du forum, alors ce n'est pas normal, car depuis 3.1, les fichiers mis en cache sont créés dans le répertoire "production".

Au passage vous avez mentionné une mise à niveau de 3.1 vers 3.2.
Vous avez oubliez de mettre à jour le pack de langue. ce dernier est toujours en 3.1 :roll:
Donc, partant de là, qu'est qui certifie qu'il n'y aurait pas d'autres fichiers non mis à jour ?

Concernant le forum de test, il y a pas de problème de chargement.
Skouat
Resp. Traducteurs
Resp. Traducteurs
 
Messages: 14773
Enregistré le: 02 Avr 2008 à 19:47

Re: Lenteur index du forum

Messagepar thierry92 » 19 Avr 2020 à 11:24

Que je comprennes bien :

Dans le répertoire "cache" j'efface les 3 répertoires "installer" " production" "twig"
et j’efface tous les fichiers sauf htaccess et index.htm.

Je vais le faire si c'est bien ça mais je trouve bien le fichier index.htm mais je ne trouve pas de fichier htaccess

Concernant la pack de langue ,je vais le faire de suite
thierry92
Apprenti-posteur
Apprenti-posteur
 
Messages: 157
Enregistré le: 06 Mar 2015 à 00:24

Re: Lenteur index du forum

Messagepar Sylveretour » 19 Avr 2020 à 12:19

Bonjour,

Concernant la pack de langue ,je vais le faire de suite

Relis bien la phrase de Skouat :
Donc, partant de là, qu'est qui certifie qu'il n'y aurait pas d'autres fichiers non mis à jour ?

Donc renvoie tous les fichiers du core de phpBB car ce n'est certainement pas le seul oubli.

Puis, pour tracer les erreurs, ouvre le fichier config/production/config.yml
Remplace le contenu du fichier par :
Code: Tout sélectionner
imports:
    - { resource: ../default/config.yml }

parameters:
    debug.load_time: true
    debug.sql_explain: true
    debug.memory: true
    debug.show_errors: true
    debug.exceptions: true

Puis vide le cache pour faire prendre en compte la modification.
Avatar de l’utilisateur
Sylveretour
Floodeur mature
Floodeur mature
 
Messages: 1688
Enregistré le: 21 Nov 2017 à 18:24
Localisation: West Coast

Re: Lenteur index du forum

Messagepar thierry92 » 19 Avr 2020 à 12:40

Sylveretour a écrit:Donc renvoie tous les fichiers du core de phpBB car ce n'est certainement pas le seul oubli.


Ça été fait lors de la mise a jour, j'ai téléchargé un fichier nommer "update_archive_1587096059_5e9929fb0f6a0"

Sylveretour a écrit:Puis, pour tracer les erreurs, ouvre le fichier config/production/config.yml
Remplace le contenu du fichier par :
Code: Tout sélectionner
imports:
    - { resource: ../default/config.yml }

parameters:
    debug.load_time: true
    debug.sql_explain: true
    debug.memory: true
    debug.show_errors: true
    debug.exceptions: true

Puis vide le cache pour faire prendre en compte la modification.


Je viens de le faire mais ça ne change rien
thierry92
Apprenti-posteur
Apprenti-posteur
 
Messages: 157
Enregistré le: 06 Mar 2015 à 00:24

Re: Lenteur index du forum

Messagepar On Stage » 19 Avr 2020 à 12:48

Salut
Tu parles d'un fichier nommé "update" lors de la mise à jour

La seule façon fiable de faire une mise à jour est selon cette méthode : documentation/mise-a-jour/mise-a-niveau-de-phpbb-32x-vers-33x-a248-view.html
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 771
Enregistré le: 19 Mar 2018 à 16:04

Re: Lenteur index du forum

Messagepar thierry92 » 19 Avr 2020 à 12:55

Lors de la mise a jour,

J'ai télécharger le pack que j'ai décompresser et j'ai lancer l'install
après avoir modifier certains fichier en écriture, la BdD a été mis a jour
puis il m'a été demandé de télécharger ce fichier zip et de l'extraire sur le serveur. Et c'est ce que j'ai fais

Puis d'effacer le répertoire install

Mais comme dis dans mon premier message, le problème était déjà présent avec l'ancienne version.

Mais je viens de me rendre compte que je n'ai pas fait la manip 9 qui est d'effacer des fichiers

Mais je ne peux pas passer V3.3.X car ma version de PHP n'est pas celle demandée
thierry92
Apprenti-posteur
Apprenti-posteur
 
Messages: 157
Enregistré le: 06 Mar 2015 à 00:24

Re: Lenteur index du forum

Messagepar Skouat » 19 Avr 2020 à 14:58

Hello,

Si on relis bien ce que tu décris, le problème est apparue lors de la mise en place de 3.2.0
Donc on ne te parle pas de la mise à jour de 3.2.0 -> 3.2.9, mais 3.1.x -> 3.2.0

Comme indiqué précédemment, il a été constaté que tu n'avais pas mis à jour le pack de langue (car il était toujours en 3.1.x)
Donc il en est peut-être de même pour les fichiers de base de phpBB.

Donc récupère l'archive de phpBB Complète (pas la mise à jour).
Et effectue les étapes 6 à 10 de la doc de mise à niveau
Evidemment, récupère l'archive 3.2.9 de phpBB ;)
Skouat
Resp. Traducteurs
Resp. Traducteurs
 
Messages: 14773
Enregistré le: 02 Avr 2008 à 19:47

Re: Lenteur index du forum

Messagepar thierry92 » 19 Avr 2020 à 16:15

Skouat a écrit:Hello,

Si on relis bien ce que tu décris, le problème est apparue lors de la mise en place de 3.2.0
Donc on ne te parle pas de la mise à jour de 3.2.0 -> 3.2.9, mais 3.1.x -> 3.2.0


Non c'est arrivé pendant que la version V3.2.0 était en cours.Le forum est dans cette version depuis longtemps. Le problème ne c'est pas déclencher pendant une mise a jour

Skouat a écrit:Comme indiqué précédemment, il a été constaté que tu n'avais pas mis à jour le pack de langue (car il était toujours en 3.1.x)
Donc il en est peut-être de même pour les fichiers de base de phpBB.

Donc récupère l'archive de phpBB Complète (pas la mise à jour).
Et effectue les étapes 6 à 10 de la doc de mise à niveau
Evidemment, récupère l'archive 3.2.9 de phpBB ;)


Ok je fais ça ce soir


Réédition a 18h23

J'ai fais la manip et tout refonctionne pour le moment en style par défaut

MERCI a tous :D :D
Modifié en dernier par thierry92 le 19 Avr 2020 à 17:23, modifié 1 fois.
thierry92
Apprenti-posteur
Apprenti-posteur
 
Messages: 157
Enregistré le: 06 Mar 2015 à 00:24

Re: Lenteur index du forum

Messagepar Skouat » 19 Avr 2020 à 17:23

Une fois les fichiers remplacés et si le pb persistes, il faut aller voir dans le répertoire cache si tout les fichiers de cache se mettent bien dans le répertoire production (ce qui devrait être le cas).

Maintenant qu'on est sûr que le problème n'est plus liés aux fichiers, il faut regarder côté BDD.
Dans le PCA>Général> Paramètres de charge, il faut s'assurer que l'option "Recompiler les différents éléments du style" est bien définie à NON.

Il faudrait aussi vérifier dans le fichier config.php que le ligne // @define('DEBUG_CONTAINER', true); est bien commentée.
Skouat
Resp. Traducteurs
Resp. Traducteurs
 
Messages: 14773
Enregistré le: 02 Avr 2008 à 19:47

Re: Lenteur index du forum

Messagepar thierry92 » 19 Avr 2020 à 18:21

Merci Skouat,

Je viens de vérifier le tout et tout est OK et tout est rentré dans l'ordre !!!!

J'ai commencé à m'attaquer au style mais je ne maitrise pas les fichier SVG encore ... Cela fera l'objet d'un nouveau sujet si je n'y arrive pas

J'ai éditer mon premier post

Merci a tous
thierry92
Apprenti-posteur
Apprenti-posteur
 
Messages: 157
Enregistré le: 06 Mar 2015 à 00:24


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité