[Réglé] Depuis la mise a niveau a phpBB 3.2.8, les membres ne voient "aucun forum"

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Depuis la mise a niveau a phpBB 3.2.8, les membres ne voient "aucun forum"

Messagepar Fonck1 » 22 Sep 2019 à 23:42

Bonjour,

Depuis peu, nous avons migré de 3.0.4 vers la version 3.2.8 du forum.
Depuis cette migration, certains seulement de nos membres, une fois logués,
voient s'afficher "Aucun forum" sur l'index. Or, j'ai bien réglé a nouveau
toutes les permissions des forums, des groupes, des utilisateurs et malgré tout,
certains ont toujours ce message. Auriez-vous une idée ? Je désespère
Pourriez-vous m'expliquer aussi comment les permissions sont stockées dans la base,
car j'ai plusieurs dizaines d'utilisateurs qui rencontrent ce problème, or
dans la table phpbb_users, je ne vois rien en rapport, et le champ user_permissions
reste vide, que les utilisateurs (du même groupe) ait ce problème ou non !

Merci par avance.
Modifié en dernier par Fonck1 le 23 Sep 2019 à 15:15, modifié 1 fois.
http://www.forum-actualite.com

La peur n'évite pas le danger!
Patience et longueur de temps font plus que force ni que rage. (La Fontaine)
Fonck1
Posteur néophyte
Posteur néophyte
 
Messages: 35
Enregistré le: 10 Sep 2007 à 23:08
Localisation: 34

Re: Depuis la mise a niveau a phpBB 3.2.8, les membres ne voient "aucun forum"

Messagepar Steph » 23 Sep 2019 à 06:23

Salut,

Tout d'abord j'ai modifié le titre de ton sujet car "problème" n'est pas explicite et avec un tout petit peu de réflexion le peu de changement que j'ai apporté est bien plus utile.

Pour très permissions, regarde si tes membres sont dans le groupe "Nouveaux utilisateurs enregistrés".

Ensuite, il faut vérifier qu'une des permissions affectée a l'un des groupes ou le membre se trouve ne soit pas sur "Jamais".

Pour tous ces réglages, créé un compte test que tu place dans le groupe souhaité.

Je suggère fortement l'utilisation des permissions par groupes forums qui sera beaucoup plus simple a maintenir que utilisateurs forums.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20812
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Depuis la mise a niveau a phpBB 3.2.8, les membres ne voient "aucun forum"

Messagepar Fonck1 » 23 Sep 2019 à 10:28

Bonjour,
Je pense avoir trouvé ou tout au moins isolé le problème, les utilisateurs qui ont le problème de visibilité des forums ne sont assignés à aucun groupe, probablement une modif de l'ancienne BDD qui ne s'est pas réactualisée .
Ce qui est curieux c'est que certains le soient d'autres non, mais c'est peut être du à des modifications de groupe, toutes les inscriptions après ces modifs ne se seraient donc pas actualisées.

Je vais classer ce sujet en résolu dès que j'ai trouvé la parade et merci de votre aide.
http://www.forum-actualite.com

La peur n'évite pas le danger!
Patience et longueur de temps font plus que force ni que rage. (La Fontaine)
Fonck1
Posteur néophyte
Posteur néophyte
 
Messages: 35
Enregistré le: 10 Sep 2007 à 23:08
Localisation: 34

Re: Depuis la mise a niveau a phpBB 3.2.8, les membres ne voient "aucun forum"

Messagepar Steph » 23 Sep 2019 à 11:55

Je ne vois qu'une chose : tu as utilisé des groupes que tu as créés et viré les utilisateurs de ceux par défaut, puis un coup de STK a supprimé ceux qui ne sont pas de base.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20812
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Depuis la mise a niveau a phpBB 3.2.8, les membres ne voient "aucun forum"

Messagepar Fonck1 » 23 Sep 2019 à 15:15

Steph a écrit:Je ne vois qu'une chose : tu as utilisé des groupes que tu as créés et viré les utilisateurs de ceux par défaut, puis un coup de STK a supprimé ceux qui ne sont pas de base.


Oui je pense que c'est un truc comme ça. (je ne programme pas alors je comprends pas tous les termes lol)

Merci en tous ças, ça m'a obligé à chercher autrement et j'ai finis par isoler la racine du problème.

je mets donc résolu ;)
http://www.forum-actualite.com

La peur n'évite pas le danger!
Patience et longueur de temps font plus que force ni que rage. (La Fontaine)
Fonck1
Posteur néophyte
Posteur néophyte
 
Messages: 35
Enregistré le: 10 Sep 2007 à 23:08
Localisation: 34


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité