[Réglé] url ne fonctionne plus sous 3.2.7

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Re: url ne fonctionne plus sous 3.2.7

Messagepar Sylveretour » 23 Juil 2019 à 18:45

La mise à jour non conforme a peut-être fait des erreurs de maj dans la bdd.
A tu bien la version 3.2.7 indiquée dans le PCA?

En attendant, on va reparser les bbcodes.
Tu télécharge le STK ici => https://github.com/AlexSheer/phpBB3.2-STK
Tu met le tout dans un dossier stk/
D'abord, fait une sauvegarde de la bdd via phpmyadmin.
Dans l'onglet "Outils pour les administrateurs", tu trouvera "Réanalyser le BBCode", tu lance cet outil...
Modifié en dernier par Sylveretour le 23 Juil 2019 à 18:48, modifié 1 fois.
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 964
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: url ne fonctionne plus sous 3.2.7

Messagepar tomberaid » 23 Juil 2019 à 18:47

Hello
Ce que tu dis n'es pas cohérent, tu n'as pas remis tous les fichiers d'un phpBB sans modifs car on voit très bien que prosilver est modifié.
Pourtant ce que dit Sylveretour est clair !
Et si tu veux avoir ton propre style, pourquoi pas, mais ne touches pas aux fichiers de prosilver. La procédure pour créer son style a déjà été expliquée maintes fois.

Cordialement
Image
Avatar de l’utilisateur
tomberaid
Roi des posts
Roi des posts
 
Messages: 751
Enregistré le: 18 Juin 2009 à 00:27

Re: url ne fonctionne plus sous 3.2.7

Messagepar pyroshugo » 24 Juil 2019 à 11:00

Sylveretour a écrit:A tu bien la version 3.2.7 indiquée dans le PCA?
Dans l'onglet "Outils pour les administrateurs", tu trouvera "Réanalyser le BBCode", tu lance cet outil...

Bonjour,
Le PCA indique bien 3.2.7.
J'ai bien tranféré le dossier STk mais je ne trouve pas l'onglet "Outils pour les administrateurs".
Erreur : je viens de trouver où se trouve c et outil ! Je vais l'essayer. Réanalyser le BBCode effectué le problème persiste. Par contre l'utilitaire ERK indique :
Le kit de réparation d’urgence n’a trouvé aucune erreur pour l’installation de phpBB.
Warning: include(./language//common.php): failed to open stream: No such file or directory in /home/clients/90da9a520f56c8b4182e72c468444d7c/web/phpbb3.2/stk/includes/critical_repair/bom_sniffer.php on line 86

Warning: include(./language//common.php): failed to open stream: No such file or directory in /home/clients/90da9a520f56c8b4182e72c468444d7c/web/phpbb3.2/stk/includes/critical_repair/bom_sniffer.php on line 86

Warning: include(): Failed opening './language//common.php' for inclusion (include_path='.:/opt/php7.2/lib/php') in /home/clients/90da9a520f56c8b4182e72c468444d7c/web/phpbb3.2/stk/includes/critical_repair/bom_sniffer.php on line 86

Warning: include(./language//common.php): failed to open stream: No such file or directory in /home/clients/90da9a520f56c8b4182e72c468444d7c/web/phpbb3.2/stk/includes/critical_repair/bom_sniffer.php on line 1004

Warning: include(./language//common.php): failed to open stream: No such file or directory in /home/clients/90da9a520f56c8b4182e72c468444d7c/web/phpbb3.2/stk/includes/critical_repair/bom_sniffer.php on line 1004

Warning: include(): Failed opening './language//common.php' for inclusion (include_path='.:/opt/php7.2/lib/php') in /home/clients/90da9a520f56c8b4182e72c468444d7c/web/phpbb3.2/stk/includes/critical_repair/bom_sniffer.php on line 1004

Warning: include(./language//common.php): failed to open stream: No such file or directory in /home/clients/90da9a520f56c8b4182e72c468444d7c/web/phpbb3.2/stk/includes/critical_repair/bom_sniffer.php on line 164

Warning: include(./language//common.php): failed to open stream: No such file or directory in /home/clients/90da9a520f56c8b4182e72c468444d7c/web/phpbb3.2/stk/includes/critical_repair/bom_sniffer.php on line 164

Warning: include(): Failed opening './language//common.php' for inclusion (include_path='.:/opt/php7.2/lib/php') in /home/clients/90da9a520f56c8b4182e72c468444d7c/web/phpbb3.2/stk/includes/critical_repair/bom_sniffer.php on line 164
pyroshugo
Posteur expérimenté
Posteur expérimenté
 
Messages: 383
Enregistré le: 25 Aoû 2004 à 20:54
Localisation: GAILLAC

Re: url ne fonctionne plus sous 3.2.7

Messagepar Sylveretour » 24 Juil 2019 à 17:48

Pas besoin du kit de réparation d'urgence et je le déconseille très fortement si on ne connait pas exactement la portée de l'action entreprise.

Pour voir ce qui s'est passé lors des dernières mises à jour, tu ouvre le dossier store/, dans ce dossier, tu trouvera des fichiers nommés migrations_xxxxxxxxx.log
Tu copie le contenu des 3 plus récents et tu partage le contenu ici ► https://pastebin.com/
Puis tu donne les liens...
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 964
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: url ne fonctionne plus sous 3.2.7

Messagepar pyroshugo » 24 Juil 2019 à 20:07

Lorsque j'ai fait tout cela, je fais quoi ? Je n'ai pu envoyer que le dernier fichier.log car les 3 dépassaient les 512 ko autorisés !
pyroshugo
Posteur expérimenté
Posteur expérimenté
 
Messages: 383
Enregistré le: 25 Aoû 2004 à 20:54
Localisation: GAILLAC

Re: url ne fonctionne plus sous 3.2.7

Messagepar cocooncrash » 25 Juil 2019 à 17:27

Puis tu donne les liens...


lien du fichier généré par pastebin!
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7959
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: url ne fonctionne plus sous 3.2.7

Messagepar pyroshugo » 25 Juil 2019 à 17:47

J'espère que c'est le bon :
https://pastebin.com/u/DREUILHE
Modifié en dernier par Steph le 25 Juil 2019 à 17:51, modifié 1 fois.
Raison: Suppression de la citation inutile
pyroshugo
Posteur expérimenté
Posteur expérimenté
 
Messages: 383
Enregistré le: 25 Aoû 2004 à 20:54
Localisation: GAILLAC

Re: url ne fonctionne plus sous 3.2.7

Messagepar Sylveretour » 26 Juil 2019 à 17:37

D'après ce que j'ai pu voir dans le log, la mise à jour de la bdd est bien passée.
La solution est donc dans le bon remplacement des fichiers de base de phpBB.

Tu peut aussi fournir un compte test permettant de poster des messages afin de voir en direct le comportement de ton forum...
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 964
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: url ne fonctionne plus sous 3.2.7

Messagepar pyroshugo » 27 Juil 2019 à 10:03

Bonjour,
Je viens de voir quelque chose de pas normal : dans la table phpbb_acl_users je n'ai que très peu de membres alors qu'ils sont 716 comme on le voit sur la capture d'écran ci-dessous :

https://uagrugby.com/phpbb.jpg
pyroshugo
Posteur expérimenté
Posteur expérimenté
 
Messages: 383
Enregistré le: 25 Aoû 2004 à 20:54
Localisation: GAILLAC

Re: url ne fonctionne plus sous 3.2.7

Messagepar Steph » 27 Juil 2019 à 10:10

Salut,

Tu confonds la liste des utilisateurs avec la liste des permissions, mais autre sujet = autre demande, cela n'a rien à voir avec celui-ci.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 19121
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: url ne fonctionne plus sous 3.2.7

Messagepar pyroshugo » 27 Juil 2019 à 10:42

Effectivement j'ai écrit une grosse ânerie en confondant 2 tables...
pyroshugo
Posteur expérimenté
Posteur expérimenté
 
Messages: 383
Enregistré le: 25 Aoû 2004 à 20:54
Localisation: GAILLAC

Re: url ne fonctionne plus sous 3.2.7

Messagepar Sylveretour » 27 Juil 2019 à 11:47

Je viens de tester et le seul bbcode connaissant un problème est le bbcode url.
Il est totalement géré dans les fichiers des dossiers vendor, phpbb et includes...
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 964
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: url ne fonctionne plus sous 3.2.7

Messagepar pyroshugo » 27 Juil 2019 à 12:25

As-tu quelque chose à me proposer ?
pyroshugo
Posteur expérimenté
Posteur expérimenté
 
Messages: 383
Enregistré le: 25 Aoû 2004 à 20:54
Localisation: GAILLAC

Re: url ne fonctionne plus sous 3.2.7

Messagepar Sylveretour » 27 Juil 2019 à 13:57

A part supprimer les dossiers includes et vendor puis renvoyer des nouveaux, rien...
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 964
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: url ne fonctionne plus sous 3.2.7

Messagepar pyroshugo » 27 Juil 2019 à 14:42

Je vais essayer !
Merci pour ta patience !
Les effacements et les transferts n'ont toujours pas résolu le problème !
pyroshugo
Posteur expérimenté
Posteur expérimenté
 
Messages: 383
Enregistré le: 25 Aoû 2004 à 20:54
Localisation: GAILLAC

PrécédenteSuivante

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités