[Réglé] Forum qui ne s'affiche pas / Page blanche

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Forum qui ne s'affiche pas / Page blanche

Messagepar Cherycok » 08 Avr 2019 à 14:37

Bonjour,

Depuis quelques jours, lorsque je vais sur mon forum, j'ai une page blanche :

http://forum.darksidereviews.com

Je n'ai rien fait dessus entre le moment où il fonctionnait et celui ou il ne fonctionnait pas.

J'arrive à aller dans l'ACP en rajoutant "admin" à l'adresse ci-dessus. J'ai à priori accès à tout sauf à la section FORUM de l'ACP. Et dès que je retourne sur le forum, j'ai une page blanche.

J'ai fait quelques recherches sur le net, ils disaient de supprimer le contenu du répertoire CACHE (à l'exception de 2 fichiers). Je l'ai fait mais ca n'a rien changé.
Il faut savoir que je n'ai aucun plug-in/extension sur le forum. J4ai même désactivé mon style pour remettre le prosilver normal mais ca ne change rien.

Quand j'y accède via chrome, j'ai "HTTP ERROR 500"

Si quelqu'un a une idée pour me dépanner, je lui en serait infiniment reconnaissant ^_^

Bonne journée,

Cédric
Modifié en dernier par Cherycok le 09 Avr 2019 à 09:00, modifié 1 fois.
Cherycok
Posteur néophyte
Posteur néophyte
 
Messages: 73
Enregistré le: 07 Nov 2002 à 10:26

Re: Forum qui ne s'affiche pas / Page blanche

Messagepar Sylveretour » 08 Avr 2019 à 16:48

Bonjour,

Je trouve un bug chez toi:
Code: Tout sélectionner
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 580: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 636: sizeof(): Parameter must be an array or an object that implements 

Quelle est la version de ton forum?
Je pense connaitre la source du problème...
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 891
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Forum qui ne s'affiche pas / Page blanche

Messagepar Cherycok » 08 Avr 2019 à 18:12

Je suis en 3.2.5

Effectivement, sur un autre PC, j'ai ce même message d'erreur...
Cherycok
Posteur néophyte
Posteur néophyte
 
Messages: 73
Enregistré le: 07 Nov 2002 à 10:26

Re: Forum qui ne s'affiche pas / Page blanche

Messagepar Cherycok » 08 Avr 2019 à 18:13

LA ligne 580, c'est :

Code: Tout sélectionner
		if (sizeof($this->data))


La ligne 636, c'est :

Code: Tout sélectionner
		if (!sizeof($this->data) || !is_array($this->data))
Cherycok
Posteur néophyte
Posteur néophyte
 
Messages: 73
Enregistré le: 07 Nov 2002 à 10:26

Re: Forum qui ne s'affiche pas / Page blanche

Messagepar Sylveretour » 08 Avr 2019 à 20:06

C'est donc bien exactement ce que je pensais, mais en pire...
Si le navigateur contient les cookies de ton forum, page blanche ou erreur 500 sinon on voit apparaitre le bug.
Je n'ai rien fait dessus entre le moment où il fonctionnait et celui ou il ne fonctionnait pas

Ton serveur est passé en version 7.2 de php et c'est ce passage qui est à l'origine du problème.
Je suis en 3.2.5

Ça, c'est ce que tu pense, mais tu a raté une ou des mises à jour.
Les lignes que tu donne datent de versions de phpbb antérieures, elles sont différentes en 3.2.5
Sous php 7.2, la fonction sizeof() ne peut pas être employée avec un paramètre vide, remplacée par count()
La version 3.2.5 étant compatible php 7.2, ceci est modifié

Si ce fichier n'a pas été mis à jour, de très nombreux autres fichiers ont le même problème.

Solution pour réparer:
Tu télécharge le pack complet de phpbb 3.2.5 ici -> http://www.phpbb-fr.com/telechargements/

Dans ce pack, supprime les dossiers cache - ext - files - images - store
Les fichier .htaccess et config.php
Tu envoie tout ceci à la place des dossiers/fichiers en place sur ton serveur.

A ce niveau, tu a tous les fichiers en 3.2.5
Pour bien assurer une version 3.2.5 de la bdd, fait tourner l'install incluse dans le pack complet.
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 891
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Forum qui ne s'affiche pas / Page blanche

Messagepar Cherycok » 09 Avr 2019 à 07:54

Ok je teste ca de suite et je te tiens au courant. Merci !
Cherycok
Posteur néophyte
Posteur néophyte
 
Messages: 73
Enregistré le: 07 Nov 2002 à 10:26

Re: Forum qui ne s'affiche pas / Page blanche

Messagepar Cherycok » 09 Avr 2019 à 08:39

Alors j'ai fait tout comme tu as dit. J'ai envoyé le package complet sauf les répertoires que tu as listé et sauf le fichier .htaccess et le fichier config.php. Le résultat était le même sur mon PC du boulot. Page blanche sur Firefox, Error 500 sur Chrome.

J'ai testé de change la version de PHP sur mon hébergement. Il était en 7.3, je l'ai passé en 7.2, et là tout refonctionne !!!

Merci enormement !
Cherycok
Posteur néophyte
Posteur néophyte
 
Messages: 73
Enregistré le: 07 Nov 2002 à 10:26

Re: [Réglé] Forum qui ne s'affiche pas / Page blanche

Messagepar Steph » 09 Avr 2019 à 09:01

Salut,

Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]

Et Merci de ne faire des UPs que toutes les 24 heures minimum !
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18959
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: [Réglé] Forum qui ne s'affiche pas / Page blanche

Messagepar Cherycok » 09 Avr 2019 à 09:04

c'est ce que j'ai fait direct =)
Cherycok
Posteur néophyte
Posteur néophyte
 
Messages: 73
Enregistré le: 07 Nov 2002 à 10:26

Re: [Réglé] Forum qui ne s'affiche pas / Page blanche

Messagepar Steph » 09 Avr 2019 à 09:07

Pas l’attribut de sujet en bas à droite. Pas grave je le fais pour toi du coup :wink:
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18959
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Dehas et 1 invité