Redirection erronée après saisie des identifiants

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Redirection erronée après saisie des identifiants

Messagepar pierredu » 28 Mar 2019 à 15:00

Bonjour,

J'ai un forum d'essai créé avec quickinstall, sous lequel j'ai rechargé une sauvegarde de mon forum, afin de faire des essais de mise à jour. Je me trouve donc avec un forum 3.2.4 qui fonctionne bien (ouverture de session, édition des messages, etc.).

J'ai le problème suivant :
Quand je reviens au forum après avoir mis à jour les fichiers par simple écrasement, le logiciel me demande de saisir mes identifiants (alors que j'avais demandé à ce qu'il se rappelle de moi, mais c'est peut-être un détail). Je les saisis et la redirection ne se fait pas vers le forum local, mais vers le forum distant.

Cela m'était déjà arrivé dans le passé, mais je n'avais jamais réussi à en trouver la cause.

Est-ce que cela vous dit quelque chose ?
Merci d'avance.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1181
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Redirection erronée après saisie des identifiants

Messagepar Sylveretour » 28 Mar 2019 à 17:48

Bonjour,

sous lequel j'ai rechargé une sauvegarde de mon forum

Tu a tout simplement oublié de changer les données serveur et cookies dans la bdd table config.

Regarde ici -> documentation/installation/30x-transferer-son-forum-vers-un-autre-hebergeur-a73-view.html
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 947
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Redirection erronée après saisie des identifiants

Messagepar pierredu » 28 Mar 2019 à 21:45

Non, ce n'est pas si simple.
Le forum a fonctionné correctement avec la nouvelle base de données.
C'est après cela que la mise à jour a été faite et a planté le bousin.

Ce n'est pas la première fois que ça m'arrive.
Mais je n'ai jamais pris le temps de comprendre ce qui se passait.
Avant, j'avais un prestataire qui faisait les mises à jour. Donc au plus je plantais mon serveur local, ce que je reconstituais assez rapidement.

Sur phpbb.com, le diagnostic s'oriente vers un conflit de cookies.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1181
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Redirection erronée après saisie des identifiants

Messagepar Dakin Quelia » 29 Mar 2019 à 11:13

Bonjour pierredu,

Ne serait-ce pas plutôt le domaine dans « Paramètres du serveur » qui n'a pas été mis à jour, semble-t-il.

Bien à toi
Aucun support par mail, MP ou msn.
Mes MODs: ici | Mon blogue: Mon blogue | DeviantArt: cliquez ici
Dakin Quelia
Floodeur universel
Floodeur universel
 
Messages: 21412
Enregistré le: 31 Oct 2006 à 19:33
Localisation: Belgique

Re: Redirection erronée après saisie des identifiants

Messagepar pierredu » 29 Mar 2019 à 15:51

Sur phpbb.com, quelqu'un m'a donné une liste de corrections à appliquer à la table phpbb3_config.
J'ai trouvé qu'il fallait aussi ne pas oublier la variable script_path.
Maintenant, je suis à pied d'œuvre. Je vais refaire la mise à jour pour la quatrième fois.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1181
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Redirection erronée après saisie des identifiants

Messagepar Sylveretour » 29 Mar 2019 à 20:51

C'est exactement ce que je t'avait indiqué dans mon message en te donnant le bon lien pour ce problème.
Notamment la partie:
- Changement des valeurs server_name et script_path dans phpmyadmin 2
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 947
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Redirection erronée après saisie des identifiants

Messagepar pierredu » 29 Mar 2019 à 21:30

Quand on est dans la mouise, comme dans ce genre de situation, on perd sa capacité d'analyse.
Je n'avais pas perçu cet aspect du script_path. Je m'en suis aperçu en voyant apparaître des segments forum dans les URL, alors que mon serveur local ne comprenait que le forum, pas de niveau immédiatement supérieur avec autre chose (dans notre cas, un site SPIP).
Sur mon serveur local, j'avais au moins 5 serveurs virtuels et, de ce fait, mes redirections semblaient aller tantôt de l'un à l'autre.

Merci tout de même à tous les intervenants.
Je ne suis même pas sûr de pouvoir en tirer toutes les conclusions nécessaires pour pouvoir aider d'autres personnes à l'avenir.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1181
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité