[Réglé] Des problèmes suites à un passage en https

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Des problèmes suites à un passage en https

Messagepar silenus » 18 Mai 2018 à 06:55

Bonjour.

Venant de migrer mon forum chez un autre hébergeur, et optant par la même occasion pour le https,
les usagers et moi-même remarquons de temps en temps, le besoin de ré actualiser des pages (lire un sujet ou répondre à un message) car affiche que le site est inaccessible.
N'ayant pas que le forum sur l'hébergement, ce phénomène n'ayant été pour l'instant que signalé sur le forum, je me pose la question de savoir si je n'ai pas oublié de configurer quelque chose.

Dans panneau admin/ Configuration du serveur / Paramètres des URLs du serveur, j'ai bien indiqué https// (phpbb a laissé un port 80 associé, j'ai tenté de modifier en 443).

Je n'ai réalisé aucune modification particulière au niveau du config.php sauf bien sûr les informations liées à la connexion à la base.

Je n'ai pas fait de htacces particulier pour rediriger http vers https.

Je ne vois pas d'autres paramètre susceptibles d'être modifiés .

Dans le template, tout lien avec chemin d'accès complet a été renommé https, sauf celui <span class="crumb" itemtype="http://data-vocabulary.org/Breadcrumb" itemscope=""> présent dans navbar_header.html ligne 179.
(je ne sais pas trop d'ailleurs à quoi sert ce lien externe et ce qu'il fait, si quelqu'un peut me détailler, ni s'il est possible de l'inhiber).

Autres problèmes constatés : la purge du cache via le panneau admin renvoie une erreur Ajax (service unavailaible), je dois supprimer manuellement via ftp.

Auriez-vous une idée afin de poser un diagnostic précis?

En vous remerciant d'avance.

PhpBB 3.2.2
Modifié en dernier par silenus le 22 Mai 2018 à 14:01, modifié 1 fois.
silenus
Posteur néophyte
Posteur néophyte
 
Messages: 32
Enregistré le: 09 Fév 2017 à 19:40

Re: Des problèmes suites à un passage en https

Messagepar Tchanthes » 22 Mai 2018 à 13:44

Check les logs du webserver (apache2, nginx, simplehttp) et du serveur de base de données (mysql, mariadb, postrgresql) afin de trouver des indications sur les erreurs.

Tu n'as pas juste switché de http vers https mais changé d'hébergeur: il doit y avoir pas mal de changements côté serveur.

silenus a écrit:Dans le template, tout lien avec chemin d'accès complet a été renommé https, sauf celui <span class="crumb" itemtype="http://data-vocabulary.org/Breadcrumb" itemscope=""> présent dans navbar_header.html ligne 179.
(je ne sais pas trop d'ailleurs à quoi sert ce lien externe et ce qu'il fait, si quelqu'un peut me détailler, ni s'il est possible de l'inhiber).


Je ne sais pas a quoi sert ce truc (qui renvoie chez google), mais il faudrait signaler aux devs qu'ils peuvent remplacer http par https. :P

PS: j'ai une erreur "Trying to redirect to potentially insecure url" lorsque je post sur forums.phpbb-fr.com
Image
Tchanthes
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 03 Fév 2017 à 14:47

Re: Des problèmes suites à un passage en https

Messagepar silenus » 22 Mai 2018 à 14:00

Je note donc que cela n'est pas une erreur de configuration mais plutôt un problème au niveau du serveur.

Merci pour cette confirmation.
silenus
Posteur néophyte
Posteur néophyte
 
Messages: 32
Enregistré le: 09 Fév 2017 à 19:40

Re: Des problèmes suites à un passage en https

Messagepar cabot » 22 Mai 2018 à 14:27

Hello,

silenus a écrit:Dans le template, tout lien avec chemin d'accès complet a été renommé https, sauf celui <span class="crumb" itemtype="http://data-vocabulary.org/Breadcrumb" itemscope=""> présent dans navbar_header.html ligne 179.
(je ne sais pas trop d'ailleurs à quoi sert ce lien externe et ce qu'il fait, si quelqu'un peut me détailler, ni s'il est possible de l'inhiber).


C'est un attribut de microdonnées pour le marquage sémantique.
En gros, c'est utilisé par google pour définir et afficher l’arborescence d'un sujet/forum au travers du fil d'Ariane dans les résultats de recherche.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26797
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Des problèmes suites à un passage en https

Messagepar Zoddo » 26 Mai 2018 à 22:17

Bonjour,

Normalement, il n'y a rien à modifier dans les styles pour passer en HTTPS, tout est déjà prévu.
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 6875
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités

cron