[Réglé] pas d'affichage d'avatars dans le pca

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] pas d'affichage d'avatars dans le pca

Messagepar jeffm » 25 Mar 2018 à 17:27

Bonjour a tous
petit soucis d'affichage des avatars qui sont dans la gallerie.
ils sont bien présent dans le ftp, mais ne s'affichent pas dans le panneau d'admin

le CHMOD du dossier est a 777
les chemins sont bien renseignés dans le pca

j'avais déja le probleme en version 3.1 avant de passer en 3.2

adresse du forum : http://www.lescaravaniers2.com/forums

nota : le forum est dans un sous dossier
Modifié en dernier par jeffm le 30 Mar 2018 à 16:04, modifié 1 fois.
jeffm
Apprenti-posteur
Apprenti-posteur
 
Messages: 165
Enregistré le: 21 Mar 2012 à 09:23

Re: pas d'affichage d'avatars dans le pca

Messagepar Zoddo » 25 Mar 2018 à 19:45

Bonjour,

Sur une image, si tu fait clique droit -> Copier l'adresse de l'image, qu'obtiens-tu comme URL ?
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 6742
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: pas d'affichage d'avatars dans le pca

Messagepar jeffm » 25 Mar 2018 à 20:11

sur une image au hasard, j'obtiens ceci

http://www.lescaravaniers2.com/forums/d ... p?id=49224

sur un avatar existant

http://www.lescaravaniers2.com/forums/d ... 887935.gif

et dans le pca, j'ai cela
Image
jeffm
Apprenti-posteur
Apprenti-posteur
 
Messages: 165
Enregistré le: 21 Mar 2012 à 09:23

Re: pas d'affichage d'avatars dans le pca

Messagepar Zoddo » 25 Mar 2018 à 20:14

Effectivement, ça indique qu'on est pas autorisé à télécharger l'image.

Quelqu'un qui a déjà utilisé la gallerie a-t-il une idée ? (je n'ai pas de moyen de faire de tests ce soir)
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 6742
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: pas d'affichage d'avatars dans le pca

Messagepar pierredu » 25 Mar 2018 à 20:49

Oui, mais le second lien marche.
C'est bizarre que le premier, qui est un lien de consultation, réponde comme un lien de téléchargement.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1058
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: pas d'affichage d'avatars dans le pca

Messagepar jeffm » 30 Mar 2018 à 09:40

entre temps, j'ai déplacé le forum dans un sous domaine
voila 2 exemples d'adresses relevée
https://forum.lescaravaniers2.com/downl ... p?id=49051

https://forum.lescaravaniers2.com/downl ... 483151.jpg

rien de changé au niveau avatar

par contre, quand je suis sur la page des avatars, il y a un message tout en bas qui tourne en boucle

-en attente de connection à xxxxxxxxxx
-connecté à xxxxxxxxxxx
-transfert de donnée de xxxxxxxx

ces messages restent tout le temps du rafraichissement de la page (assez long) mais rien d'autre ne se passe
jeffm
Apprenti-posteur
Apprenti-posteur
 
Messages: 165
Enregistré le: 21 Mar 2012 à 09:23

Re: pas d'affichage d'avatars dans le pca

Messagepar Sylveretour » 30 Mar 2018 à 10:18

Hello Jeffm,

J'ai trouvé ce qui coince dans les galeries d'avatars.
C'est le .htaccess qui empêche toute consultation d'avatars, tu le supprime et alors tout fonctionne comme il se doit.
Il faudrait alors faire une remontée de bug chez phpbb.com pour cela car tout est d'origine...

Pour éviter une consultation des dossiers, on peut remplacer le .htaccess par un index.html vide
Avatar de l’utilisateur
Sylveretour
Maître-posteur
Maître-posteur
 
Messages: 443
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: pas d'affichage d'avatars dans le pca

Messagepar jeffm » 30 Mar 2018 à 11:00

Bonjour Sylver
je viens de tester - si je supprime le htaccess ca ne change rien au niveau avatar, par contre, c'est ta shoutbox qui plante

j'avoue avoir du mal a comprendre
jeffm
Apprenti-posteur
Apprenti-posteur
 
Messages: 165
Enregistré le: 21 Mar 2012 à 09:23

Re: pas d'affichage d'avatars dans le pca

Messagepar Sylveretour » 30 Mar 2018 à 11:03

Je parle du .htaccess qui se trouve dans le dossier images/avatars/gallery/ bien sûr
Avatar de l’utilisateur
Sylveretour
Maître-posteur
Maître-posteur
 
Messages: 443
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: pas d'affichage d'avatars dans le pca

Messagepar jeffm » 30 Mar 2018 à 11:07

ah ok,
ben, y'en a pas
jeffm
Apprenti-posteur
Apprenti-posteur
 
Messages: 165
Enregistré le: 21 Mar 2012 à 09:23

Re: pas d'affichage d'avatars dans le pca

Messagepar Sylveretour » 30 Mar 2018 à 11:18

Il y en a un d'origine et en le supprimant, la galerie fonctionne.
Tu peut aller vérifier chez moi, dans ton profil, la preuve par 9 :D
Car j'avais exactement le même problème et le voilà résolu.
Avatar de l’utilisateur
Sylveretour
Maître-posteur
Maître-posteur
 
Messages: 443
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: pas d'affichage d'avatars dans le pca

Messagepar jeffm » 30 Mar 2018 à 11:36

oui, j'ai testé chez toi, bien evidement, ca fonctionne
j'ai fait l'essai de supprimer tous les avatars sauf 1
ca m'affiche tjrs la meme image comme si ils y etaient tous - la mise a jour ne se fait pas
jeffm
Apprenti-posteur
Apprenti-posteur
 
Messages: 165
Enregistré le: 21 Mar 2012 à 09:23

Re: pas d'affichage d'avatars dans le pca

Messagepar Sylveretour » 30 Mar 2018 à 13:52

bien evidement, ca fonctionne

Cela ne fonctionnait pas avant, c'est la suppression du fichier images/avatars/gallery/.htaccess qui a entrainé le bon fonctionnement.
ca m'affiche tjrs la meme image comme si ils y etaient tous - la mise a jour ne se fait pas

Les avatars sont mis en cache dans le fichier data_avatar_local_list.php
Donc, les ajouts et suppressions ne prennent effet que suite au vidage du cache bien-sûr...
Avatar de l’utilisateur
Sylveretour
Maître-posteur
Maître-posteur
 
Messages: 443
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: pas d'affichage d'avatars dans le pca

Messagepar jeffm » 30 Mar 2018 à 14:08

je n'ai pas de fichier htaccess a cet endroit

et je vide le cache a chaque modif

j'ai testé avec un sous dossier sans lequel j'ai mis qques exemples

j'ai bien le bon nombre de boutons, mais rien ne s’affiche
jeffm
Apprenti-posteur
Apprenti-posteur
 
Messages: 165
Enregistré le: 21 Mar 2012 à 09:23

Re: pas d'affichage d'avatars dans le pca

Messagepar Sylveretour » 30 Mar 2018 à 14:19

Je viens de vérifier dans un pack phpBB neuf 3.2.2 et effectivement pas de .htaccess
J'ai dû alors le chopper dans une version ultérieure.
Supprime celui présent dans avatars/upload/ pour voir
Avatar de l’utilisateur
Sylveretour
Maître-posteur
Maître-posteur
 
Messages: 443
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Suivante

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité