[Réglé] Le bouton "insérer dans le message" n’apparaît pas

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Le bouton "insérer dans le message" n’apparaît pas

Messagepar copain des copeaux » 27 Fév 2018 à 01:14

Bonjour

Lorsque l'on veut poster une image (ou un autre type de fichier), on clique sur "fichiers joints", puis "ajouter des fichiers", l'upload se fait et le nom du fichier apparait. Cependant le bouton "insérer dans le message" n'apparait pas :
Image

Par contre lorsque l'on édite un vieux post qui comporte déjà une image, le bouton est présent pour l’image déjà présente :
Image


Auriez vous une idée de l'origine du problème?


Plusieurs opérations ayant été menées de front pour la mise à jour et l'adaptation du style je ne saurais dire après quelle modification le problème est apparu. De plus je ne peux pas restaurer la version précédente car celle ci a été perdue dans le naufrage de mon ancien serveur (qui a dit que les emm.. ca vole en escadrille?)

Mon forum est en phpbb 3.2.2
version de php 7.1.14
adresse du forum : https://www.copaindescopeaux.fr/forum


Merci d'avance pour vos conseils.
Modifié en dernier par copain des copeaux le 19 Mar 2018 à 10:55, modifié 1 fois.
copain des copeaux
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 27 Fév 2018 à 00:35

Re: le bouton "insérer dans le message" n'apparait pas

Messagepar Sylveretour » 27 Fév 2018 à 01:30

Bonjour,

Je te conseille alors de faire un essais avec prosilver pour voir si le problème provient du style.
Avatar de l’utilisateur
Sylveretour
Maître-posteur
Maître-posteur
 
Messages: 440
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: le bouton "insérer dans le message" n'apparait pas

Messagepar copain des copeaux » 27 Fév 2018 à 01:52

Merci
Le problème est présent aussi avec prosilver.
Je précise également que les utilisateurs sont autorisés à poster des fichiers :
Image
copain des copeaux
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 27 Fév 2018 à 00:35

Re: le bouton "insérer dans le message" n'apparait pas

Messagepar MrGaby » 27 Fév 2018 à 15:18

Salut

Deux pistes à explorer :
- Certains ont rencontré des problèmes avec les fichiers attachés lors de la mise à jour 3.2.2. Voir la partie de ce message consacrée à l'affichage des fichiers attachés.

- Ton hébergeur te permet-il de repasser en php 5.6 pour voir si cela change quelque chose ?

PS : pour ton image de fond, afin de gagner en fluidité avec certains navigateurs, je te conseille de jeter un oeil à ce sujet, soit en modifiant ton code d'affichage de l'image de fond, soit en utilisant l'extension "Background forum" en la modifiant selon les explications dudit sujet :wink:
@+
Gaby, ké un gars
MrGaby
Apprenti-posteur
Apprenti-posteur
 
Messages: 132
Enregistré le: 10 Fév 2010 à 17:47

Re: le bouton "insérer dans le message" n'apparait pas

Messagepar copain des copeaux » 27 Fév 2018 à 23:20

merci pour ces suggestions
J'ai tenté la modification du fichier functions_posting.php sans succès
Je suis passé en php5.6 (serveur dédié) sans succès.

J'ai l'impression que l'upload ne se fait pas en fait car en utilisant l'inspecteur de firefox, le fichier n'a pas d'adresse html (par contre il a un id) :
Image Se pourrait il que le problème vienne du passage récent en ssl?
(les permissions de files, cache et store sont en 777)
copain des copeaux
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 27 Fév 2018 à 00:35

Re: le bouton "insérer dans le message" n'apparait pas

Messagepar MrGaby » 28 Fév 2018 à 12:25

Salut

Il me semble que la page se comporte comme si le téléversement ne s'était pas terminé.

As-tu modifié la page styles/prosilver/template/posting_attach_body.html ?

Dans le doute, renvois la version "propre" kivabien.

Quel est la version de ton style ?

Qu'affiche la colonne "Statut" lorsque le problème se présente ? On ne la voit pas sur tes copies d'écran.
@+
Gaby, ké un gars
MrGaby
Apprenti-posteur
Apprenti-posteur
 
Messages: 132
Enregistré le: 10 Fév 2010 à 17:47

Re: le bouton "insérer dans le message" n'apparait pas

Messagepar copain des copeaux » 28 Fév 2018 à 21:56

Il me semble que la page se comporte comme si le téléversement ne s'était pas terminé.

Oui il me semble aussi.

Latte version 3.2.2

styles/prosilver/template/posting_attach_body.html avait été modifié pour enlever le "hidden" . le bouton apparaissait mais était inopérant.
styles/prosilver/template/posting_attach_body.html rétabli dans sa version d'origine


La colonne statut affiche une barre verte de progression puis plus rien.
copain des copeaux
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 27 Fév 2018 à 00:35

Re: le bouton "insérer dans le message" n'apparait pas

Messagepar MrGaby » 03 Mar 2018 à 00:16

Salut

As-tu essayer de désactiver toutes les extensions, pour voir ce que cela donne ?

Il semble que tu as de l'url rewriting sur ton forum. Comment tu t'y es pris, étant donné qu'il n'y a pas d'extension validée pour phpbb 3.2.x ?

Aurais-tu un compte de test pour aller jeter un oeil ?
@+
Gaby, ké un gars
MrGaby
Apprenti-posteur
Apprenti-posteur
 
Messages: 132
Enregistré le: 10 Fév 2010 à 17:47

Re: le bouton "insérer dans le message" n'apparait pas

Messagepar copain des copeaux » 07 Mar 2018 à 17:03

Après de nombreux tests, cela venait du htacess modifié pour intégrer p8pbb.
En enlevant les lignes spécifiques à p8pbb, ca remarche.
J'ai contacté p8pbb afin de savoir quoi écrire dans le htacess.
copain des copeaux
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 27 Fév 2018 à 00:35

Re: le bouton "insérer dans le message" n'apparait pas

Messagepar cocooncrash » 07 Mar 2018 à 17:25

Donc sujet resolu,

Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]. Cordialement.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7631
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 5 invités