[Réglé] Page Blanche (totalité du forum)

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Page Blanche (totalité du forum)

Messagepar Getrox » 29 Déc 2017 à 14:21

Bonjour :)

Hier tout allé bien après l'installation d'un tout nouveau forum, puis ce matin en voulant m'y connecter je tombe sur une page blanche. Je n'ai même pas de page d'accueil.

J'ai tenté le re-upload de tous mes fichiers (à part install et config) mais rien n'y fait.
Les cookies sont purgés aussi et le cache je l'ai fais via FTP.
Ça ne fonctionne pas non plus sous Opera.
Les seuls modification apportées pour l'instant ont été au niveau des permission du forum hier en début de matinée.

Le sujet a était soulevé maintes fois, mais aucunes des solutions que j'ai trouvé sur ce forum n'ont pu m'aider pour l'instant.

Si vous avez une idée, je suis preneur.

Merci d'avance à tous.

Si ça peut aider je met le lien du site ici: http://sou-neant.info/BADasso/forum/
Modifié en dernier par Getrox le 31 Déc 2017 à 11:34, modifié 1 fois.
Getrox
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 29 Déc 2017 à 14:10

Re: Page Blanche (totalité du forum)

Messagepar pierredu » 29 Déc 2017 à 14:30

Une page blanche, c'est une erreur 500 (ce que Chrome affiche, d'ailleurs).

Si cela allait bien hier soir, peut-être as-tu fait une petite modif' sans importance au dernier moment avant d'arrêter ?
C'est classique.
C'est souvent facile à (re)trouver.

Sinon, il faut modifier le fichier config.php
Mettre development dans PHPBB_ENVIRONMENT
et
@define('DEBUG', true);
@define('DEBUG_EXTRA', true);
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1026
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Page Blanche (totalité du forum)

Messagepar Getrox » 29 Déc 2017 à 14:42

Bonjour, merci de la réponse rapide.

Afin de ne pas faire de conneries j'aimerai être bien sûr.

J'ai donc ceci:
@define ('PHPBB_INSTALLED', true) ;
@define ('PHPBB_ENVIRONMENT', 'production') ;

Et je dois faire ceci?
@define ('PHPBB_ENVIRONMENT', 'production', 'development') ;

Et ajouter ces deux lignes à la suite?
@define('DEBUG', true);
@define('DEBUG_EXTRA', true);

Désolé, mais je ne veux pas faire de bêtises.
Getrox
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 29 Déc 2017 à 14:10

Re: Page Blanche (totalité du forum)

Messagepar pierredu » 29 Déc 2017 à 21:41

Oui.
Et bien sûr garder une copie du fichier dans son état antérieur.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1026
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Page Blanche (totalité du forum)

Messagepar Getrox » 30 Déc 2017 à 01:26

D'accord, merci.

J'ai donc essayé ce que vous m'avez proposé, mais la page blanche est toujours présente.

Image
Getrox
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 29 Déc 2017 à 14:10

Re: Page Blanche (totalité du forum)

Messagepar pierredu » 30 Déc 2017 à 09:31

La ligne de l'environnement ne doit contenir que développement, pas les deux.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1026
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Page Blanche (totalité du forum)

Messagepar Getrox » 30 Déc 2017 à 11:03

J'ai corrigé l'erreur, mais je n'ai pas de résultat visible pour l'instant.

Edit: Une nouvelle chose vient de s'afficher, ceci:

Image
Getrox
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 29 Déc 2017 à 14:10

Re: Page Blanche (totalité du forum)

Messagepar Sylveretour » 30 Déc 2017 à 15:28

Bonjour,

L'erreur parle d'elle même:
The file "development/config.yml" does not exist

Il manque le fichier config.yml qui doit se trouver dans le dossier config/production

Je te conseille donc de revoir la présence de la totalité des fichiers...
Avatar de l’utilisateur
Sylveretour
Maître-posteur
Maître-posteur
 
Messages: 426
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Page Blanche (totalité du forum)

Messagepar pierredu » 30 Déc 2017 à 22:21

Je ne trouve pas non plus la branche config/development.
Je n'ai pas trouvé d'indications sur le forum phpbb.com.

Corrige ton fichier config.php en remettant production.
Peut-être que les deux lignes de validation du débogage suffiront pour voir le problème.

Si tu as accès aux journaux, peut-être y trouveras-tu des éléments.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1026
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Page Blanche (totalité du forum)

Messagepar Getrox » 30 Déc 2017 à 23:49

Le forum n'ayant que plus ou moins 24h de vie et seulement des réglages travail fait dessus, je le reprend entièrement.
Il faut que j'avance.

Merci tout de même de votre aide, surtout vous pierredu.

En espérant ne pas avoir à repasser par ici pour le même problème.

Getrox.
Getrox
Posteur néophyte
Posteur néophyte
 
Messages: 5
Enregistré le: 29 Déc 2017 à 14:10

Re: Page Blanche (totalité du forum)

Messagepar cocooncrash » 31 Déc 2017 à 10:38

Bonjour,
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé].

Cordialement.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7617
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité