Impossible d'afficher les images (et les vidéos Youtube)

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Nguyom » 05 Déc 2017 à 14:12

Bonjour à tous,

Après être resté quelques années sur une version 3.0 de mon forum (http://www.mysweetforum.fr/forum), j'ai eu un bug de manière totalement subite : du jour au lendemain, sans intervention de quiconque, les images et vidéos youtube ne s'affichaient plus.
Un peu décontenancé et pensant à un problème lié à l'âge un peu ancien de la dernière MAJ, j'ai tenté une mise à jour vers la version 3.2.1. Tout s'est bien déroulé.
Toutefois, le problème persiste toujours. J'ai beau avoir regardé des sujets vaguement similaires un peu partout, rien ne semble faire avancer ce bug.
C'est pareil pour tout les membres. J'ai désactivé les adblocks et testé avec plusieurs navigateurs, rien ne change.
Idem quand je regarde avec l'option "inspecter" de google chrome. Sans trop m'y connaitre, il me semble que la ligne pour afficher l'image est correcte.

Avec, au pif, une image trouvée sur le net le bbcode de mon forum donne ceci :
Code: Tout sélectionner
[img]https://static.alipson.fr/ty---beanie-boos.820/beanie-boos-peluche-beanie-boos-small-fantasia-la-licorne.145238-1.235.jpg[/img]


et la ligne qui en résulte :

Code: Tout sélectionner
<img src="https://static.alipson.fr/ty---beanie-boos.820/beanie-boos-peluche-beanie-boos-small-fantasia-la-licorne.145238-1.235.jpg" class="postimage" alt="Image">


Peu importe la taille de l'image, rien ne s'affiche.

Chose très bizarre : cela marche bien quand je mets un lien d'une image présente sur l'hébergeur.
Même genre de souci avec les liens Youtube.
J'ai tenté d'utiliser des extensions du type Advanced BBCode mais rien n'y fait.

Avez-vous une idée de la source du problème ?
Merci de votre aide !

(J'espère avoir posté cela bien là où il faut mais j'ai du mal à voir d'où cela vient).
Nguyom
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 05 Déc 2017 à 14:00

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Sylveretour » 05 Déc 2017 à 14:58

Bonjour,

Il serait bon alors de nous donner un lien d'un message sur ton forum ou le problème est visible.
Sans cela, attendre la sortie finale de l'extension boule de cristal :mrgreen:
Sylveretour
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 21 Nov 2017 à 18:24

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Nguyom » 05 Déc 2017 à 15:13

Merci de ta réponse.
C'est pas faux :D

Pour les images, j'ai fait un sujet test ici : http://mysweetforum.fr/forum/viewtopic.php?f=1&t=220

Ce qui donne :
Code: Tout sélectionner
Test de l'affichage d'une image :

[img]https://www.w3schools.com/w3css/img_lights.jpg[/img]

Vidéo Youtube :

[BBvideo=560,315]https://www.youtube.com/watch?v=zOjaTNHh9CQ[/BBvideo]


Je prends pas trop la peine de résoudre les vidéos Youtube (et le reste des plugins qui affichent de l'image, du son ou de la vidéo) car je pense que c'est lié. Dans un premier temps, je veux me focaliser sur les images, ça me semble plus important.

Merci :P
Nguyom
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 05 Déc 2017 à 14:00

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar prototype » 05 Déc 2017 à 15:37

salutation ^^

quand je vais voir ton lien ce dessous, voici ce que renvoi les fichiers en bbcode
Code: Tout sélectionner
Les requêtes vers le serveur ont été bloquées par une extension


^^ tu as pas une extensions qui bloque les bbcodes ? ou une extension de bbcode mal désinstallé ?

sinon, les permissions invités et membre sont bien autoriser pour les bbcode sur le forum concerné également ?

voila quelques pistes ^^

bon courage
Sa sainteté le seul et l'unique Proto vous salut
Elwen, jeu rp basé sur phpbb
prototype
Posteur néophyte
Posteur néophyte
 
Messages: 85
Enregistré le: 08 Mai 2014 à 22:09

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Sylveretour » 05 Déc 2017 à 15:43

Apparemment, c'est une restriction coté serveur.
Poste une image hébergée chez toi et tu la verra apparaitre J'ai testé en ligne de code.
Pour les vidéos, c'est donc le même soucis.
Sylveretour
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 21 Nov 2017 à 18:24

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Nguyom » 05 Déc 2017 à 15:47

Merci pour le coup de main !
Normalement j'ai rien qui justifie qu'une requête soit bloquée car même sans aucune extension le souci se presentait.

Par contre, cela me fait penser à un problème que j'avais eu il y a quelques temps sur un site perso où les requêtes images ont été bloquées du jour au lendemain sans raison par le serveur.
C'était un bug de mon hébergeur (le même ici) mais ils ont mis des lustres à le trouver. Ça pourrait être du même acabit ici ?

Je vais continuer à creuser, merci beaucoup pour cette réponse.

Edit : Merci pour la deuxième réponse, je vais me rapprocher d'eux dans ce cas.
Nguyom
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 05 Déc 2017 à 14:00

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Sylveretour » 05 Déc 2017 à 15:53

Voilà les erreurs retournées:
Code: Tout sélectionner
Content Security Policy: Les paramètres de la page ont empêché le chargement d’une ressource à https://www.w3schools.com/w3css/img_lights.jpg (« default-src http://mysweetforum.fr https://*.gravatar.com https://*.gstatic.com https://*.googleapis.com https://ssl.google-analytics.com https://s-static.ak.facebook.com https://www.google-analytics.com data: 'unsafe-inline' 'unsafe-eval' »).
Content Security Policy: Les paramètres de la page ont empêché le chargement d’une ressource à http://www.youtube.com/embed/zOjaTNHh9CQ (« default-src http://mysweetforum.fr https://*.gravatar.com https://*.gstatic.com https://*.googleapis.com https://ssl.google-analytics.com https://s-static.ak.facebook.com https://www.google-analytics.com data: 'unsafe-inline' 'unsafe-eval' »).

C'est donc bien un paramètre coté serveur en cause
Sylveretour
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 21 Nov 2017 à 18:24

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Nguyom » 05 Déc 2017 à 16:24

Ah c'est top, je vais leur envoyer ça histoire de gagner du temps.
Vraiment, merci beaucoup, je vous tiens au jus des résultats et de la réponse de mon hébergeur.
Nguyom
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 05 Déc 2017 à 14:00

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Nguyom » 05 Déc 2017 à 18:12

Panne résolue, merci à vous pour ce diagnostic rapide :)
Nguyom
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 05 Déc 2017 à 14:00

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Steph » 05 Déc 2017 à 18:30

Salut,

Merci de ne faire des UPs que toutes les 24 heures minimum !

Aussi, merci de penser aux autres membres en donnant la solution.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17367
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Sylveretour » 05 Déc 2017 à 20:42

Et quelle en était la raison ??
Sylveretour
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 21 Nov 2017 à 18:24

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar galixte » 06 Déc 2017 à 07:46

Est-ce ton hébergeur qui injecte du code dans le .htaccess pour dire à Apache d’activer le Content Security Policy.

Ça me fait penser à une extension « Content Security Policy » qui avait été développée en ce sens.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10027
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Impossible d'afficher les images (et les vidéos Youtube)

Messagepar Nguyom » 10 Déc 2017 à 10:30

Navré pour le temps de réponse un peu long, je n'étais pas chez moi ces derniers jours et je comptais repasser pour vous donner des nouvelles.

Vous aviez raison, il s'agissait bien d'une restriction côté serveur, apparue subitement et sans raison apparente. Cela fait un certain temps que j'ai des soucis avec cet hébergeur et j'ai un peu de mal à savoir comment ils gèrent tout ça. Pas un mot d'excuse, rien juste "Ah oui, il y a bien eu une restriction qui avait été ajoutée". Rien de plus.
Ce qui est bizarre, c'est qu'ils m'avaient déjà "fait le coup" sur un autre de mes sites. Hors, les audiences que j'ai sont ultra confidentielles et rien ne semble justifier cela.
La première personne de l'assistance que j'avais eu avait pointé un fichier problématique mais même après avoir été supprimé cela ne changeait rien.
Par la suite, j'ai eu une deuxième personne qui elle avait pointé cette restriction un peu random.

galixte a écrit:Est-ce ton hébergeur qui injecte du code dans le .htaccess pour dire à Apache d’activer le Content Security Policy.

Ça me fait penser à une extension « Content Security Policy » qui avait été développée en ce sens.


Ça peut être une piste. Comment savoir si c'est bel et bien le cas ? Ils ne précisent rien de particulier sur leur site et j'ai regardé le .htaccess mais je ne vois rien de particulier.
Nguyom
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 05 Déc 2017 à 14:00


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité