Protocole ssl qui s'affiche mal

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

Protocole ssl qui s'affiche mal

Messagepar Abcve » 29 Aoû 2017 à 03:25

Bonjour,

J'aimerais savoir pourquoi le protocole ssl s'enlève d'un coup alors qu'il devrait pas..

Je vais sur mon forum tout fonctionne super bien et parfois quand je navigue sur le forum le protocole disparaît..

Si quelqu'un aurai la réponse ça serai fantastique :)

Merci d'avance.
Modifié en dernier par Abcve le 30 Aoû 2017 à 20:33, modifié 1 fois.
Abcve
Posteur néophyte
Posteur néophyte
 
Messages: 77
Enregistré le: 04 Déc 2015 à 16:15
Avertissements: 1

Re: Protocole ssl qui s'affiche mal

Messagepar galixte » 29 Aoû 2017 à 07:16

Salut,

car le contenu de la page fait appel à des éléments qui ne sont pas hébergés sur des sites sécurisés, telles que les images dans les messages, par exemple.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9914
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Protocole ssl qui s'affiche mal

Messagepar Abcve » 29 Aoû 2017 à 14:31

Salut,

Merci d'avoir répondu à mon message.

C'est bien ce que je me disait MAIS le soucis c'est que mes images son toutes hébergé sur mon site..

et quand je m'amuse à réactualiser plusieurs fois la page parfois ça reviens VERT et le protocole re fonctionne, sans compter qu'il me le fait systématiquement quand je suis sur l'administration de mon forum et sur l'admin il n'y a aucune images :x
Abcve
Posteur néophyte
Posteur néophyte
 
Messages: 77
Enregistré le: 04 Déc 2015 à 16:15
Avertissements: 1

Re: Protocole ssl qui s'affiche mal

Messagepar Steph » 29 Aoû 2017 à 14:43

Salut,

Cela peut aussi venir des signatures, des avatars ou d'autres liens.

D'ailleurs si tes images sont hébergées sur ton site, les URL sont-elles en https ?
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17274
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Protocole ssl qui s'affiche mal

Messagepar Abcve » 29 Aoû 2017 à 23:14

Salut steph,

Alors quand on va sur l'image on n'a pas le "https" qui s'affiche automatiquement.. donc ça enlève le https..

Par contre quand on ajoute "https" dans l'url ça fonctionne mais ça le fait pas automatiquement..

Comment faire pour que ça soit prit en compte automatiquement ?

Cdt.
Abcve
Posteur néophyte
Posteur néophyte
 
Messages: 77
Enregistré le: 04 Déc 2015 à 16:15
Avertissements: 1

Re: Protocole ssl qui s'affiche mal

Messagepar galixte » 29 Aoû 2017 à 23:40

Forcer les paramètres serveur dans le panneau d’administration, pour y indiquer le port HTTPS de ton serveur. Ajouter une règle de redirection des liens HTTP vers HTTPS dans le fichier HTACCESS de ton forum.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9914
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Protocole ssl qui s'affiche mal

Messagepar Abcve » 30 Aoû 2017 à 00:28

Comment on fait ça stp ?
Abcve
Posteur néophyte
Posteur néophyte
 
Messages: 77
Enregistré le: 04 Déc 2015 à 16:15
Avertissements: 1

Re: Protocole ssl qui s'affiche mal

Messagepar galixte » 30 Aoû 2017 à 01:14

Écoute vu le peu d’investissement que tu passes à chercher par toi même les réponses, je pense que nous en resterons là. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9914
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Protocole ssl qui s'affiche mal

Messagepar Steph » 30 Aoû 2017 à 08:26

Salut,

Effectivement un peu d'effort pour rechercher sur le forum aidera fortement, j'ai déjà personnellement donnée la solution en deux lignes à ajouter dans le htaccess et puis si je relis le message de galixte les 3/4 des réponses à Comment on fait ça stp ? s'y trouve.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17274
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité