[Réglé] Erreur encodage envoi email de masse depuis maj 3.2.1

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Erreur encodage envoi email de masse depuis maj 3.2.1

Messagepar geric » 19 Aoû 2017 à 18:47

Bonjour,

Depuis la mise à jour 3.2.0 vers 3.2.1 la fonction d'envoi d'email de masse depuis la page d'administration de mon forum ne fonctionne plus.
J'ai ce message sous Firefox dès que je clique sur la demande d'envoi :
Erreur d’encodage de contenu
La page que vous essayez de voir ne peut être affichée car elle utilise un type de compression invalide ou non pris en charge.
Veuillez contacter les propriétaires du site web pour les informer de ce problème.


Avec Edge, j'ai ce message :
Désolé, nous ne pouvons pas atteindre cette page
Assurez-vous d’avoir la bonne adresse web
Détails
Nous nous sommes connectés à ce site web, mais nous n’avons reçu aucune donnée le concernant.
Code d’erreur : INET_E_DATA_NOT_AVAILABLE


Le reste du forum semble fonctionner normalement, je n'avais pas ce problème sous 3.2.0.
J'ai déjà tenté de vider le cache de mon navigateur et du forum sans résultat.

Merci d'avance pour votre aide.
Modifié en dernier par geric le 20 Aoû 2017 à 09:45, modifié 2 fois.
geric
Posteur néophyte
Posteur néophyte
 
Messages: 40
Enregistré le: 02 Nov 2008 à 00:43

Re: Problème envoi email de masse depuis maj 3.2.1

Messagepar galixte » 19 Aoû 2017 à 23:08

Salut,

envoi à nouveau les fichiers de phpBB 3.2.1, supprime les fichiers de ton espace FTP avant d’envoyer les nouveaux.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Erreur encodage envoi email de masse depuis maj 3.2.1

Messagepar geric » 20 Aoû 2017 à 10:37

Merci pour la réponse.

Je viens de supprimer tous les fichiers et uploader tous les fichiers de l'archive complète 3.2.1 hormis le répertoire images/

Le problème d'erreur d'encodage reste le même.
Modifié en dernier par geric le 20 Aoû 2017 à 13:00, modifié 4 fois.
geric
Posteur néophyte
Posteur néophyte
 
Messages: 40
Enregistré le: 02 Nov 2008 à 00:43

Re: Erreur encodage envoi email de masse depuis maj 3.2.1

Messagepar geric » 20 Aoû 2017 à 10:56

Je précise aussi que je n'ai rien changé dans la configuration des emails dans la page d'admin et que si j'envoie un message directement depuis ma messagerie avec le compte email utilisé par le forum, ça fonctionne.
Le service mail de mon fournisseur de domaine fonctionne donc normalement.

J'ai aussi relancé le service apache sur mon serveur et également vidé le cache à de nombreuses reprises.
geric
Posteur néophyte
Posteur néophyte
 
Messages: 40
Enregistré le: 02 Nov 2008 à 00:43

Re: Erreur encodage envoi email de masse depuis maj 3.2.1

Messagepar geric » 20 Aoû 2017 à 11:17

Je viens aussi de faire une vérif de notification via les MP.
Lors de l'envoi du MP j'ai aussi un message d'erreur lié aux emails. Le MP est par contre bien créé dans la base de données.

Voici le message d'erreur visible momentanément :
[phpBB Debug] PHP Warning : in file [ROOT]/includes/functions_messenger.php on line 1541 : stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed


Dans le journal d'erreur dans les pages d'administration du forum, j'ai aussi ce message (par souci de confidentialité, j'ai remplacé le nom de domaine par "domaine") :

Erreur d’e-mail
» EMAIL/SMTP
/ucp.php

Impossible de récupérer les codes de réponse du serveur.
Backtrace

Connecting to smtp.domaine.fr:25
LINE: 1139 <- 220 ssl0.ovh.net player778

# EHLO domaine.fr
LINE: 1486 <- 250-player778.ha.ovh.net

LINE: 1486 <- 250-SIZE 104850000

LINE: 1486 <- 250-STARTTLS

LINE: 1486 <- 250-AUTH PLAIN LOGIN

LINE: 1486 <- 250-AUTH=PLAIN LOGIN

LINE: 1486 <- 250-ENHANCEDSTATUSCODES

LINE: 1486 <- 250 8BITMIME

# STARTTLS
LINE: 1531 <- 220 2.0.0 Ready to start TLS

# AUTH PLAIN


Edit 11h56 :

Après pas mal d'essais, je viens de trouver une solution à mon problème en modifiant un des paramètres des emails :

Vérifier le certifcat SSL :
Exige la vérification du certificat SSL utilisé par le server SMTP partenaire.Attention : Établir une connexion avec un certificat SSL non vérifié peut induire des problèmes de sécurité.


Cette option était cochée sur OUI, je l'ai modifié sur NON et les emails fonctionnent de nouveau.

La mise à jour de 3.2.0 vers 3.2.1 peut elle avoir modifié cette option ?

Edit 13h54 :

Je viens de restaurer sur un wampserver la version 3.2.0 de mon forum.
Il semble que la version 3.2.1 rajoute trois options dans la configuration des emails :

Vérifier le certifcat SSL :
Exige la vérification du certificat SSL utilisé par le server SMTP partenaire.Attention : Établir une connexion avec un certificat SSL non vérifié peut induire des problèmes de sécurité.

Vérifier le nom du partenaire SMTP :
Exige la vérification du nom du partenaire pour les serveurs SMTP utilisant une connexion SSL/TLS.Attention : Établir une connexion à un partenaire non vérifié peut induire des problèmes de sécurité.

Autoriser les certificats SSL auto-signés :
Autorise les connexions à un serveur SMTP utilisant un certificat SSL auto-signé.Attention : Autoriser des certificats SSL auto-signés peut induire des problèmes de sécurité.


Les options par défaut, dans l'ordre : OUI / OUI / NON ne fonctionnaient donc pas dans mon cas.
Les bonnes options semblent être (en tout cas pour un serveur mail chez OVH) : NON / OUI / NON
Modifié en dernier par geric le 20 Aoû 2017 à 13:01, modifié 2 fois.
geric
Posteur néophyte
Posteur néophyte
 
Messages: 40
Enregistré le: 02 Nov 2008 à 00:43

Re: Erreur encodage envoi email de masse depuis maj 3.2.1

Messagepar galixte » 20 Aoû 2017 à 17:35

Merci pour tes investigations. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Erreur encodage envoi email de masse depuis maj 3.2.1

Messagepar geric » 20 Aoû 2017 à 18:21

De rien. :wink:
Suis-je le seul à avoir été confronté à ce problème ?

Je note ce sujet comme réglé mais si vous avez d'autres infos, surtout merci de le faire savoir.
geric
Posteur néophyte
Posteur néophyte
 
Messages: 40
Enregistré le: 02 Nov 2008 à 00:43

Re: Erreur encodage envoi email de masse depuis maj 3.2.1

Messagepar galixte » 20 Aoû 2017 à 18:44

Aucune idée, peut-être un problème spécifique à ton hébergeur, mais puisque ce dernier est un mastodonte, je ne doute pas que cela pourra servir à d’autres. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Erreur encodage envoi email de masse depuis maj 3.2.1

Messagepar geric » 20 Aoû 2017 à 18:53

Oui, je pense que beaucoup passent par OVH pour leurs domaines.
Ces trois options sont-elles bien nouvelles sur la version 3.2.1 ou ma version de 3.2.0 n'était pas "complète" ?

Edit 20h25 :

Une confirmation de mon problème initial ici :

http://guide.ovh.com/ConfigurationEmail
Vous devez aussi cocher l'option "serveur d'envoi/smtp requiert une authentification" (pas SSL ni cryptée) en utilisant les mêmes paramètres que pour le serveur entrant POP.
geric
Posteur néophyte
Posteur néophyte
 
Messages: 40
Enregistré le: 02 Nov 2008 à 00:43

Re: Erreur encodage envoi email de masse depuis maj 3.2.1

Messagepar galixte » 20 Aoû 2017 à 20:19

Ces trois options existent sous phpBB 3.1.x donc elles ne sont pas nouvelles, par défaut à l’installation elles sont toutes trois désactivées. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Erreur encodage envoi email de masse depuis maj 3.2.1

Messagepar geric » 20 Aoû 2017 à 21:55

OK merci. :wink:
La conversion 3.1.9 vers 3.2.0 de mon forum ne s'est donc pas entièrement bien déroulée puisque je n'avais pas ces options sous 3.2.0.
geric
Posteur néophyte
Posteur néophyte
 
Messages: 40
Enregistré le: 02 Nov 2008 à 00:43


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité