Bug identification administrateur ?

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Bug identification administrateur ?

Messagepar silenus » 16 Fév 2017 à 17:27

Bonjour.

Je rencontre un problème mineur qui était présent en 3.1.x qui persiste en 3.2.0.

Est-ce que quelqu'un pourrait tester et vérifier avoir le même problème que moi avant de le signaler ?

Contexte :

Je suis connecté avec mon compte usager, qui a les privilèges d'administrateur.
Je vais sur la page des notifications : ucp.php?i=ucp_notifications

Dans la liste des notifications, j'ai plusieurs comptes d'usagers qui demandent l'activation de leur compte (j'ai paramétré le forum de façon à ce que chaque compte soit validé par l'admin) "activation de compte requise .... " .

Disons que j'ai deux demandes d'activation de comptes mentionnées dans les notifications.
Dans la liste des notifications, je fais clic droit puis ouvrir dans un nouvel onglet, et ce pour chaque compte (ce qui me fait trois onglets ouverts dans mon navigateur, la liste des notifications + deux panneaux d'info sur membre memberlist.php?mode=viewprofile&u=xxx)

Je vais sur l'onglet d'un des viewprofile, je choisis "administrer le membre" en vue de vérifier les infos et activer le compte.
Bien qu'identifié pour la connexion au forum, phpbb me redemande une identification car c'est le premier accès à l'ACP (normal).
J'accède sans problème à la page, je fais ma validation de compte si nécessaire.

Je ferme l'onglet, et je vais sur l'autre onglet contenant le viewprofile du second compte.
Je fais là encore "administrer le membre" et là j'ai systématiquement une page blanche.
Je rafraîchis la page (dans l'esprit de mise à jour de la session, je ne sais pas comment son stockées les variables indiquant que l'identification acp est ok), autant c'est cela qui bloque? Non, toujours page blanche.
Il faut que je fasse un "back" dans le navigateur, pour revenir sur le viewprofile et recliquer sur "administrer le membre" pour que ca marche (accès direct à la page permettant de valider le compte).

J'ai refais plusieurs essais, c'est systématique.
Autres essais :
Si dans un premier temps j'accède à un compte, m'identifie pour l'acp, et ensuite revient sur la liste des notifications, là je peux ouvrir sans problème, dans plusieurs onglets les viewprofile et accéder à administrer le membre sans avoir la page blanche. C'est si j'ouvre plusieurs onglets de viewprofile avant une première identification pour accéder à l'ACP que ce "problème" se produit.

J'utilise firefox 51.0.1 , non testé sur d'autres navigateurs.

Cordialement.
silenus
Posteur néophyte
Posteur néophyte
 
Messages: 32
Enregistré le: 09 Fév 2017 à 19:40

Re: Bug identification administrateur ?

Messagepar galixte » 11 Mar 2017 à 05:57

Salut,

en effet tu as constaté un comportement qui devrait en toute logique te permettre d’accéder à l’administration du second utilisateur, puisque tu as accédé au panneau d’administration lors de l’accès au profil du premier utilisateur.

Me concernant je ne rencontre pas de page blanche mais une simple redirection vers l’index du forum, ce qui est moins dommageable.

« Le problème » est sans doute lié au fait que ton SID change entre le temps où tu es simplement connecté (et que tu ouvres tes deux onglets supplémentaires) et le temps où tu accèdes pour la première fois au panneau d’administration. D’où l’impossibilité (même en rechargeant la page) de contourner cette sécurité (oui, c’en est une).
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10524
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité