[Réglé] Page blanche dans ACP/Gérer les extensions

Forum de support pour les questions concernant l'utilisation de phpBB 3.2, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Page blanche dans ACP/Gérer les extensions

Messagepar BBBenj » 07 Fév 2017 à 13:05

Bonjour,

Tout d'abord, désolé si je ne poste pas au bon endroit, j'ai essayé de trouver la place la plus appropriée.

Mon forum provisoire (migration en cours de préparation entre 3.0.14 vers 3.2) : www.irp-smart-rx.com/transfert
phpBB 3.2
Compte : Test
MdP : Test1234
(compte administrateur donné uniquement par MP :wink: )

Mon problème :
Après avoir supprimé en bonne et due règle deux extensions qui ne me convenaient pas (upload-master utilisant helper-master https://www.phpbb.com/community/viewtop ... &t=2268786), je n'arrive plus à accéder à la page "Gérer les extensions" dans le ACP : page blanche.

J'ai restauré la base de donnée à une date précédent l'installation, mais les problèmes restent identiques.

Auriez-vous une solution à me proposer, s'il-vous-plaît ? Merci d'avance.
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 19:38

Re: Page blanche dans ACP/Gérer les extensions

Messagepar manond » 08 Fév 2017 à 12:01

Bonjour

Une première piste , vider le cache ...
Modifié en dernier par manond le 08 Fév 2017 à 14:37, modifié 1 fois.
Mon hébergeur .. Phpbb-services
manond
Posteur habitué
Posteur habitué
 
Messages: 268
Enregistré le: 22 Nov 2008 à 00:22

Re: Page blanche dans ACP/Gérer les extensions

Messagepar pierredu » 08 Fév 2017 à 12:11

Les extensions ont-elles été désinstallées proprement, ou à la hussarde en supprimant les fichiers ?
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1051
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Page blanche dans ACP/Gérer les extensions

Messagepar BBBenj » 08 Fév 2017 à 13:31

Bonjour,

Merci pour vos réponses.
manond a écrit:Une premier piste , vider le cache ...

C'est bien sûr une des premières choses que j'ai faite car j'ai accès à tout dans le ACP sauf cette page. J'ai également purgé le cache de Firefox, j'ai testé depuis Opéra, depuis mon téléphone... Et malheureusement ça n'a rien réglé. Du tout.

pierredu a écrit:Les extensions ont-elles été désinstallées proprement, ou à la hussarde en supprimant les fichiers ?

Oui, mais je n'ai peut-être pas respecté un éventuel ordre à la désinstallation, maintenant que tu en parles. En effet, il faut mettre Helper avant de mettre UploadImage, sinon UploadImage indique que Helper est nécessaire.

J'écris "peut-être" car je ne me souviens plus et je ne sais plus lequel j'ai supprimé avant l'autre. Désolé.


[Edit 8 février 2017, 19h32] Une précision déjà apportée mais qui n'a peut-être pas été remarquée : j'ai restauré la base de données, donc nécessairement à une date ANTÉRIEURE à celle où j'ai désinstallé les extensions. Du coup, ça revient à des extensions désinstallées à la sauvage. J'ai malgré tout essayé de remettre en ligne les versions des extensions, mais toujours page blanche.
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 19:38

Re: Page blanche dans ACP/Gérer les extensions

Messagepar pierredu » 08 Fév 2017 à 22:29

Dans ce cas, il faut y aller à la main.
Dans phpMyAdmin (ou similaire), va dans la table phpbb3_ext (le préfixe peut varier) et met 0 dans la colonne ext_active pour tes deux extensions. Vide le cache. Avec un outil FTP, va supprimer les fichiers dans fournisseur/extension (pour les deux).

Ce sont les manœuvres minimales (il restera des scories, mais normalement sans trop d'importance).

Essaie de rouvrir la page qui coince.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1051
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Page blanche dans ACP/Gérer les extensions

Messagepar BBBenj » 08 Fév 2017 à 23:16

Merci pour ta réponse, Pierredu.

J'avais également pensé à cette solution, mais ça ne marche pas.

Bon, pour te répondre complètement, dans la table phpbb_ext, je n'ai que les 3 extensions actuellement actives sur le forum :
  • board3/portal
  • dmzx/memberlistavatar
  • dmzx/downloadlog
Et pas de trace de forumhulp/helper ni de forumhulp/UploadImage. Rien.

De la même manière, avant que je ne les rajoute ce soir via ftp ces dossiers (et leurs fichiers), ils n'étaient plus présents dans le répertoire ext.

Et le cache a été vidé, via l'ACP mais aussi via ftp et le répertoire /cache/production.

Et j'ai toujours cette fichue page blanche.

J'ai regardé si je voyais des modifications à d'autres emplacements de la table, mais je n'ai rien trouvé (ce qui ne signifie nullement qu'il n'y en a pas).
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 19:38

Re: Page blanche dans ACP/Gérer les extensions

Messagepar pierredu » 08 Fév 2017 à 23:32

Une page blanche, c'est normalement une erreur 500. À ma connaissance, Chrome est le seul navigateur à afficher ce renseignement. Cela vaut la peine de faire l'essai. Après ça, il faut aller dans les journaux.

Encore un point. L'erreur 500 provient souvent d'un code BOM au début de certains fichiers (surtout les fichiers de langue). Tu n'aurais pas édité des fichiers avec des éditeurs « malpropres » (comme Word ou Notepad tout court) ?
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1051
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Page blanche dans ACP/Gérer les extensions

Messagepar BBBenj » 09 Fév 2017 à 00:01

Re...

(oui, je sais, je ne respecte pas le up de 24h, mais c'est pour une bonne cause).

J'ai trouvé la raison du problème. Cette [censuré] de [censuré] :twisted: :evil: :twisted: :evil: d'extension, en s'installant, vient modifier le code de \includes\acp\acp_extensions.php, en retirant :
Code: Tout sélectionner
, $phpbb_dispatcher

en ligne 40.

Dégoûté.

Mais en tout cas, je vous remercie de vous être penchés sur mon problème et d'avoir contribué à le résoudre.
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 19:38


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités