Redirection au mauvais port

Forum de support pour les questions concernant l'utilisation de phpBB 3.1, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

Redirection au mauvais port

Messagepar racacax » 02 Nov 2017 à 15:08

Bonjour,
Je suis administrateur du forum http://forum-racacax.ga/ . Je suis actuellement en version 3.1.11 et je souhaite dans les mois à venir passer à la branche 3.2. On me prête un hébergement pour mon forum actuellement mais il est en PHP 5.3 donc pas assez récent pour phpBB 3.2. Étant donné que j'ai une bonne connexion et un appareil qui ne me sert plus, j'ai décidé de tenter d'héberger mon forum chez moi. Niveau fluidité ça a l'air d'être bon.
En local mon forum est hébergé sur http://192.168.1.24:8080
En ligne, il est http://86.253.177.90 (ou http://test-domaine.ga)

J'ai dut forcer dans les paramètres du serveurs à ce que ça soit test-domaine.ga en domaine et 80 en port car sinon, lorsque je postais un message ou me connectais, ça redirigeait vers http://86.253.177.90:8080 au lieu de http://86.253.177.90 . Maintenant c'est bon mais comme je l'héberge chez moi, je suis obligé d'accéder comme ceci de mon côté : http://192.168.1.24:8080/ Mais du coup ça ne fonctionne pas parce que lorsque je me connecte, ça tente de rediriger vers http://test-domaine.ga dont je n'ai pas accès étant donné que je suis dans le domicile. Je suis obligé de passer par un proxy et ce n'est pas super pratique.

Avez-vous une idée du problème ?

Merci
Image | Image
Avatar de l’utilisateur
racacax
Apprenti-posteur
Apprenti-posteur
 
Messages: 105
Enregistré le: 11 Oct 2014 à 10:51

Re: Redirection au mauvais port

Messagepar galixte » 03 Nov 2017 à 07:12

Salut,

…mais comme je l'héberge chez moi, je suis obligé d'accéder comme ceci de mon côté : http://192.168.1.24:8080/


ce n'est pas un problème de l'application phpBB, c'est un problème réseau, sans doute au niveau de ton routeur, puisque tu ne peux pas accéder à ce nom de domaine test-domaine.ga depuis ton réseau local.

Aussi, as-tu redirigé depuis ta box le port 80 du WAN (86.253.177.90, IP publique de ta box) vers le port 8080 de l’IP de la machine utilisée comme serveur (http://192.168.1.24) ?

Autrement, pourquoi ne pas avoir utilisé le port 80 pour la machine hébergeant ton forum ? Cela aurait grandement simplifié le problème, en modifiant le fichier C:\Windows\system32\drivers\etc\hosts sur ton poste client (la machine qui te sert à naviguer sur le Web) tu aurais eu juste à saisir l’information suivante : 192.168.1.24 test-domaine.ga. Ne cherche pas à y ajouter le port 8080 ça ne fonctionnera pas. :mrgreen:
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités