[Réglé] SMTP 550 Please Retry Later - Online.net

Forum de support pour les questions concernant l'utilisation de phpBB 3.1, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] SMTP 550 Please Retry Later - Online.net

Messagepar cklckl67 » 01 Sep 2016 à 11:14

Bonjour,

Ma version phpBB est: la Version 3.0.12

Cela fait quelque temps que je ne reçois plus de notifications email.
Malheureusement, en parcourant le forum je n'ai pas trouvé de réponses à mon problème.

Exemple qui montre l'incident
A travers l'interface phpBB, lorsque j'essaye d'envoyer un email à un utilisateur :
Par exemple, en tant qu'administrateur, j'essaye d'envoyer un email vers l'utilisateur CKL,
le mail ne part pas, et j'obtiens dans le journal d'erreur le message ci-dessous

Code: Tout sélectionner
Erreur d’e-mail
» EMAIL/SMTP
/phpBB3/memberlist.php

Un problème est survenu lors de l’envoi de l’e-mail à la ligne 1063. Réponse: 550 Please Retry Later. 
.
Backtrace
Connecting to smtpauth.online.net:587
LINE: 1047 <- 220 smtpauth-dc2-1.online.net ESMTP Exim 4.82 Ubuntu Wed, 31 Aug 2016 11:33:13 +0200 
# EHLO pf-lb-2.online.net
LINE: 1319 <- 250-smtpauth-dc2-1.online.net Hello pf-lb-2.online.net [62.210.185.3] 
LINE: 1319 <- 250-SIZE 52428800 
LINE: 1319 <- 250-8BITMIME 
LINE: 1319 <- 250-PIPELINING 
LINE: 1319 <- 250-AUTH PLAIN LOGIN 
LINE: 1319 <- 250-STARTTLS 
LINE: 1319 <- 250 HELP 
# AUTH PLAIN
LINE: 1427 <- 334 
# Omitting sensitive information
LINE: 1434 <- 235 Authentication succeeded 
# MAIL FROM:<christian.<dans le fichier il y mon vrai nom>@geosolterm.fr>
LINE: 1063 <- 550 Please Retry Later.


Fonction Mail

Si j'essaye directement la fonction mail suivante, en la lançant de mon interface

Code: Tout sélectionner
<?php
 
// Mettez ici votre adresse valide
$to = "christian.<dans le fichier il y mon vrai nom>@geosolterm.fr";
 
// Sujet du message 
$subject = "Test fonction mail() de PHP";
 
// Corps du message, écrit en texte et encodage iso-8859-1
$message = "Bonjour,\nl'envoi du mail via PHP a réussi. Le webmaster\n";
 
// Entêtes du message
$headers = ""; // on vide la variable
$headers = "From: Webmaster Site <webmaster@domaine.ext>\n"; // ajout du champ From
// $headers = $headers."MIME-Version: 1.0\n"; // ajout du champ de version MIME
$headers = $headers."Content-type: text/plain; charset=iso-8859-1\n"; // ajout du type d'encodage du corps
 
// Appel à la fonction mail
if ( mail($to, $subject, $message, $headers) == TRUE )
{
   echo "Envoi du mail reussi.";
}
else
{
   echo "Erreur : l'envoi du mail a échoué.";
}
 
?>

Cela fonctionne parfaitement, je reçois bien un mail dans ma boite, et en retour de fonction, le message: "Envoi du mail reussi."

Autres Ports

J'ai essayé d'utiliser d'autres ports, qui sont autorisé par online.net
25
587
2525
--> Cela ne marche pas mieux

Désactivation serveur SMTP

Si je désactive "Utiliser un serveur SMTP pour l’envoi d’e-mails" j'ai l'erreur

Code: Tout sélectionner
admin	78.229.20.105	31 Aoû 2016 12:19 pm	Erreur d’e-mail
» EMAIL/PHP/mail()
/phpBB3/memberlist.php



Pourriez-vous m'aider ?

Merci d'avance

Christian
Modifié en dernier par cklckl67 le 05 Sep 2016 à 08:42, modifié 2 fois.
cklckl67
Posteur néophyte
Posteur néophyte
 
Messages: 24
Enregistré le: 01 Sep 2016 à 10:58
Localisation: Alsace

Re: Mail ne fonctionne plus

Messagepar Steph » 01 Sep 2016 à 13:59

Salut,

Avant toutes choses, il faut te mettre à jour en version 3.0.14 ou mieux encore ... 3.1

Cela peut peut être résoudre ton problème, mais dans tous les cas le support ne peut se faire que sur la dernière version en date.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18404
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Mail ne fonctionne plus

Messagepar cklckl67 » 01 Sep 2016 à 23:12

Parfait.

J'ai mis la dernière version :-)
3.1.9

Malheureusement, j'ai toujours le même problème

Code: Tout sélectionner
Une erreur de courrier électronique est survenue
» EMAIL/SMTP
/phpBB3/memberlist.php

Une erreur est survenue lors de l’envoi du courrier électronique à la ligne 1050. Réponse : 550 Please Retry Later. 
.
Backtrace
Connecting to smtpauth.online.net:587
LINE: 1034 <- 220 smtpauth-dc2-1.online.net ESMTP Exim 4.82 Ubuntu Thu, 01 Sep 2016 23:09:24 +0200 

# EHLO pf-lb-2.online.net
LINE: 1383 <- 250-smtpauth-dc2-1.online.net Hello pf-lb-2.online.net [62.210.185.3] 

LINE: 1383 <- 250-SIZE 52428800 

LINE: 1383 <- 250-8BITMIME 

LINE: 1383 <- 250-PIPELINING 

LINE: 1383 <- 250-AUTH PLAIN LOGIN 

LINE: 1383 <- 250-STARTTLS 

LINE: 1383 <- 250 HELP 

# STARTTLS
LINE: 1428 <- 220 TLS go ahead 

# EHLO pf-lb-2.online.net
LINE: 1383 <- 250-smtpauth-dc2-1.online.net Hello pf-lb-2.online.net [62.210.185.3] 

LINE: 1383 <- 250-SIZE 52428800 

LINE: 1383 <- 250-8BITMIME 

LINE: 1383 <- 250-PIPELINING 

LINE: 1383 <- 250-AUTH PLAIN LOGIN 

LINE: 1383 <- 250 HELP 

# AUTH PLAIN
LINE: 1486 <- 334 

# Omitting sensitive information
LINE: 1493 <- 235 Authentication succeeded 

# MAIL FROM:<christian.******@geosolterm.fr>
LINE: 1050 <- 550 Please Retry Later. 


Merci d'avance

Christian
cklckl67
Posteur néophyte
Posteur néophyte
 
Messages: 24
Enregistré le: 01 Sep 2016 à 10:58
Localisation: Alsace

Re: Mail ne fonctionne plus

Messagepar Steph » 02 Sep 2016 à 06:50

Il est préférable d'utiliser la fonction mail()

Tu l'a déjà fait, mais regarde cette documentation : Tester la fonction mail() de votre hébergeur.

As-tu accès aux logs error de ton serveur, cela peut peut être nous en apprendre un peu plus.

Par contre, c'est sympathique d'avoir enlevé les copyrights en bas du forum :evil:

Le copyright des styles/extensions doit être conservé pour recevoir du support par les membres de l'équipe.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18404
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Mail ne fonctionne plus

Messagepar cabot » 02 Sep 2016 à 08:22

Hello,

Le copyright n'a pas été supprimé, c'est le overall_footer.html qui ne charge pas.

cklckl67, tu n'as pas d'autres erreurs, notamment avec les fonctionnalités javascript ?
Ouvre un sujet dédié au problème de fichier non chargé.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26802
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Mail ne fonctionne plus

Messagepar cklckl67 » 02 Sep 2016 à 10:03

Hello,

Tout d'abord, je n'ai pas enlevé les copyrights en bas du forum. :oops:
J'ai uniquement voulu modifier le style, et je suis passé par défaut sur le style Elegance.
(Problème résolu: voir ci-dessous)

Concernant le test mail,j'ai chargé le fichier test_mail.php vers mon hébergeur, tout est presque OK.
Je reçois bien une réponse dans ma boite email.

Juste petite remarque à ce sujet.
Quand j'envoie l'adresse à
christian.***@free.fr
--> Expéditeur du mail = webmaster@geosolterm.fr
christian.****@geosolterm.fr
--> Expéditeur du mail = christian.****@geosolterm.fr
christian.****@gmail.com
--> je ne recois pas de mail


Nouveau Test (Avec serveur SMTP)

Si à travers le panneau membre (avec compte admin) j'essaie d'envoyer un mail à l'utilisateur ckl, j'obtiens

Pour info:
Le compte admin a comme @email = christian.****@geosolterm.fr
Le compte ckl a comme @email = christian.****@free.fr

Code: Tout sélectionner
Une erreur de courrier électronique est survenue
» EMAIL/SMTP
/phpBB3/memberlist.php

Une erreur est survenue lors de l’envoi du courrier électronique à la ligne 1050. Réponse : 550 Please Retry Later. 
.
Backtrace
Connecting to smtp.online.net:587
LINE: 1034 <- 220 smtpauth-dc2-1.online.net ESMTP Exim 4.82 Ubuntu Fri, 02 Sep 2016 09:59:26 +0200 

# EHLO pf-lb-2.online.net
LINE: 1383 <- 250-smtpauth-dc2-1.online.net Hello pf-lb-2.online.net [62.210.185.3] 

LINE: 1383 <- 250-SIZE 52428800 

LINE: 1383 <- 250-8BITMIME 

LINE: 1383 <- 250-PIPELINING 

LINE: 1383 <- 250-AUTH PLAIN LOGIN 

LINE: 1383 <- 250-STARTTLS 

LINE: 1383 <- 250 HELP 

# STARTTLS
LINE: 1428 <- 220 TLS go ahead 

# EHLO pf-lb-2.online.net
LINE: 1383 <- 250-smtpauth-dc2-1.online.net Hello pf-lb-2.online.net [62.210.185.3] 

LINE: 1383 <- 250-SIZE 52428800 

LINE: 1383 <- 250-8BITMIME 

LINE: 1383 <- 250-PIPELINING 

LINE: 1383 <- 250-AUTH PLAIN LOGIN 

LINE: 1383 <- 250 HELP 

# AUTH PLAIN
LINE: 1486 <- 334 

# Omitting sensitive information
LINE: 1493 <- 235 Authentication succeeded 

# MAIL FROM:<christian.******@geosolterm.fr>
LINE: 1050 <- 550 Please Retry Later. 


Nouveau Test (Sans serveur SMTP)
Lorsque je désactive dans le panneau de config admin:
--->Envoyer les courriers électroniques par un serveur SMTP : NON
J'obtiens

Code: Tout sélectionner
Une erreur de courrier électronique est survenue
» EMAIL/PHP/mail()
/phpBB3/ucp.php

ou
Code: Tout sélectionner
Une erreur de courrier électronique est survenue
» EMAIL/PHP/mail()
/phpBB3/memberlist.php

selon si j'essaye d'envoyer un message privé ou message mail vers l'utilisateur CKL



cklckl67, tu n'as pas d'autres erreurs, notamment avec les fonctionnalités javascript ?
Ouvre un sujet dédié au problème de fichier non chargé.


Non pas d'autres erreurs.
J'ai refais un tour dans la partie admin, et indiqué que le style "Elegance", héritait de "prosilver"
Là, je vois à nouveau le Footer.. :D
Peut-être lié à cela :-)

Merci d'avance pour votre aide

Christian


PS: Comme adresse email sur le forum php (celui-ci) j'ai christian.******@gmail.com.
C'est normal que je ne reçois pas de notifications email sur gmail, lorsque quelqu'un contribue à cet article ?
cklckl67
Posteur néophyte
Posteur néophyte
 
Messages: 24
Enregistré le: 01 Sep 2016 à 10:58
Localisation: Alsace

Re: Mail ne fonctionne plus

Messagepar Steph » 02 Sep 2016 à 11:57

Désolé concernant le copyright, depuis le tel je n'ai pas fait attention que le footer n'était pas chargé. :oops:

Utilise plutôt la fonction mail() au lieu de SMTP et essai ceci, on ne sait jamais :

Va dans l'administration > onglet "Général" > "Paramètres des e-mails" > passe l'option "Taille des paquets d’e-mails" a "0" > valide le formulaire.

Sur ton FTP, vide le contenu du dossier cache (fichiers et dossiers à l'intérieur) sauf les fichiers .hatccess et index.html.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18404
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Mail ne fonctionne plus

Messagepar cklckl67 » 02 Sep 2016 à 14:07

J'ai vidé le dossier Cache comme tu l'as proposé.
Par contre je n'ai pas trouvé dans les options:
Taille des paquets d’e-mails = 0

J'ai par contre:
Nombre de courriers électroniques envoyés en une seule fois : 0

J'ai refais le test avec fonction mail
Toujours même problème. :( :(

Code: Tout sélectionner
Une erreur de courrier électronique est survenue
» EMAIL/PHP/mail()
/phpBB3/memberlist.php
cklckl67
Posteur néophyte
Posteur néophyte
 
Messages: 24
Enregistré le: 01 Sep 2016 à 10:58
Localisation: Alsace

Re: Mail ne fonctionne plus

Messagepar Steph » 02 Sep 2016 à 14:16

Oui c'est parce que tu n'utilises pas notre traduction du coup cela différé sur pas mal de choses.

L'option était déjà sur 0 ?

Ton adresse mail est bien active ?
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18404
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Mail ne fonctionne plus

Messagepar cklckl67 » 02 Sep 2016 à 15:04

Oui, l''option était déjà à Zéro

Que veux tu dire par adresse mail valide ?
Si j'envoie un mail de mon boulot (adresse en @alcatel.com) à
christian.****@geosolterm.fr
christian.****@free.fr
tout fonctionne. :)

Aussi comme spécifié
Le compte admin a comme @email = christian.****@geosolterm.fr
Le compte ckl a comme @email = christian.****@free.fr

Autre Test.
Lorsque j'envoie un mail de masse aux administrateurs (en fait il n'y a qu'un seul admin, c'est christian.****@geosolterm.fr) à travers l'interface admin, j'ai le message.

Code: Tout sélectionner
Une ou plusieurs erreurs sont survenues lors de l’envoi du courrier électronique. Pour plus d’informations, veuillez consulter l’historique des erreurs.


et là l'erreur est :

Code: Tout sélectionner
Une erreur de courrier électronique est survenue
» EMAIL/PHP/mail()
/phpBB3/adm/index.php


J'ai demandé aux admins de Online.net s'il y avait des Logs.
Tout est OK coté hébergeur

En aparté.

Il faudrait peut-être déplacer ce topic dans le Forum phpBB 3.1, comme je suis passé sur cette version 8)

Merci d'avance pour votre aide.
Cela doit coincer quelque part mais où ?? :idea:

Christian
cklckl67
Posteur néophyte
Posteur néophyte
 
Messages: 24
Enregistré le: 01 Sep 2016 à 10:58
Localisation: Alsace

Re: Mail ne fonctionne plus

Messagepar cklckl67 » 03 Sep 2016 à 09:05

Sujet déplacé sur:
support-utilisation-phpbb31/sujet208527.html

Je clôturerais ce topic lorsque le problème sera fixé 8)
cklckl67
Posteur néophyte
Posteur néophyte
 
Messages: 24
Enregistré le: 01 Sep 2016 à 10:58
Localisation: Alsace

Re: Mail ne fonctionne plus

Messagepar Steph » 03 Sep 2016 à 09:34

Votre sujet a été déplacé par un membre de l'équipe.

Inutile d'ouvrir plusieurs sujets pour le même souci.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18404
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Mail ne fonctionne plus

Messagepar cklckl67 » 03 Sep 2016 à 16:05

Bien entendu.

Quelqu'un a une idée d'ou pourrait venir mon problème. :idea: :idea:

Pour info, le test de la fonction mail() est possible sur
http://geosolterm.fr/phpBB3/test_mail.php

Merci d'avance

Christian
cklckl67
Posteur néophyte
Posteur néophyte
 
Messages: 24
Enregistré le: 01 Sep 2016 à 10:58
Localisation: Alsace

Re: Mail ne fonctionne plus

Messagepar Steph » 03 Sep 2016 à 16:09

Je viens de tester avec une adresse mail jetable et cela fonctionne.

C'est surement ton adresse mail qui est out
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18404
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Mail ne fonctionne plus

Messagepar cklckl67 » 03 Sep 2016 à 17:01

Hummm, si seulement,

Je viens de vérifier dans phpmyadmin s'il ne pouvait pas rester une adresse email invalide, mais non, tout est OK

C'est à en devenir chèvre ...

mes adresses sont bien valides comme expliqué ci-dessus

Si j'envoie un mail de mon boulot (adresse en @alcatel.com) à
christian.****@geosolterm.fr
christian.****@free.fr
tout fonctionne. :)
cklckl67
Posteur néophyte
Posteur néophyte
 
Messages: 24
Enregistré le: 01 Sep 2016 à 10:58
Localisation: Alsace

Suivante

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Google [Bot] et 2 invités