Index de recherche qui se vide

Forum de support pour les questions concernant l'utilisation de phpBB 3.1, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Index de recherche qui se vide

Messagepar Parmelan » 28 Aoû 2016 à 01:17

Bonjour,

J'ai tenté à plusieurs reprises de créer des Index mais sans succès. Ou plutôt, cela fonctionne, mais au bout d'un certain temps, je dirais quelques heures, tout disparait.
Du coup le moteur de recherche ne fonctionne pas.

Qu'en pensez vous que puis-je faire pour remédier à ce problème ?

J'indexe :
Image

Et quelques temps après, plus rien :
Image
Modifié en dernier par Parmelan le 28 Aoû 2016 à 12:09, modifié 1 fois.
Parmelan
Posteur néophyte
Posteur néophyte
 
Messages: 17
Enregistré le: 07 Aoû 2016 à 20:06

Re: Indexation pour la recherche

Messagepar cocooncrash » 28 Aoû 2016 à 08:58

Bonjour,
Comme écrit sur ton panneau vert, une seule indexation ne peut fonctionner, or tu en as deux, il faut supprimer l'une des deux qui peut faire bugguer les deux.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7700
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Indexation pour la recherche

Messagepar Parmelan » 28 Aoû 2016 à 12:07

Bonjour,

Justement j'ai fait une deuxième indexation pour voir si ça fonctionnait mieux mais le problème était déjà présent avant.

Plus précisemment c'est l'index phpBB Native fulltext qui se vide tout seul (on le voit sur ma capture d'écran, les mots référencés ont diparu).
Parmelan
Posteur néophyte
Posteur néophyte
 
Messages: 17
Enregistré le: 07 Aoû 2016 à 20:06

Re: Index de recherche qui se vide

Messagepar Parmelan » 29 Aoû 2016 à 19:22

Un exemple concret avec ces captures d'écran prises à quelques heures d'intervalle, on voit que l'indexation a disparu ou presque :

Image


Image


Comment cela peut-il arriver je ne comprends pas ... :?
Parmelan
Posteur néophyte
Posteur néophyte
 
Messages: 17
Enregistré le: 07 Aoû 2016 à 20:06

Re: Index de recherche qui se vide

Messagepar cocooncrash » 30 Aoû 2016 à 15:45

tes tables en base de donnée ne seraient pas en innodb?
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7700
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Index de recherche qui se vide

Messagepar Parmelan » 30 Aoû 2016 à 20:50

Bonjour,

Si, précisément :D
Image

Elles ont été créées ainsi lors de l'installation, est-ce problématique ? J'avoue que je n'y connais rien :oops:

Merci
Parmelan
Posteur néophyte
Posteur néophyte
 
Messages: 17
Enregistré le: 07 Aoû 2016 à 20:06

Re: Index de recherche qui se vide

Messagepar cocooncrash » 31 Aoû 2016 à 08:38

decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7700
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Index de recherche qui se vide

Messagepar Henrique » 27 Déc 2016 à 04:03

Bonjour à tous,
J'ai exactement le même problème d'index de recherche, à ceci près que mon index se vide complètement au bout de quelques heures. A la suite de cela, la réponse pour toute recherche est "0 résultat".
Malheureusement, la solution qui consiste à passer d'innoDB en MyISAM avec les commandes du type
Code: Tout sélectionner
    ALTER TABLE phpbb_acl_groups ENGINE=MyISAM;
    ALTER TABLE phpbb_acl_options ENGINE=MyISAM;
    ALTER TABLE phpbb_acl_roles ENGINE=MyISAM;
    ALTER TABLE phpbb_acl_roles_data ENGINE=MyISAM;
    ALTER TABLE phpbb_acl_users ENGINE=MyISAM;

etc. ne règle pas le problème chez moi. Quant à passer en indexation MySQL fulltext, dans Général/Configuration du serveur/paramètres de recherche cela me répond toujours avec l'erreur "Le formulaire envoyé n’est pas valide. Essayez à nouveau."
Il semblerait que la seule chose à faire soit d'attendre que son hébergeur passe à MySQL 5.6 au moins (pas de bol, je suis à 5.5.52).
Ce qui est fou, c'est que l'indexation est tout de même possible et que ça marche quelques heures.
Je serais curieux de savoir si quelqu'un a un hébergeur avec MySQL à moins de 5.6 et pour qui l'indexation fonctionne, voire une solution.
Henrique
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 22 Oct 2003 à 16:59

Re: Index de recherche qui se vide

Messagepar cocooncrash » 27 Déc 2016 à 10:22

Bonjour,
Merci d'ouvrir ton propre sujet. C'est un sujet/auteur.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7700
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Index de recherche qui se vide

Messagepar Henrique » 27 Déc 2016 à 11:34

Ok, je craignais de vraiment faire doublon, vu que c'est exactement le même problème et qu'il n'a pas vraiment été réglé mais c'est comme vous voulez.
Henrique
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 22 Oct 2003 à 16:59

Re: Index de recherche qui se vide

Messagepar galixte » 30 Déc 2016 à 05:20

Salut,
cocooncrash a écrit:Ben, de ce que j 'ai pu lire, native fulltext ne fonctionne pas avec innodb :

https://www.phpbb.com/community/viewtopic.php?f=466&t=2285881&sid=69b63782215cb6782d5087b525622900&start=15#p14207431


il n’est pas dit que cela n’est pas compatible, il est dit que pour que cela soit compatible il est nécessaire d’utiliser une version supérieure ou égale à MySQL 5.6.4.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10150
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités