[Réglé] Nouveaux utilisateurs, affichage de lignes d'erreur

Forum de support pour les questions concernant l'utilisation de phpBB 3.1, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar Bege » 11 Aoû 2016 à 11:56

Bonjour à tous,

sur mon forum quand on clique sur "Nouveaux utilisateurs enregistrés" en bas de page, la liste s'affiche bien, mais il y a ces lignes d'erreur :
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 77
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 77
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 77
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 97
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 97
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 97
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 104
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 104
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 104
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 113
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 113
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 113
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 126
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 126
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 126
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 129
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 129
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 1532: Undefined offset: 129


ça peut venir de quoi svp?

voilà l'adresse du forum : http://www.bloooo.fr/forums/index.php
merci pour votre aide
Modifié en dernier par Bege le 19 Aoû 2016 à 16:17, modifié 2 fois.
Le 1er portail Francophone de machines à vapeur et moteurs à air chaud :
Le portailhttp://www.blooo.fr
le Forum : http://www.bloooo.fr/forums/
Avatar de l’utilisateur
Bege
Roi des posts
Roi des posts
 
Messages: 806
Enregistré le: 12 Jan 2010 à 14:31
Localisation: Rouhling (57)

Re: Nouveaux utilisateurs, bug?

Messagepar Skouat » 11 Aoû 2016 à 12:14

Bonjour,

C'est normal qu'il y ait autant de compte "invité" ?

Avez-vous supprimé des comptes ? si oui comment avez-vous procédé ?

--- EDIT ---

Ah non, ca ne semble pas être une suppression de comptes,

Avez-vous installé des extensions ?
Skouat
Traducteur
Traducteur
 
Messages: 13790
Enregistré le: 02 Avr 2008 à 20:47

Re: Nouveaux utilisateurs, bug?

Messagepar Steph » 11 Aoû 2016 à 13:37

Salut,

Ça c'est un titre super explicite :!:
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18404
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Nouveaux utilisateurs, bug?

Messagepar Bege » 11 Aoû 2016 à 15:49

Skouat a écrit:Avez-vous installé des extensions ?

oui plusieurs, mais il me semble bien que ces lignes d'erreur sont apparues bien après, voilà les extensions installées :
Add User
Annual Stars
Board Rules
carte-des-membres
FAQ manager
Left Profile
phpBB Display Age Users
Quickedit
Site internet dans le mini profil
Sortables Captcha

Steph a écrit:Salut,
Ça c'est un titre super explicite :!:

euh mais j'aurais du mettre quoi?
Le 1er portail Francophone de machines à vapeur et moteurs à air chaud :
Le portailhttp://www.blooo.fr
le Forum : http://www.bloooo.fr/forums/
Avatar de l’utilisateur
Bege
Roi des posts
Roi des posts
 
Messages: 806
Enregistré le: 12 Jan 2010 à 14:31
Localisation: Rouhling (57)

Re: Nouveaux utilisateurs, bug?

Messagepar Steph » 11 Aoû 2016 à 17:22

Un bon titre permet de savoir de quoi va parler le sujet sans avoir besoin de l'ouvrir alors "Nouveaux utilisateurs" avec des précisons pourquoi pas, mais "bug", pour moi c'est trop vague. Fait attention à l'avenir.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18404
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar Skouat » 11 Aoû 2016 à 18:30

Bonjour,

Bege a écrit:euh mais j'aurais du mettre quoi?


C'est simple, en titre c'est bien de mettre l'erreur rencontrée et non l'interprétation que vous pouvez en faire.
Un exemple de titre : PHP Notice: in file [ROOT]/memberlist.php on line 1532
:wink:

Bege a écrit:oui plusieurs, mais il me semble bien que ces lignes d'erreur sont apparues bien après, voilà les extensions installées :

Essayez de désactiver toutes les extensions, puis de purger le cache.
Ensuite regardez si le problème est toujours présent.
Si, oui => réactivez vos extensions (le temps de trouver le pb)
Si, non => alors réativez les extensions une à une et voyez à quel moment le problème apparait.
Skouat
Traducteur
Traducteur
 
Messages: 13790
Enregistré le: 02 Avr 2008 à 20:47

Re: Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar Bege » 11 Aoû 2016 à 19:34

j'ai désactivé les extensions l'une après l'autre, mais les lignes d'erreur étaient toujours affichées quand on clique sur
" Nouveaux utilisateurs enregistrés"
Le 1er portail Francophone de machines à vapeur et moteurs à air chaud :
Le portailhttp://www.blooo.fr
le Forum : http://www.bloooo.fr/forums/
Avatar de l’utilisateur
Bege
Roi des posts
Roi des posts
 
Messages: 806
Enregistré le: 12 Jan 2010 à 14:31
Localisation: Rouhling (57)

Re: Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar Skouat » 11 Aoû 2016 à 19:44

Bonjour,

Deux hypothèses.
  • Soit un bug au niveau de la base de données ;
  • soit un bug au niveau des fichiers.
Vous ne l'avez pas précisez, mais on va dire que c'est le cas et que votre forum est en 3.1.9...
Récupérez le pack complet de phpBB
Décompressez l'archive, supprimez le répertoire install et le fichier config.php.
Une fois fait, envoyez tous les fichiers sur votre hébergement.

Ensuite, purgez le cache manuellement (donc en passant par votre hébergement via FTP ou le gestionnaire de fichier fournit par votre hébergeur).
Skouat
Traducteur
Traducteur
 
Messages: 13790
Enregistré le: 02 Avr 2008 à 20:47

Re: Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar ABDev » 11 Aoû 2016 à 19:45

Vous avez bien purgé le cache après avoir désactivé les extensions ?
Avez-vous effectué des modifications des fichiers préalablement ?
Quid de restaurer un fichier memberlist.php d'origine ?
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15695
Enregistré le: 12 Mai 2005 à 23:54

Re: Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar Bege » 11 Aoû 2016 à 20:07

oui j'ai bien purgé le cache après avoir désactivé chaque extension,

et j'ai aussi essayé de remettre un fichier memberlist.php d'origine, j'ai aussi essayé de renommer un fichier memberlist.php.bak en memberlist.php, mais rien à faire, les lignes d'erreur sont toujours là :(
Le 1er portail Francophone de machines à vapeur et moteurs à air chaud :
Le portailhttp://www.blooo.fr
le Forum : http://www.bloooo.fr/forums/
Avatar de l’utilisateur
Bege
Roi des posts
Roi des posts
 
Messages: 806
Enregistré le: 12 Jan 2010 à 14:31
Localisation: Rouhling (57)

Re: Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar Skouat » 11 Aoû 2016 à 20:50

Bonjour,

Merci d'excécuter les requêtes SQL suivante:
Code: Tout sélectionner
SELECT u.user_id FROM phpbb_users u WHERE (u.user_type = 0 OR u.user_type = 3) ORDER BY u.user_id;


Code: Tout sélectionner
SELECT u.user_id FROM phpbb_users u, phpbb_user_group ug WHERE (u.user_type = 0 OR u.user_type = 3) AND u.user_id = ug.user_id AND ug.group_id = 7 ORDER BY u.user_id;


Pour les deux requêtes... Combien de résultats avez-vous ? Avez-vous des valeurs en doublon ?
Skouat
Traducteur
Traducteur
 
Messages: 13790
Enregistré le: 02 Avr 2008 à 20:47

Re: Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar Bege » 12 Aoû 2016 à 07:18

à la première requête il m'affiche ce texte :
Affichage des lignes 0 - 499 (total de 779, Traitement en 0.0034 secondes.) [user_id: 2 - 1061]
et voilà une copie partielle d'écran :
Image

à la deuxième requête il m'affiche ce texte :
Affichage des lignes 0 - 196 (total de 197, Traitement en 0.0015 secondes.) [user_id: 77 - 468]
et voilà une copie partielle d'écran :
Image
et là on voit des doublons,
Le 1er portail Francophone de machines à vapeur et moteurs à air chaud :
Le portailhttp://www.blooo.fr
le Forum : http://www.bloooo.fr/forums/
Avatar de l’utilisateur
Bege
Roi des posts
Roi des posts
 
Messages: 806
Enregistré le: 12 Jan 2010 à 14:31
Localisation: Rouhling (57)

Re: Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar Skouat » 12 Aoû 2016 à 11:19

Donc on s'oriente vers un PB de base de données.

Vous allez déjà vérifier que seul le groupe "Nouveaux utlisateurs" est erroné.

Executez la requête
Code: Tout sélectionner
SELECT group_id, group_name FROM `phpbb_groups` WHERE group_type = 3


Ca va vous lister les groupes speciaux qui devrait aller de l'ID 1 à 7

Ensuite, reprenez la deuxième requête de mon message précédent et remplacez la valeur de ug.group_id = 7

Avez-vous également des doublons ?
Skouat
Traducteur
Traducteur
 
Messages: 13790
Enregistré le: 02 Avr 2008 à 20:47

Re: Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar Bege » 13 Aoû 2016 à 08:54

très bien, ça liste bien les groupes spéciaux qui vont de l'ID 1 à 7

mais je remplace la valeur de
Code: Tout sélectionner
ug.group_id = 7
par quoi?
Le 1er portail Francophone de machines à vapeur et moteurs à air chaud :
Le portailhttp://www.blooo.fr
le Forum : http://www.bloooo.fr/forums/
Avatar de l’utilisateur
Bege
Roi des posts
Roi des posts
 
Messages: 806
Enregistré le: 12 Jan 2010 à 14:31
Localisation: Rouhling (57)

Re: Nouveaux utilisateurs, affichage de lignes d'erreur

Messagepar Bege » 15 Aoû 2016 à 09:37

Hello, j'ai été malade et donc je n'ai pas pu continuer les recherches,

mais je n'ai pas bien compris :
"Ensuite, reprenez la deuxième requête de mon message précédent et remplacez la valeur de ug.group_id = 7"

merci pour votre patience
Le 1er portail Francophone de machines à vapeur et moteurs à air chaud :
Le portailhttp://www.blooo.fr
le Forum : http://www.bloooo.fr/forums/
Avatar de l’utilisateur
Bege
Roi des posts
Roi des posts
 
Messages: 806
Enregistré le: 12 Jan 2010 à 14:31
Localisation: Rouhling (57)

Suivante

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités