[Réglé] Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Forum de support pour les questions concernant l'utilisation de phpBB 3.1, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 05 Mai 2016 à 20:12

Bonjour,

Voilà le problème, dans certains mails de notification de réponse, les liens commencent par https:// et d'autres en http:// sans que je sache pourquoi il y a cette différence. Idem sur Google, certains résultats de recherche renvoient sur des liens en https:// et d'autres en http://

Et quand ça renvoie sur un lien en https, j'ai ce message :

La connexion n'est pas sécurisée

Les propriétaires de http://www.binano.fr ont mal configuré leur site web. Pour éviter que vos données ne soient dérobées, Firefox ne s'est pas connecté à ce site web.


Exemple :
https://www.binano.fr/viewtopic.php?t=48733
http://www.binano.fr/viewtopic.php?t=48733

Bon c'est peut-être mon navigateur qui pose problème (Firefox) mais bon pourquoi tous les liens ne sont-ils pas référencés en http:// ??? Comment uniformiser s'il vous plait ?
Modifié en dernier par Binano le 25 Mai 2016 à 11:46, modifié 3 fois.
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 19 Mai 2016 à 14:00

Je remonte un petit coup le sujet... je cherche juste une piste sur laquelle me pencher... :|
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar FoFa » 19 Mai 2016 à 14:07

Hello,

Tu as quoi dans Administration => Général => Configuration du serveur => Paramètres de cookie => cookie sécurié ?
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10561
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 19 Mai 2016 à 15:14

Paramètres de cookie

Domaine du cookie : .binano.fr
Nom du cookie : phpbb3_rtnfb
Chemin du cookie : /
Cookie sécurisé : Désactivé
Si votre site Internet est accessible par l’intermédiaire du protocole SSL (https://), activez cette option sinon laissez sur « Désactivé ». Si vous activez cette option alors que votre site Internet n’est pas accessible par le protocole SSL, des erreurs se produiront lors des redirections.
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar lolovoisin » 19 Mai 2016 à 17:21

Et dans Administration => Général => Configuration du serveur => Paramètres du serveur => Paramètres des URLs du serveur ?
Ceux qui échouent trouvent des excuses, ceux qui réussissent trouvent les moyens
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
PAS DE SUPPORT PAR MP !!

tutophpbb3 + astuce + tutos debian
Avatar de l’utilisateur
lolovoisin
Rugbix ³
Rugbix ³
 
Messages: 39779
Enregistré le: 04 Mai 2006 à 13:16
Localisation: Dans la BDD ...

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 19 Mai 2016 à 22:43

Forcer les paramètres URL du serveur : Non
Protocole du serveur : http://
Nom de domaine : http://www.binano.fr
Port : 80
Chemin du script : /

Est-ce qu'en forçant les paramètres URL du serveur cela peut régler mon problème sans risque ???
Edit : non, même en forçant ça ne fonctionne pas...

Peut-être un souci avec mon .htacess ???
Code: Tout sélectionner
SetEnv PHP_VER 5_3

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTP_HOST} !^www\.binano\.fr$ [NC] 
RewriteRule ^(.*) http://www.binano.fr/$1 [QSA,L,R=301]

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 20 Mai 2016 à 10:25

  1. Ton site est à la fois accessible en http ET https, d'où les 2 types de résultats dans google
  2. L'url change dans tes mails de notification, selon le cas où le visiteur qui a généré l'envoi, navigue sur ton forum en http ou en https
  3. L'erreur affichée par firefox est normale car le certificat SSL associé à ton forum n'est pas correcte, il est signé pour ssl3.ovh.net et non pas pour binano.fr, donc pour ton navigateur, tu n'est pas arrivé sur le site que tu as demandé, et t'en informe (car c'est peut être signe d'une attaque, tu penses par exemple te connecter au site de ta banque, mais le certificat ne correspond pas)
  4. La règle de redirection dans ton htaccess n'est pas bonne (ou incomplète), elle n'effectue la redirection en http que si l'url n'est pas http://www.binano.fr, sans tenir compte du protocole (http ou https) ce qui veut dire que:
    https://www.binano.fr ne redirige pas vers http://www.binano.fr
    Je te conseille de mettre ceci:
    Code: Tout sélectionner
    RewriteEngine On
    RewriteCond %{HTTPS} on
    RewriteRule ^ http://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 20 Mai 2016 à 10:34

Super !

Je le mets en plus dans mon .htaccess, après ceci par exemple ?
Code: Tout sélectionner
RewriteEngine On
RewriteCond %{HTTP_HOST} !^www\.binano\.fr$ [NC] 
RewriteRule ^(.*) http://www.binano.fr/$1 [QSA,L,R=301]


Ou bien carrément en remplacement d'autre chose ?

Je suis vraiment content que quelqu'un me propose une solution, cela fait plusieurs années que je traîne ça, ce qui est bizarre c'est que j'ai d'autres forums avec le même fichier htaccess et je ne rencontre pas ce problème

L'erreur affichée par firefox est normale car le certificat SSL associé à ton forum n'est pas correcte, il est signé pour ssl3.ovh.net et non pas pour binano.fr, donc pour ton navigateur, tu n'est pas arrivé sur le site que tu as demandé, et t'en informe (car c'est peut être signe d'une attaque, tu penses par exemple te connecter au site de ta banque, mais le certificat ne correspond pas)

Est-ce que je peux changer ça quelque part ?
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 20 Mai 2016 à 10:42

Si on accepte le risque de faire sauter la redirection binano.fr vers www.binano.fr, je dirais de le mettre à la place

Par contre, pour assurer le coup:
sylkapi a écrit:Forcer les paramètres URL du serveur : Non
Protocole du serveur : http://
Nom de domaine : http://www.binano.fr
Port : 80
Chemin du script : /

Force les paramètres, et pour le champ "nom de domaine", tu mets juste www.binano.fr (le protocole est déjà spécifié dans le champ du dessus)
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 20 Mai 2016 à 10:47

soda a écrit:Force les paramètres, et pour le champ "nom de domaine", tu mets juste http://www.binano.fr (le protocole est déjà spécifié dans le champ du dessus)

Oups, c'était une erreur de recopiage, le champ "nom de domaine" était bien sur www.binano.fr

Si on accepte le risque de faire sauter la redirection binano.fr vers http://www.binano.fr, je dirais de le mettre à la place

J'avais cru comprendre que pour le référencement et éviter les doublons dans google, il fallait rediriger soit vers l'un soit vers l'autre. On ne peut vraiment pas forcer le http:// avec la redirection unique vers http://www.binano.fr ???


Sinon, je suis chez OVH, je vois dans les paramètres : "certificat SSL : oui", je dois pouvoir modifier quelque chose à ce niveau pour configurer ce certificat SSL au bon domaine, non ???
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 20 Mai 2016 à 11:46

Google ne connait pas ton site en version "non www", donc à moins qu'il trouve des urls http://binano.fr ça ne devrait pas changer.
Mais au cas ou, tu peux essayer ceci:
Code: Tout sélectionner
RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule ^ http://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteCond %{HTTP_HOST} !^www\.binano\.fr$ [NC] 
RewriteRule ^(.*) http://www.binano.fr/$1 [QSA,L,R=301]

Il y a surement moyen de combiner les deux mais je n'ai pas de quoi faire des tests

sylkapi a écrit:Sinon, je suis chez OVH, je vois dans les paramètres : "certificat SSL : oui", je dois pouvoir modifier quelque chose à ce niveau pour configurer ce certificat SSL au bon domaine, non ???
Navré, je ne travaille pas chez OVH, je n'en sais rien
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 20 Mai 2016 à 11:55

en fait ça ne fonctionne pas, même avec le code suivant seul en remplacement de l'autre

Code: Tout sélectionner
RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule ^ http://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 20 Mai 2016 à 11:59

ça marche, https://binano.fr me redirige bien vers http://binano.fr
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 20 Mai 2016 à 12:03

Pas moi :shock:
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 20 Mai 2016 à 12:07

Vous pouvez tester proprement ici:
http://www.redirection-web.net
http://web-sniffer.net

Commencez par vider votre cache
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Suivante

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités