[Réglé] Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Forum de support pour les questions concernant l'utilisation de phpBB 3.1, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 20 Mai 2016 à 12:51

Effectivement sur http://www.redirection-web.net on voit bien la double redirection.
J'ai donc vidé le cache de mon forum et supprimé de mon navigateur Chrome "historique de navigation", "cookies", "images et fichiers en cache" mais rien n'y fait.

Test sur Firefox, idem :| => Échec de la connexion sécurisée
Edit : IE, idem => Le certificat de sécurité présenté par ce site Web a été émis pour une autre adresse de site Web


--------------------------------------

Je viens de tomber sur un truc en cherchant dans la FAQ OVH : http://help.ovh.ie/SslOnHosting
Si je ne veux pas utiliser le https:// il faut que ça renvoie sur cette adresse : https://ssl3.ovh.net/~LoginFTP

Pour moi ça donne https://ssl3.ovh.net/~binano

Comment dois-je modifier mon .htacess pour renvoyer sur cette adresse quand l'URL est en https ???

(en parallèle je vais essayer de voir si on peut paramétrer un truc chez OHV)
Edit : justement, ils en parlent ici !!!
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 20 Mai 2016 à 14:54

sylkapi a écrit:Effectivement sur http://www.redirection-web.net on voit bien la double redirection.
J'ai donc vidé le cache de mon forum et supprimé de mon navigateur Chrome "historique de navigation", "cookies", "images et fichiers en cache" mais rien n'y fait.

Test sur Firefox, idem :| => Échec de la connexion sécurisée
Edit : IE, idem => Le certificat de sécurité présenté par ce site Web a été émis pour une autre adresse de site Web
Mais enfin, on parle de redirection là, pas de transformer un certificat invalide en certificat valide.
Le certificat est envoyé au navigateur AVANT la lecture du .htaccess par le serveur Web, la redirection ne sert que pour les visiteurs ayant déjà passé l'étape du certificat

Je viens de tomber sur un truc en cherchant dans la FAQ OVH : http://help.ovh.ie/SslOnHosting
Si je ne veux pas utiliser le https:// il faut que ça renvoie sur cette adresse : https://ssl3.ovh.net/~LoginFTP

Euh non, ce tuto ovh traite justement le sujet: comment accéder à votre site en https, et ils confirment mes propos précédents:
This type of access requires verification of certificate by your browser. The SSL certificate is not installed for your domain but for the server of your hosting service.


Vous êtes certain de vouloir naviguer suer votre forum en utilisant l'url https://ssl3.ovh.net/~binano juste pour profiter du ssl ? Cela va avoir un impacte sur votre référencement, en plus d'être moche.
Franchement ça ne vaut pas le coup
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 20 Mai 2016 à 15:11

bon je suis largué là...
si ce problème de certificat ne peut pas être corrigé par le fichier .htaccess , pourquoi vous me le faite modifier ? :oops:

Edit :
J'ai essayé de comprendre de mon coté. Tu m'as conseillé de modifier mon .htaccess pour améliorer les redirections mais le problème de départ c'est le certificat SSL qui n'est pas bon... comme tu le disais au début également, j'ai tout mélangé.

Apparemment OVH ont activé le protocole SSL pour l'ensemble des sites récemment et ils sont en train de générer les certificats, ce n'est pas encore fait pour mon hébergement ... c'est surement à cause de ça que ça génère cette erreur.

http://travaux.ovh.net/?do=details&id=18027
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 20 Mai 2016 à 16:49

sylkapi a écrit:bon je suis largué là...
si ce problème de certificat ne peut pas être corrigé par le fichier .htaccess , pourquoi vous me le faite modifier ? :oops:

Pour que toute personne essayant de naviguer sur votre votre forum en https, soit redirigé vers la version http, afin que les urls dans les mails de notifications soient tous en http et que google ne référence plus les deux versions; or il me semble que ce c'est ce que vous demandez au départ:
sylkapi a écrit:pourquoi tous les liens ne sont-ils pas référencés en http:// ??? Comment uniformiser s'il vous plait ?
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 21 Mai 2016 à 12:36

Oui, tout à fait. C'est parfait, merci ! 8)
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 23 Mai 2016 à 22:41

Alors ça doit être une coïncidence mais OVH vient justement aujourd'hui d'activer les certificats SSL des hébergements mutualisés. De ce fait je n'ai plus d'erreur quand je navigue en https sur mon forum. L'info est ici : http://travaux.ovh.net/?do=details&id=18027

Du coup, je me pose la question inverse, y-a-t'il un intéret à faire une redirection de toutes les URL HTTP vers HTTPS sur un forum phpbb ?

Edit : à priori, meilleur référencement google en SSL ???
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 24 Mai 2016 à 10:48

Oui effectivement https aide au référencement dans certains cas de figures.

Après il faut savoir qu'ovh utilise les certificats SSL délivrés par let's encrypt, or l'implantation par défaut de ces certificats les rend incompatibles avec certains navigateurs sous Win XP, je ne sais pas si OVH a remédié au problème, mais apparemment non: https://www.ssllabs.com/ssltest/analyze ... =binano.fr (section "Handshake Simulation").
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 24 Mai 2016 à 11:16

J'ai trouvé un morceau de code ici : https://www.phpbb-services.com/guides.p ... ticle=8857

Code: Tout sélectionner
RewriteEngine On

RewriteCond %{HTTPS} off
RewriteCond %{HTTP_USER_AGENT} !(Windows\ NT\ 5) [NC]
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [L,QSA,R=permanent]


Mais bon je m'embrouille sérieusement...

Le code renvoie les HTTP vers HTTPS sauf avec les navigateurs incompatibles.
Mais Google ? Il va référencer les pages de mon forum en HTTPS j'imagine ???

Deuxième question : Est-ce qu'on peut coupler cette redirection avec l'autre redirection qui ajoute WWW à l'URL ?
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 24 Mai 2016 à 12:05

sylkapi a écrit:J'ai trouvé un morceau de code ici : https://www.phpbb-services.com/guides.p ... ticle=8857
Ah ah ah c'est le guide qu'on a rédigé pour nos clients :mrgreen:

sylkapi a écrit:Le code renvoie les HTTP vers HTTPS sauf avec les navigateurs incompatibles.
Mais Google ? Il va référencer les pages de mon forum en HTTPS j'imagine ???
En fait il redirige tout le monde sauf si le système d'exploitation est Windows XP, Google n'est donc pas concerné et indexera votre site en https

sylkapi a écrit:Deuxième question : Est-ce qu'on peut coupler cette redirection avec l'autre redirection qui ajoute WWW à l'URL ?
En négligeant le test sur le système d'exploitation utilisé, ceci devrait faire l'affaire:
Code: Tout sélectionner
RewriteEngine On

RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^www\.binano\.fr$ [NC]
RewriteRule ^ https://www.binano.fr%{REQUEST_URI} [R=301]

Mais si on veut éviter de rediriger les utilisateurs XP:
Code: Tout sélectionner
RewriteEngine On

RewriteCond %{HTTPS} off
RewriteCond %{HTTP_USER_AGENT} !(Windows\ NT\ 5) [NC]
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule .* https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Il y a peut être moyen de combiner mais je n'ai actuellement pas les moyens de tester
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 24 Mai 2016 à 12:37

soda a écrit:Ah ah ah c'est le guide qu'on a rédigé pour nos clients :mrgreen:

Ok, je comprends mieux pourquoi tu es aussi calé :wink:
Merci beaucoup pour ton aide.

Mais si on veut éviter de rediriger les utilisateurs XP:
Code: Tout sélectionner
RewriteEngine On

RewriteCond %{HTTPS} off
RewriteCond %{HTTP_USER_AGENT} !(Windows\ NT\ 5) [NC]
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule .* https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Il y a peut être moyen de combiner mais je n'ai actuellement pas les moyens de tester

Donc on est bien d'accord, si j'applique cette redirection ça ne peut être que positif sur le référencement ?
Aucun utilisateur ne sera mis de coté parce qu'il n'a pas le bon navigateur ?
Enfin bref, ça va vraiment dans le bon sens ? et cela même si en haut à gauche de l'URL j'ai un truc où il y a marqué que le forum n'est pas 100% sécurisé du coup
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 24 Mai 2016 à 13:05

sylkapi a écrit:Donc on est bien d'accord, si j'applique cette redirection ça ne peut être que positif sur le référencement ?
Oui mais suivez bien le guide, il faut bien configurer les paramètres dans phpBB
sylkapi a écrit:Aucun utilisateur ne sera mis de coté parce qu'il n'a pas le bon navigateur ?
Avec le 2ème code, tout le monde aura accès à votre forum, mais ceux sous XP ne seront pas redirigé en https.
Mais personnellement, je suis contre le fait d'exclure les utilisateurs d'XP de la redirection; s'ils sont pas à jour, tant pis pour eux, que ce soit leur faute ou pas. Il vaut mieux uniformiser la méthode d'accès à votre forum, faire du http et du https c'est prendre le risque de rencontrer des dysfonctionnements à un moment ou à un autre.
sylkapi a écrit:et cela même si en haut à gauche de l'URL j'ai un truc où il y a marqué que le forum n'est pas 100% sécurisé du coup

Le proxy de ma boite m'empêche d'aller sur votre site en https, mais c'est probablement une histoire de mixed content ou simplement un défaut de certificat
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 24 Mai 2016 à 13:41

J'ai appliqué l'option 1 de votre explication sur le forum http://www.vtt-alsace.fr : https://www.phpbb-services.com/guides.p ... ticle=8857

Par contre, pour ajouter WWW à l'URL, ça ne fonctionne pas avec le code, il n'y aque le texte de la page qui s'affiche :

RewriteEngine On

RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^www\.binano\.fr$ [NC]
RewriteRule ^ https://www.binano.fr%{REQUEST_URI} [R=301]


Edit :
j' navais pas fait attention mais vous parlez de créer un .htacess dans un répertoire HTTPDOC ??? pas à la racine du site ???
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar soda » 24 Mai 2016 à 13:58

sylkapi a écrit:J'ai appliqué l'option 1 de votre explication sur le forum http://www.vtt-alsace.fr

sylkapi a écrit:
RewriteEngine On

RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^www\.binano\.fr$ [NC]
RewriteRule ^ https://www.binano.fr%{REQUEST_URI} [R=301]

Y'a ptete un truc là non ? 8)

sylkapi a écrit:j' navais pas fait attention mais vous parlez de créer un .htacess dans un répertoire HTTPDOC ??? pas à la racine du site ???
Dans le tuto nous parlons de httpdocs c'est c'est dans ce dossier que se trouve la racine de l'espace web, il faut adapter dans votre cas.
Comme votre forum semble à la racine de votre espace web, il faut placer ces règles de redirection dans le .htaccess se trouvant au même endroit que config.php, common.php, etc...
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 349
Enregistré le: 25 Déc 2006 à 12:55
Localisation: Sur mon cheval blanc

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 24 Mai 2016 à 14:11

soda a écrit:Y'a ptete un truc là non ? 8)

Oups !!!!!!!
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Re: Liens en HTTPS dans les mails de notification de réponse : connexion non sécurisée ?

Messagepar Binano » 24 Mai 2016 à 19:04

Je suis en train de tester sur un autre de mes forums où il y a moins de fréquentation pour tester tranquillement : http://www.forum-velo-pliant.fr

J'ai testé la redirection suivante que tu m'avais proposé Soda :
Code: Tout sélectionner
RewriteEngine On

RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^www\.forum-velo-pliant\.fr$ [NC]
RewriteRule ^ https://www.forum-velo-pliant.fr%{REQUEST_URI} [R=301]


mais il n'y a rien à faire, ça ne passe pas :(

Du coup j'ai imbriqué ça :
Code: Tout sélectionner
RewriteCond %{HTTP_HOST} !^www\.forum-velo-pliant\.fr$ [NC] 
RewriteRule ^(.*) http://www.forum-velo-pliant.fr/$1 [QSA,L,R=301]

RewriteCond %{HTTPS} off
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [L,QSA,R=permanent]


Ca fonctionne mais dans le doute est-ce que tu pourrais me valider cette double redirection ? Je suis un peu trouille-cul et j'ose pas l'utiliser sans être sûr que ça soit pas une bétise :oops:

Edit : Bon ça ne doit pas être la bonne solution... car quand j'utilise Google Webmaster "Explorer comme Google", ça détecte la redirection et ça récupère une page bizarre...

Edit n°2 : C'est ok, j'avais oublié le "S" à http dans la première redirection :oops:
Avatar de l’utilisateur
Binano
Roi des posts
Roi des posts
 
Messages: 617
Enregistré le: 02 Aoû 2005 à 09:36

Précédente

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités

cron