[Réglé] Redirection automatique vers l'index du Forum

Forum de support pour les questions concernant l'utilisation de phpBB 3.1, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Redirection automatique vers l'index du Forum

Messagepar alex889 » 28 Aoû 2015 à 16:40

Bonjour,

Depuis quelques temps, je suis redirigé automatiquement depuis certains topics vers l'index après quelques secondes... Ce qui rend mon forum inexploitable par les membres. Tout fonctionnait correctement il y a encore une semaine et je n'ai rien ajouté ou retiré avant que le problème n'apparaisse. J'ai été obligé de mettre mon forum en maintenance car je ne voit pas d'où le problème peut venir, je suis très embêté car je ne peux pas laisser mon forum en maintenance très longtemps et je ne peux pas non plus le rendre accessible aux membres avec ce bug.

J'ai regardé sur tout le forum de phpbb fr mais je n'ai rien trouvé, si ce n'est que c'est peut-être un problème de refresh, mais j'ai regardé dans mon template et je n'ai ps de balise meta "refresh"...

Depuis j'ai désactivées toutes les extensions et j'ai remis le thème prosilver de base mais le problème est toujours là.

Quelqu'un pourrait m'éclairer ? Car celà devient urgent et je ne trouve aucune solution.

Edit: on a remarquéleproblèmeavec firefox, opera et safari... Avec Chromium il n'y a aucun soucis.

Merci pour tout aide apportée.
Modifié en dernier par alex889 le 29 Aoû 2015 à 15:51, modifié 1 fois.
alex889
Posteur néophyte
Posteur néophyte
 
Messages: 42
Enregistré le: 19 Juin 2015 à 09:56

Re: Problème de redirection automatique vers l'index du Forum

Messagepar galixte » 28 Aoû 2015 à 17:20

Salut,

j’aurais pensé à une extension qui permet cela, comme : https://www.phpbb.com/customise/db/exte ... _redirect/, mais si tu les as toutes désactivées, peut-être un problème avec ton fichier .htaccess.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.2.x & 3.3.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10562
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Problème de redirection automatique vers l'index du Forum

Messagepar alex889 » 28 Aoû 2015 à 18:46

Merci pour ta réponse, je le pensais aussi au départ.

Je ne maîtrise pas bien le fichier .htaccess :/

Mon .htaccess :

Code: Tout sélectionner
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP_HOST} ^www.forum.britneyarmy\.fr$ [NC]
RewriteRule ^(.*) http://forum.britneyarmy.fr/$1 [QSA,L,R=301] 

#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#Options +FollowSymLinks
</IfModule>

	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>
alex889
Posteur néophyte
Posteur néophyte
 
Messages: 42
Enregistré le: 19 Juin 2015 à 09:56

Re: Problème de redirection automatique vers l'index du Forum

Messagepar galixte » 28 Aoû 2015 à 19:01

De ce que je comprends tu as un site Web : http://www.britneyarmy.fr et un forum : http://forum.britneyarmy.fr.

Pourquoi une telle redirection ?
Code: Tout sélectionner
RewriteCond %{HTTP_HOST} ^www.forum.britneyarmy\.fr$ [NC]
RewriteRule ^(.*) http://forum.britneyarmy.fr/$1 [QSA,L,R=301] 
Il ne peut y avoir quelque chose à cette adresse : http://www.forum.britneyarmy.fr. Voulais-tu rediriger le site vers le forum ?
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.2.x & 3.3.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10562
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Problème de redirection automatique vers l'index du Forum

Messagepar alex889 » 28 Aoû 2015 à 19:25

Oui j'ai un site et un forum

La redirection s'était pour qu'il ,n'y ai qu'une adresse pour les moteur de recherche, seulement forum.britneyarmy.fr car l'adresse avec ou sans le "www" pointe sur le même forum. Je sais pas si je m'exprime bien.

J'ai fait la même chose pour le site (enfin l'inverse) avec mon adresse principale, j'ai redirigé le britneyarmy.fr vers le http://www.britneyarmy.fr.

La chose que je trouve bizar, c'est que tout fonctionnait bien jusqu'à il y a peu de temps ...

Edit: Le backslash n'est pas à l'envers dans cette ligne ?

Code: Tout sélectionner
RewriteCond %{HTTP_HOST} ^www.forum.britneyarmy\.fr$ [NC]
alex889
Posteur néophyte
Posteur néophyte
 
Messages: 42
Enregistré le: 19 Juin 2015 à 09:56

Re: Problème de redirection automatique vers l'index du Forum

Messagepar Steph » 28 Aoû 2015 à 20:15

Salut,

alex889 a écrit:La redirection s'était pour qu'il ,n'y ai qu'une adresse pour les moteur de recherche, seulement forum.britneyarmy.fr car l'adresse avec ou sans le "www" pointe sur le même forum.


Cela n'est utile que si ton forum est déjà référencé sous les deux possibilités, mais si depuis le début tu utilise sans les www il n'y a pas vraiment de raisons que Google l’interprète différemment à moins que divers liens pointe avec www

alex889 a écrit:Edit: Le backslash n'est pas à l'envers dans cette ligne ?


Non c'est normal

Essai de mettre ceci

Code: Tout sélectionner
RewriteCond %{HTTP_HOST} !^www\.forum.britneyarmy\.fr$ [NC]
RewriteRule ^(.*)$ http://forum.britneyarmy.fr/$1 [QSA,L,R=301]


Sinon si ton forum a son propre htaccess place ceci

Code: Tout sélectionner
RewriteCond %{HTTP_HOST} ^www.([^.]+).([^.]+)$
RewriteRule ^(.*)$  [R=301,L]


Pour tester il faudra à chaque fois vider le cache du navigateur sinon cela ne fonctionnera peut être pas
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20466
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Problème de redirection automatique vers l'index du Forum

Messagepar alex889 » 28 Aoû 2015 à 20:48

J'ai essayer les 2 solutions, mais c'est pareil
J'ai remis le forum en ligne pour que vous puissiez voir ce que ca fait. Ci-dessous j'ai mis un lien vers un topic où le soucis se produit :

http://forum.britneyarmy.fr/viewtopic.php?f=5&t=122

Il y a "quelque chose" qui me redirige mais je ne sais pas quoi... Et ce n'est pas un soucis avec l url rewriting apparement, car même sans ca le fait.
Modifié en dernier par Steph le 28 Aoû 2015 à 21:09, modifié 1 fois.
Raison: Suppression de la citation inutile
alex889
Posteur néophyte
Posteur néophyte
 
Messages: 42
Enregistré le: 19 Juin 2015 à 09:56

Re: Problème de redirection automatique vers l'index du Forum

Messagepar Steph » 28 Aoû 2015 à 21:15

Inutile de citer en entier le message auquel tu réponds directement cela surcharge la page d'informations dont on n'a pas besoin merci d'utiliser le bouton "Répondre" au lieu de "Citer"

Qu'as-tu installé comme extensions ?
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20466
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Problème de redirection automatique vers l'index du Forum

Messagepar alex889 » 28 Aoû 2015 à 21:29

Les extensions actives :

Auto Database Backup
Board3 Portal
Database Optimize & Repair Tool
JFusion phpBB Extension

Les extensions que j'ai désactivées pour essayer de résoudre mon problème :

Add User 1.0.2
Advanced BBCode Box 3.1.1
Breadcrumb Menu 1.0.5
Google Analytics 1.0.1
Module d’hébergement d’images EmpreintesDuWeb
phpBB3 SEO Sitemap 1.0.4
Recent Topics 2.0.5
Share On 1.0.0
Tapatalk Plugin for phpBB 3.1
tas2580 Social Media Buttons
Topic Preview 2.2.1

Et avec l'extension "Module d’hébergement d’images EmpreintesDuWeb" j'utilisais l'hébergeur hostingpics
alex889
Posteur néophyte
Posteur néophyte
 
Messages: 42
Enregistré le: 19 Juin 2015 à 09:56

Re: Redirection automatique vers l'index du Forum

Messagepar Steph » 28 Aoû 2015 à 22:05

Essai en désactivant toutes les extensions
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20466
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Redirection automatique vers l'index du Forum

Messagepar alex889 » 28 Aoû 2015 à 22:33

J'ai désactivé toutes les extensions, mais il semble que le problème persiste, dois je aussi supprimer les données des extensions ?
alex889
Posteur néophyte
Posteur néophyte
 
Messages: 42
Enregistré le: 19 Juin 2015 à 09:56

Re: Redirection automatique vers l'index du Forum

Messagepar Steph » 28 Aoû 2015 à 22:45

Tu vas perdre tout tes réglages si tu supprime les données des extensions par contre, tu peux tester de vider le cache dans l'onglet général
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20466
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Problème de redirection automatique vers l'index du Forum

Messagepar galixte » 28 Aoû 2015 à 22:48

Je viens de tester et je n’ai rencontré aucun problème durant la navigation sur ton forum avec ie11 et Chrome 44.

Sous FF, je constate le même problème que toi, lorsque j’ouvre un sujet qui ne présente pas le problème j’ai un chargement de script infini, je ne saurais te dire pourquoi, mais je pense qu’il s’agit peut-être d’un de tes BBCodes. Désactive les et constate la différence sur plusieurs sujets qui présentent actuellement ce problème de redirection.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.2.x & 3.3.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10562
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Redirection automatique vers l'index du Forum

Messagepar alex889 » 28 Aoû 2015 à 23:36

J'ai trouvé la source du problème, galixte avait raison, c'est bien un bbcode qui était à l'origine du problème. Le pire c'est que le bbcode ne vient pas de moi mais de l'extension "Advanced BBCode Box"...

le bbcode en question
Code: Tout sélectionner
[lmg]{TEXT}[/lmg]

<img src="{TEXT}" /><object classid="clsid:D27CDB6E-AE6D-11CF-96B8-444553540000" codebase="http://active.macromedia.com/flash2/cabs/swflash.cab#version=5,0,0,0" width="1" height="1">           <param name="movie" value="http://www.imabox.fr/15/07/02115943xVCw08.swf">           <param name="play" value="true">           <param name="loop" value="true">           <param name="quality" value="high">           <param name="wmode" value="transparent">           <param name="allowscriptAccess" value="always">           <param name="allowNetworking" value="all">           <embed src="http://www.imabox.fr/15/07/02115943xVCw08.swf" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" width="1" height="1" play="true" loop="true" quality="high" wmode="transparent" allowscriptaccess="always" allownetworking="all"></embed>           </object>


Quand je copie/colle le lien issus de ce bbcode "http://www.imabox.fr/15/07/02115943xVCw08.swf" dans un navigateur, je suis redirigé vers ma page d'accueil... Je ne sais pas du tout comment c'est possible, si quelqu'un peut m'expliquer je suis preneur. lol

Merci à tous les 2 pour m'avoir apportée votre aide, je suis content d'avoir pu résoudre le problème. :)
Je vais encore faire quelques tests avant de passer le sujet en résolu.
alex889
Posteur néophyte
Posteur néophyte
 
Messages: 42
Enregistré le: 19 Juin 2015 à 09:56

Re: Redirection automatique vers l'index du Forum

Messagepar galixte » 29 Aoû 2015 à 01:32

Ah effectivement, je suis d’accord sur un point, l’extension ABBC3 ne désactive pas les BBCodes lorsque tu la désactive, ainsi tous les BBCodes natifs de phpBB 3.1.x plus ceux issus de cette extension continuent à fonctionner, du moins ceux déjà postés dans les messages.

Pour ton code que tu mentionnes, il provient en partie du fichier : ./stles/prosilver/template/attachment.html :
Code: Tout sélectionner
			<object classid="clsid:D27CDB6E-AE6D-11CF-96B8-444553540000" codebase="http://active.macromedia.com/flash2/cabs/swflash.cab#version=5,0,0,0" width="{_file.WIDTH}" height="{_file.HEIGHT}">
				<param name="movie" value="{_file.U_VIEW_LINK}" />
				<param name="play" value="true" />
				<param name="loop" value="true" />
				<param name="quality" value="high" />
				<param name="allowScriptAccess" value="never" />
				<param name="allowNetworking" value="internal" />
				<embed src="{_file.U_VIEW_LINK}" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" width="{_file.WIDTH}" height="{_file.HEIGHT}" play="true" loop="true" quality="high" allowscriptaccess="never" allownetworking="internal"></embed>
			</object>


Par contre, le lien vers le fichier SWF que tu mentionnes est hébergé sur le site : http://www.imabox.fr/, auquel je pense tu as un compte ou tu as déjà posté un fichier joint ou un lien dans un de tes messages.

Et ceux sont ces messages à proprement parler qui comportent ton problème de redirection vers la page de l’index de ton forum : ce fichier SWF a non pas pour fonction d’afficher un contenu flash mais de créer un redirection (pour cette dernière hypothèse je ne savais pas que c’était possible mais pourquoi pas).

Toujours est-il que ce lien n’a pas été ajouté par l’extension ABBC3 dans un BBCode natif de phpBB 3.1.x ou dans un BBCode provenant de cette extension.

Ce BBCode nommé IMG a été configuré/modifié soit par une autre extension, je penserais à une extension en lien avec un service d’hébergement de fichiers/images, soit manuellement par une administrateur de ton forum.

Peut-être as-tu utilisé le Module hosting image EmpreintesDuWeb avec l’hébergeur de fichier imabox.fr à un moment donné.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.2.x & 3.3.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10562
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Suivante

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités