[Réglé] Abonnements aux forums et notifications...

Forum de support pour les questions concernant l'utilisation de phpBB 3.1, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Abonnements aux forums et notifications...

Messagepar antier » 04 Aoû 2015 à 17:50

Bonjour,

Avec l'aide utile et sympathique de certains d'entre vous, j'ai pu régler un premier problème dans le PCA ("tous administrateurs").

Je suis confronté à un autre problème : en juin, après être passé en version 3.1.4 , j'ai fortement incité les membres de mon forum associatif à s'abonner aux divers forums et s/forums et à effectuer les réglages nécessaires dans leur panneau de contrôle utilisateur pour recevoir les notifications par mail, ce qu'ils me réclamaient, habitués qu'ils étaient à la fonctionnalité "Envoyer une notification à tout le monde" dans la version 3.0.8 . Cela a fonctionné pendant un mois, mais depuis la fin du mois de juillet, plus personne ne reçoit de notification par mail... moi y compris. J'ai vérifié un par un les réglages de chaque utilisateur (pcu) et le pca : rien à redire, et tous sont bien abonnés... moi y compris :roll: En revanche, tout le monde reçoit normalement les notifications internes

Donc, a priori, ce problème ne vient pas du pca, des pcu et des abonnements...

Serait-il possible que ce dysfonctionnement provienne du serveur qui nous héberge (à titre gracieux) ? Et si oui, comment s'en apercevoir (FileZilla ?) et comment régler ce problème ?

Encore une fois, merci d'avance à ceux qui pourront m'aider de leurs conseils.
antier
Posteur néophyte
Posteur néophyte
 
Messages: 86
Enregistré le: 29 Aoû 2010 à 18:12
Localisation: Colombes

Re: Abonnements aux forums et notifications...

Messagepar Zoddo » 04 Aoû 2015 à 18:43

Bonjour,

Sur cette documentation, il y a un script qui permet de tester l'envoi d'e-mails.

Pouvez-vous essayer et nous dire si cela fonctionne ?
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7073
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval

Re: Abonnements aux forums et notifications...

Messagepar antier » 04 Aoû 2015 à 20:57

Merci ! J'ai essayé le script et ça fonctionne impeccablement, j'ai bien reçu le mail de test ! :o

Mais plus tôt dans la journée j'ai aussi voulu envoyer un courriel de masse adressé aux utilisateurs (s'étonnant de ne plus recevoir de notifications par mails :evil: ) mais ce mail n'est pas parti et j'ai reçu un message d'erreur me demandant d'aller dans le PCA >> Historique des Erreurs.

J'y ai trouvé ceci :


Une erreur de courrier électronique est survenue » EMAIL/SMTP /adm/index.php

Une erreur est survenue lors de l’envoi du courrier électronique à la ligne 1479. Réponse : 535 5.7.8 Error: authentication failed:
.
Backtrace
Connecting to ns39824.ovh.net:25
LINE: 1020 <- 220 ns39824.ovh.net ESMTP Postfix (Debian/GNU)

# EHLO ns3002771.ip-37-59-59.eu
LINE: 1369 <- 250-ns39824.ovh.net

LINE: 1369 <- 250-PIPELINING

LINE: 1369 <- 250-SIZE 104857600

LINE: 1369 <- 250-VRFY

LINE: 1369 <- 250-ETRN

LINE: 1369 <- 250-STARTTLS

LINE: 1369 <- 250-ENHANCEDSTATUSCODES

LINE: 1369 <- 250-8BITMIME

LINE: 1369 <- 250 DSN

# STARTTLS
LINE: 1414 <- 220 2.0.0 Ready to start TLS

# EHLO ns3002771.ip-37-59-59.eu
LINE: 1369 <- 250-ns39824.ovh.net

LINE: 1369 <- 250-PIPELINING

LINE: 1369 <- 250-SIZE 104857600

LINE: 1369 <- 250-VRFY

LINE: 1369 <- 250-ETRN

LINE: 1369 <- 250-AUTH PLAIN LOGIN

LINE: 1369 <- 250-AUTH=PLAIN LOGIN

LINE: 1369 <- 250-ENHANCEDSTATUSCODES

LINE: 1369 <- 250-8BITMIME

LINE: 1369 <- 250 DSN

# AUTH PLAIN
LINE: 1472 <- 334

# Omitting sensitive information
LINE: 1479 <- 535 5.7.8 Error: authentication failed:


antier
Posteur néophyte
Posteur néophyte
 
Messages: 86
Enregistré le: 29 Aoû 2010 à 18:12
Localisation: Colombes

Re: Abonnements aux forums et notifications...

Messagepar Zoddo » 04 Aoû 2015 à 22:23

Dans l'ACP > Général > Paramètre des e-mails, essayez de désactiver le SMTP.
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7073
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval

Re: Abonnements aux forums et notifications...

Messagepar antier » 05 Aoû 2015 à 00:04

Zoddo a écrit:Dans l'ACP > Général > Paramètre des e-mails, essayez de désactiver le SMTP.


Je l'ai fait... et ça marche ! Les mails passent bien (au moins aux 3 personnes à qui je les adressés).

[edit] et ce qui est encore plus fort, les mails de notifications passent aussi, je viens de tester à l'instant.

C'est génial... sauf que...

Le problème, c'est que je ne comprends pas pourquoi ça marche ! Le passage par le SMTP n'est donc pas obligatoire ? est-ce que, en agissant ainsi, je ne court-circuite pas les réglages du serveur faits dans le PCA par la personne qui héberge notre forum ?
antier
Posteur néophyte
Posteur néophyte
 
Messages: 86
Enregistré le: 29 Aoû 2010 à 18:12
Localisation: Colombes

Re: Abonnements aux forums et notifications...

Messagepar Zoddo » 05 Aoû 2015 à 00:08

Sauf cas exceptionnels, le passage par SMTP n'est pas obligatoire. La fonction mail() de php est censé suffire.
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7073
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval

Re: Abonnements aux forums et notifications...

Messagepar antier » 05 Aoû 2015 à 00:13

Je prends bonne note de cette réponse et vous remercie beaucoup pour cette intervention qui m'enlève une sacrée épine du pied ! :D

Par courtoisie, je vais tout de même avertir mon hébergeur pour savoir si cette solution lui convient.

En attendant sa réaction, je considère ce sujet comme réglé. Encore merci !
antier
Posteur néophyte
Posteur néophyte
 
Messages: 86
Enregistré le: 29 Aoû 2010 à 18:12
Localisation: Colombes

Re: Abonnements aux forums et notifications...

Messagepar Skouat » 05 Aoû 2015 à 00:22

Bonjour,

antier a écrit:Par courtoisie, je vais tout de même avertir mon hébergeur pour savoir si cette solution lui convient.

Si ça ne lui convenait pas il n'aurait pas autorisé la fonction mail() :wink:
Skouat
Resp. Traducteurs
Resp. Traducteurs
 
Messages: 14661
Enregistré le: 02 Avr 2008 à 20:47

Re: Abonnements aux forums et notifications...

Messagepar antier » 05 Aoû 2015 à 00:32

:lol:
antier
Posteur néophyte
Posteur néophyte
 
Messages: 86
Enregistré le: 29 Aoû 2010 à 18:12
Localisation: Colombes


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités