[Réglé] Images uploadées ne s'affichent pas

Forum de support pour les questions concernant l'utilisation de phpBB 3.1, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Images uploadées ne s'affichent pas

Messagepar treizecinq » 18 Juin 2015 à 12:53

Bonjour,
Voici mon souci :
Lorsque je place une image en pièce jointe, elle est bien uploadée mais elle ne s'affiche pas.
:? C'est grave docteur ?

Pour aller dans le détail : Je met en pièce jointe l'image 'Ma_Zoli_Image.png'
Dans l'onglet 'Fichier joint', le STATUT est ok (il y a la petite icône verte), il n'y a pas la miniature mais uniquement le nom de l'image et son extension ( 'Ma_Zoli_Image.png').
Si je clique sur le lien je vais à l'adresse : http://mon_site.com/phpBB3/download/file.php?mode=view&id=9

En regardant la souce de http://mon_site.com/phpBB3/download/file.php?mode=view&id=9, il n'y a rien, 0 , nada, keutchi

:shock: Bizarre ?

Si je regarde dans le dossier /files/ je vois mes images.
Par contre, elles ont toutes été renommées. Elles n'ont pas d'extension (Une histoire de Mime ?)

Je suis sur une config standard de phpBB3, pas de add-on
J'ai testé hier en local sous wamp (Windows), ça marchait nickel.
Je le teste en préprod sur un serveur local (Il tourne sous Debian et Lamp) et c'est le boxon :cry:

Une idée les z'amis ?
treizecinq
Posteur néophyte
Posteur néophyte
 
Messages: 3
Enregistré le: 18 Juin 2015 à 12:29

Re: Images uploadées ne s'affichent pas

Messagepar treizecinq » 18 Juin 2015 à 13:10

J'ai pas trouver la soluce
Si ça peut aider à comprendre ce qui coince :
Dans la BDD table phpbb_attachements, il y a les champs
physical_filename et real_filename
Ils correspondent respectivement au nom d'origine de mon image
et au nom de l'image qui se trouve dans le dossier /file/
Donc le problème ne vient pas de là.

Serait-ce un mauvais paramètrage de phpBB ?
treizecinq
Posteur néophyte
Posteur néophyte
 
Messages: 3
Enregistré le: 18 Juin 2015 à 12:29

Re: Images uploadées ne s'affichent pas

Messagepar treizecinq » 18 Juin 2015 à 13:21

Glup ?

Je relance le serveur est TADA !

Rien compris au prob, mais ça remarche :mrgreen:
treizecinq
Posteur néophyte
Posteur néophyte
 
Messages: 3
Enregistré le: 18 Juin 2015 à 12:29

Re: Images uploadées ne s'affichent pas

Messagepar Remi » 03 Juil 2017 à 15:30

Salut,

Je rè-ouvre ce sujet car j ai un problème similaire.

Plus aucune des images du forum de mon assos' ne s'affichent. Pourtant, les fichiers sont présents dans le dossier forum/files.
Le reste du forum fonctionne tres bien. ( meme si je cherche encore comment permettre d editer a chaque utilisateur ses messages )

le fichier .htaccess présent dans le dossier files etait sur " Deny for all " j ai donc essayé de le modifier en " allow for all " mais j ai le meme probleme. ( Ca aurait ete trop simple ^^ :mrgreen: )

J'ai l'impression qu il me manque le fichier config.php. Est ce possible ?

Merci pour votre aide !
Rémi
Remi
Posteur néophyte
Posteur néophyte
 
Messages: 12
Enregistré le: 30 Juin 2017 à 18:20

Re: Images uploadées ne s'affichent pas

Messagepar Steph » 03 Juil 2017 à 16:14

Salut,

C'est un sujet par membre et par demande, de plus celui-ci date un peu et chaque forum est différent.

La question étant réglée, le sujet a été verrouillé par un membre de l'équipe.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17266
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités