[Réglé] Forum qui rame beaucoup

Forum de support pour les questions concernant l'utilisation de phpBB3, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que Styles ou MODs.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Forum qui rame beaucoup

Messagepar BBBenj » 20 Jan 2014 à 00:12

Coucou !

Voici les bases :
adresse : http://www.ragbr.fr/forum
Compte test : utilisateur : test, mdp : testtest
Version : PHPBB 3.0.12
Date de mise en ligne : 4/1/2013
Hébergeur : OVH
Navigateur : Firefox 26 / IE 10 (d'autres utilisateurs avec Safari et Chrome, versions inconnues).
Utilisateurs : 38
Messages : 596
Mods installés : Attributs du sujet 1.2.2 / ACP add user 1.1.0 / Post as poster 1.0.1. / Show password strengh 1.0.3 / Show poll voters name 1.0.1 / Topic preview 1.0.10

Le forum rame beaucoup (pour le peu d'utilisateurs [38] et de messages [596]), j'ai également souvent des erreurs 503 et 504, parfois des erreurs msqli (je n'ai pas noté les détails pour la 504, je le ferai à la prochaine occurrence).

Erreur 503 :
Code: Tout sélectionner
503  Service Unavailable

Oupps.. seems that something went wrong. Please try to refresh this page one more time.

If the problems persists, please contact us, we will do our best to fix it.


Help your site go faster with the OVH CDN !


Erreur SQL :
Code: Tout sélectionner
General Error
SQL ERROR [ mysqli ]

Too many connections [1040]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.


Que faut-il regarder pour essayer d'améliorer la situation ?
Je sais que pour la dernière erreur, il y a assez peu d'espoir de résolution.

P.S. : s'il faut donner des droits "administrateur", ça peut s'envisager...
Modifié en dernier par BBBenj le 25 Jan 2014 à 09:49, modifié 3 fois.
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 18:38

Re: Forum qui rame beaucoup

Messagepar cabot » 20 Jan 2014 à 12:01

Hello,

Je ne sais pas si c'est La cause du problème, mais le code source renvoyé commence à la balise <head>, donc pas de doctype ni de balise html. Hors ces éléments sont bien présents dans le fichier du style.
Voilà, ça ne va peut-être pas beaucoup t'aider, mais c'est une piste à suivre pour les coupaings qui vont t'aider.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26809
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Forum qui rame beaucoup

Messagepar Invité » 20 Jan 2014 à 13:41

Bonjour,

Le dernier message indique que vous dépassez, d'une manière ou d'une autre, à certains moments, les capacités allouées à votre hébergement web.
Le premier, lui aussi courant, indique une surcharge temporaire et/ou une maintenance de la part du serveur.

Ce qui est étonnant c'est que vous ne semblez pas surchargé en modules, peut-être devriez-vous revoir votre offre d'hébergement ou contacter l'hébergeur.
Invité
 

Re: Forum qui rame beaucoup

Messagepar BBBenj » 20 Jan 2014 à 15:39

Coucou !

Tout d'abord, merci pour vos réponses.

@ ZePhYma :
Voici mon offre : http://www.ovh.com/fr/hebergement-web/h ... -perso.xml
Pas très cher, mais normalement vu la taille du forum, je n'imagine pas qu'une société comme OVH, avec la renommée et le nombre de clients, plomberait délibérément ses contrats... Donc je serai peut-être amené à contacter l'hébergeur, effectivement.

@ Cabot :
Étant assez novice en php (le moins qu'on puisse dire, même si je bosse dans l'informatique depuis 20 ans), je n'ai pas encore assez d'expérience pour débugger un code html... Que faut-il faire ?
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 18:38

Re: Forum qui rame beaucoup

Messagepar cabot » 20 Jan 2014 à 16:43

Vu que le code renvoyé n'est pas cohérent avec le contenu du fichier, rafraîchis le style (élément template) et vide le cache du forum. (voir lien dans ma signature)
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26809
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Forum qui rame beaucoup

Messagepar BBBenj » 20 Jan 2014 à 17:26

Coucou !
cabot a écrit:rafraîchis le style (élément template) et vide le cache du forum. (voir lien dans ma signature)

Déjà fait hier soir, à 22h45 puis à 23h05.

Dans le doute, je l'ai refait immédiatement. Templates + Thèmes + Images + Cache. La totale :D

Puis, déconnexion du compte, vidage du cache du navigateur, puis reconnexion à mon compte, dans cet ordre. C'est ce que je fais habituellement, depuis que j'ai remarqué que si je ne me déconnectais pas, les modifications du forum ne sont pas prises en compte. En fait, je me lance dans WAMP car je ferais tous ces tests en local. Il faut que je me penche dessus un peu plus.

Le titre des onglets sous la zone d'écriture des messages manque toujours, et le SUBMIT_VOTE est toujours là. Malheureusement, rien de changer. Tu veux un accès administrateur pour voir ce qui cloche (j'ai aussi le panneau des utilisateurs qui part en vrille dans le PCA) ?

Là, le forum semble assez rapide. Ce qui pourrait faire penser à un problème de charge des serveurs mutualisés ??
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 18:38

Re: Forum qui rame beaucoup

Messagepar cabot » 20 Jan 2014 à 17:44

Le code source est désormais correct (doctype et balise), c'est pour ça que ton forum s'affiche "normalement", il y a de fortes chances que ce rafraîchissement ait participé à résoudre le problème.

je ne te parle pas du SUBMIT_VOTE qui est un autre problème soulevé dans ce sujet. :wink:
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26809
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Forum qui rame beaucoup

Messagepar BBBenj » 20 Jan 2014 à 17:55

Je te remercie. On verra ce que ça donne ce soir, au moment du pic de connexions, si ça marche toujours aussi bien.

Est-ce que tu peux m'en dire un peu plus au sujet du "doctype" et "balise", je ne comprends pas de quoi tu parles et je ne demande qu'à apprendre...
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 18:38

Re: Forum qui rame beaucoup

Messagepar cabot » 20 Jan 2014 à 18:02

Tout est . :mrgreen:

Par contre, tu as un problème avec le sid qui s'affiche dans la barre d'adresse du navigateur.
Essaie de remplacer le domaine du cookie dans le panneau d'admin, actuellement il y a .forum.ragbr.fr au lieu de .ragbr.fr.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26809
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Forum qui rame beaucoup

Messagepar BBBenj » 20 Jan 2014 à 18:30

Waouh !

Bonjour le pavé ! Je vais potasser, donc... J'aurais aimé la méthode Assimil, mais bon... On fait avec ce qu'on a !

Pour le sid, c'est corrigé.
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 18:38

Re: Forum qui rame beaucoup

Messagepar cabot » 20 Jan 2014 à 18:45

Il y a plus didactique ici. :wink:
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26809
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Forum qui rame beaucoup

Messagepar BBBenj » 20 Jan 2014 à 19:12

Parfait !

Je sais quoi faire, maintenant, pour les 4 années qui viennent ! ;)

Allez, je fonce tout lire.
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 18:38

Re: Forum qui rame beaucoup

Messagepar cocooncrash » 21 Jan 2014 à 07:17

Bonjour,
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé].
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7732
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Forum qui rame beaucoup

Messagepar BBBenj » 23 Jan 2014 à 14:09

Coucou !

Je ne sais pas encore vraiment si le problème est résolu, je n'ai pas pu le vérifier aux heures de pointes. Je ferai ça ce soir et je viendrai donner le résultat.
Benjamin
_________________________________
Forum : http://forum.ragbr.fr/
Rencontres Astronomiques et Gastronomiques des Bouches du Rhône
Et http://forum.irp-smart-rx.com (phpBB 3.0.14) en cours de migration vers phpBB 3.2
Avatar de l’utilisateur
BBBenj
Posteur néophyte
Posteur néophyte
 
Messages: 92
Enregistré le: 16 Jan 2009 à 18:38

Re: Forum qui rame beaucoup

Messagepar cabot » 23 Jan 2014 à 14:21

En tout cas, ton forum est beaucoup plus rapide depuis que tu as fais la manip. :)
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26809
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Suivante

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 20 invités