[Réglé] Bug d'affichage

Forum de support pour les questions concernant l'utilisation de phpBB3, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que Styles ou MODs.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Bug d'affichage

Messagepar xatanael » 03 Fév 2010 à 20:36

Bonjour,

j'ai modifié le fichier "common.php" de mon forum pour mettre un lien retour, et il m'a mis ce message sur l'accueil :

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3877: Cannot modify header information - headers already sent by (output started at /language/fr/common.php:1)

J'ai alors annulé la modification, remis le fichier original, mais il me remet le même message !

Vous y comprenez quelque chose?

MErci,
Modifié en dernier par xatanael le 03 Fév 2010 à 21:40, modifié 1 fois.
xatanael
Apprenti-posteur
Apprenti-posteur
 
Messages: 129
Enregistré le: 02 Juil 2009 à 12:49

Re: Bug d'affichage

Messagepar Dr@gons » 03 Fév 2010 à 20:43

Salut,

As-tu vidé le cache après avoir annulé les modifs?

@+
Avatar de l’utilisateur
Dr@gons
Apprenti-posteur
Apprenti-posteur
 
Messages: 174
Enregistré le: 30 Mar 2007 à 19:13

Re: Bug d'affichage

Messagepar xatanael » 03 Fév 2010 à 20:43

Merci de ta réponse. Non, je n'avais pas vidé le cache, mais maintenant je ne sais même plus me logger...
Modifié en dernier par xatanael le 03 Fév 2010 à 21:43, modifié 1 fois.
xatanael
Apprenti-posteur
Apprenti-posteur
 
Messages: 129
Enregistré le: 02 Juil 2009 à 12:49

Re: Bug d'affichage

Messagepar Ariaswari » 03 Fév 2010 à 20:45

Bonsoir,

Le fichier doit être enregistré en UTF8 sans bom, ce qui est faisable via notepad++ par exemple.
Ancien supporter
« Douter de tout ou tout croire, ce sont deux solutions également commodes, qui l'une et l'autre nous dispensent de réfléchir (Henri Poincaré) »
Avatar de l’utilisateur
Ariaswari
Grand-maître des floodeurs
Grand-maître des floodeurs
 
Messages: 2738
Enregistré le: 18 Oct 2007 à 19:43

Re: Bug d'affichage

Messagepar Dr@gons » 03 Fév 2010 à 20:47

Vide le dossier /cache directement par ton ftp sauf les 2 fichiers suivant : index.htm et .htaccess dans un 1er temps, ensuite on verra comment ça se présente ;)

@+
Avatar de l’utilisateur
Dr@gons
Apprenti-posteur
Apprenti-posteur
 
Messages: 174
Enregistré le: 30 Mar 2007 à 19:13

Re: Bug d'affichage

Messagepar xatanael » 03 Fév 2010 à 20:50

Dr@gons a écrit:Vide le dossier /cache directement par ton ftp sauf les 2 fichiers suivant : index.htm et .htaccess dans un 1er temps, ensuite on verra comment ça se présente ;)

@+


C'est fait, mais rien n'a changé :cry:
xatanael
Apprenti-posteur
Apprenti-posteur
 
Messages: 129
Enregistré le: 02 Juil 2009 à 12:49

Re: Bug d'affichage

Messagepar xatanael » 03 Fév 2010 à 20:53

Ariaswari a écrit:Bonsoir,

Le fichier doit être enregistré en UTF8 sans bom, ce qui est faisable via notepad++ par exemple.


Comment dois-je faire pour l'enregistrer en UTF8 sans bom?
xatanael
Apprenti-posteur
Apprenti-posteur
 
Messages: 129
Enregistré le: 02 Juil 2009 à 12:49

Re: Bug d'affichage

Messagepar xatanael » 03 Fév 2010 à 20:56

D'après les messages d'erreur, on me dit que les bugs viennent du fichier "functions.php", de ces quatre lignes là :

header('Content-type: text/html; charset=UTF-8');

header('Cache-Control: private, no-cache="set-cookie"');
header('Expires: 0');
header('Pragma: no-cache');

Pourtant je ne les ai jamais modifiées :?
xatanael
Apprenti-posteur
Apprenti-posteur
 
Messages: 129
Enregistré le: 02 Juil 2009 à 12:49

Re: Bug d'affichage

Messagepar xatanael » 03 Fév 2010 à 20:59

J'ai trouvé quelqu'un dans le forum qui a exactement le même problème, si ça peut vous aider :

message1308746.html#p1308746
xatanael
Apprenti-posteur
Apprenti-posteur
 
Messages: 129
Enregistré le: 02 Juil 2009 à 12:49

Re: Bug d'affichage

Messagepar Dr@gons » 03 Fév 2010 à 21:14

Pour les complément d'information, il faut utiliser la fonction éditer de ton dernier message posté car sinon ça va être pris pour une remontée de topic et ça c'est 1 fois par tranche de 24h ;)
Je préfére le dire avant qu'un modo le fasse ;)

Sinon c'est normal si tu regarde l'erreur dit bien que c'est le fichier common.php par ce passage :
(output started at /language/fr/common.php:1)


Donc joint ton fichier modifié (en lien de dl) soit au format txt, soit archivé histoire que quelqu'un y jette en oeil ;)

@+
Avatar de l’utilisateur
Dr@gons
Apprenti-posteur
Apprenti-posteur
 
Messages: 174
Enregistré le: 30 Mar 2007 à 19:13

Re: Bug d'affichage

Messagepar xatanael » 03 Fév 2010 à 21:20

Mais j'ai enlevé toutes les lignes que j'avais ajouté dans les trois fichiers à modifier pour le lien retour, et l'erreur est tjrs là :?
Modifié en dernier par xatanael le 03 Fév 2010 à 21:44, modifié 1 fois.
xatanael
Apprenti-posteur
Apprenti-posteur
 
Messages: 129
Enregistré le: 02 Juil 2009 à 12:49

Re: Bug d'affichage

Messagepar Steph » 03 Fév 2010 à 21:22

  • 03 Fév 2010 à 20:50
  • 03 Fév 2010 à 20:53
  • 03 Fév 2010 à 20:56
  • 03 Fév 2010 à 20:59


Bonsoir xatanael,

Si tu ne souhaites pas que ton topic soit verrouillé je te prie de respecter les règles de phpBB-fr.com qui interdisent les UP en moins de 24 heures.

Si tu considères ton dernier message comme n'étant pas un UP alors ton complément d'information était à ajouter à ton précédent message grâce au bouton EDITER.

La solution à ton souci à été donné par Ariaswari, il faut encoder ton fichier /language/fr/common.php en UTF8 (sans BOM)

Pour ce faire tu peux utiliser Notepad++ > dans le menu clic sur Encodage > sélectionne Convertir en UTF8 (sans BOM)

@+ :wink:
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17574
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Bug d'affichage

Messagepar xatanael » 03 Fév 2010 à 21:31

Ca marche. Merci pour ce support efficace, rapide et très compétent. Bravo phpBB-fr.com !
xatanael
Apprenti-posteur
Apprenti-posteur
 
Messages: 129
Enregistré le: 02 Juil 2009 à 12:49

Re: Bug d'affichage

Messagepar Steph » 03 Fév 2010 à 21:33

[!] Si tu considère ton problème comme réglé, merci d'éditer le premier message de ce topic et d'ajouter l'icône de sujet Image

@+ :wink:
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17574
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 9 invités