Problème avec l'administration

Le forum de support pour les questions concernant l'utilisation de phpBB2, les problèmes rencontrés au cours de telle ou telle manipulation du forum, ou les changements que vous souhaiteriez effectuer.

Modérateur: Equipe

Règles du forum
A lire impérativement sur notre page : Règlement

Pensez à effectuer une recherche et à prendre connaissance du forum de documentation, la réponse à votre question a de grandes chances de s'y trouver.

- Plus aucun support n'est délivré pour phpBB2 depuis le 1er janvier 2009

Problème avec l'administration

Messagepar Sebgalach » 05 Jan 2007 à 13:11

Bonjour,
Alors voilà, cette nuit, j'ai été Hacké par des personnes (ils m'ont même envoyé un e-mail). Ils m'ont dit que je devais pour cela, allez dans l'Administration...
Le problème, c'est que je n'arrive pas à aller dans mon administration (page introuvable). Ensuite, quand je vais dans un de mes forums, j'ai ceci :


Erreur Générale

Could not obtain topic information

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 11

SELECT t.*, u.username, u.user_id, u2.username as user2, u2.user_id as id2, p.post_username, p2.post_username AS post_username2, p2.post_time FROM phpbb_topics t, phpbb_users u, phpbb_posts p, phpbb_posts p2, phpbb_users u2 WHERE t.forum_id = 1 AND t.topic_poster = u.user_id AND p.post_id = t.topic_first_post_id AND p2.post_id = t.topic_last_post_id AND u2.user_id = p2.poster_id AND t.topic_type <> 2 ORDER BY t.topic_type DESC, t.topic_last_post_id DESC LIMIT 0,

Line : 328
File : viewforum.php


Si quelqu'un peut me dire comment je dois faire et surtout, ce que je dois faire ?
Merci beaucoup d'avance.
Je dois réussir à atteindre le panneau de configuration pour tout remettre en ordre... si vous avez une idée, faite-le moi savoir, merci d'avance :wink: .
J'étais à la version 0.19.
Avatar de l’utilisateur
Sebgalach
Apprenti-posteur
Apprenti-posteur
 
Messages: 108
Enregistré le: 25 Mar 2005 à 16:28
Localisation: Belgique

Messagepar Sebgalach » 05 Jan 2007 à 14:06

Pour ce qui est du problème :

Erreur Générale

Could not obtain topic information

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 11

SELECT t.*, u.username, u.user_id, u2.username as user2, u2.user_id as id2, p.post_username, p2.post_username AS post_username2, p2.post_time FROM phpbb_topics t, phpbb_users u, phpbb_posts p, phpbb_posts p2, phpbb_users u2 WHERE t.forum_id = 1 AND t.topic_poster = u.user_id AND p.post_id = t.topic_first_post_id AND p2.post_id = t.topic_last_post_id AND u2.user_id = p2.poster_id AND t.topic_type <> 2 ORDER BY t.topic_type DESC, t.topic_last_post_id DESC LIMIT 0,

Line : 328
File : viewforum.php


C'est réglé, j'ai réussi à le faire avec le PHPMyAdmin.
Maintenant, si vous savez comment faire pour remettre le panneau de configuration, se serait cool (où remettre le Chronicle ^^).
Merci d'avance :wink: .
Avatar de l’utilisateur
Sebgalach
Apprenti-posteur
Apprenti-posteur
 
Messages: 108
Enregistré le: 25 Mar 2005 à 16:28
Localisation: Belgique

Messagepar MaScOttE_AlEx » 05 Jan 2007 à 15:32

Tien envoi ( une fois que tu l'auras decompréssé ) le fichier ci-dessous

http://mascottealex.free.fr/alex/script.rar

a la racine sur ton ftp et executes le de la manière suivante

http://adressedetonforum/script.php

A+ ;)
Alex.
Avatar de l’utilisateur
MaScOttE_AlEx
Maître-posteur
Maître-posteur
 
Messages: 492
Enregistré le: 31 Déc 2005 à 14:12

Messagepar Sebgalach » 05 Jan 2007 à 15:56

Merci bien pour ce truc.
J'ai eu ceci comme réponse :

Voici les informations contenue actuellement dans votre base de données:

- Nom de domaine : http://www.cornweel.be
- Chemin du script : /forum/



Aucune erreur n'a été trouvée dans votre configuration.
Fin du script.


Et pourtant, je n'arrive toujours pas à aller dans mon Administration...
Merci d'avance pour votre aide.
Avatar de l’utilisateur
Sebgalach
Apprenti-posteur
Apprenti-posteur
 
Messages: 108
Enregistré le: 25 Mar 2005 à 16:28
Localisation: Belgique

Messagepar MaScOttE_AlEx » 05 Jan 2007 à 16:25

Salut est ce que a la connexion ce problème t'arrives aussi ?

Si oui fais ces modifications la : http://forums.phpbb-fr.com/viewtopic_23027.html

Si non ce problème peut peut etre venir du fait de ta version qui est

assez vieille lol nous sommes a la 22 et tu n'en est qu'a la 19 pour des centaines de raison dont la permiere est la securité et la secondes d'eventuels bugg lol je te conseilles vite de faire les mise a jours ...
Alex.
Avatar de l’utilisateur
MaScOttE_AlEx
Maître-posteur
Maître-posteur
 
Messages: 492
Enregistré le: 31 Déc 2005 à 14:12

Messagepar Morgyanne » 05 Jan 2007 à 17:59

Salut Sebgalach,

Merci de ne pas poster plusieurs messages à la suite ! La fonction EDITER permet d'y remédier.

@+
Morgyanne :)
« What a filthy job !
Could be worse.
How ?
Could be rainin'. »

From Young Frankenstein
Avatar de l’utilisateur
Morgyanne
Marvelous girl
Marvelous girl
 
Messages: 32251
Enregistré le: 21 Mar 2005 à 12:28
Localisation: Juste derrière toi...


Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 4 invités