[Réglé] Perte d'images lors du passage en 3.3.0

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.3.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.3

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Perte d'images lors du passage en 3.3.0

Messagepar Ub3r-L » 16 Avr 2020 à 16:58

Re-bonjour.

Suite au sujet précédent

J'ai pu suivre la procédure de Steph, concernant les extensions et j'ai pu passer en 3.3.0
L’inscription semble bien re fonctionner.

J'ai un autre soucis, assez inquiétant, concernant les images du forum. (http://www.bushcraft.fr)
Elles semblent maintenant illisible ou «ne peut être afficher car elle contient des erreurs».


Image


Image


Ce qui m'inquiète car je n'ai pas touché aux fichiers:
Le fichier config.php
Le répertoire ext/
Le répertoire files/
Le répertoire images/
Le répertoire store/

durant la procédure.

J'ai uniquement supprimé le répertoire production qui se trouve dans le répertoire cache sur le FTP, comme indiqué par Steph.

:?
Modifié en dernier par Ub3r-L le 17 Avr 2020 à 15:40, modifié 2 fois.
“Si nous prenons la nature pour guide, nous ne nous égarerons jamais.” Cicéron
“Les choses nécessaires coûtent peu, les choses superflues coûtent cher.” Diogène
Ub3r-L
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 05 Aoû 2018 à 19:57

Re: Maj 3.3.0 Images

Messagepar On Stage » 16 Avr 2020 à 17:39

Salut
Il faudrait que tu donnes le lien d'un post ou se trouve une image corrompu, en regardant ce sujet ce n'est pas le cas : http://www.bushcraft.fr/phpBB/viewtopic.php?f=116&t=440
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 730
Enregistré le: 19 Mar 2018 à 16:04

Re: Merci de modifier le titre du sujet afin qu'il soit plus explicite.

Messagepar Steph » 16 Avr 2020 à 18:05

Salut,

Merci d'être plus inventif et explicite pour le choix du titre de sujet.

Pour ton souci, cela semble venir d'un mauvais usage du FTP, il faut utiliser le mode binaire.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20582
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Maj 3.3.0 Images

Messagepar Ub3r-L » 16 Avr 2020 à 19:10

On Stage a écrit:Salut
Il faudrait que tu donnes le lien d'un post ou se trouve une image corrompu, en regardant ce sujet ce n'est pas le cas : http://www.bushcraft.fr/phpBB/viewtopic.php?f=116&t=440


Oui, il y a plusieurs cas:

Soit elles sont visibles..

Soit seulement le nom.jpg s'affiche grisé et dès qu'on clique dessus elles s'affichent comme ici:
http://www.bushcraft.fr/phpBB/viewtopic ... 277&t=8461

Soit elle s'affiche un peu bugué comme ici par exemple: http://www.bushcraft.fr/phpBB/app.php/allume-feux

Soit l'image ne s'affiche pas car elle «contient des erreurs».



Steph a écrit:Salut,

Merci d'être plus inventif et explicite pour le choix du titre de sujet.

Pour ton souci, cela semble venir d'un mauvais usage du FTP, il faut utiliser le mode binaire.


Désolé :roll:

Effectivement, mais j'ai toujours été en automatique enfaite, c'est fou que ça arrive maintenant après plusieurs mise à jours.

Je suis donc repassé en binaire dans FileZilla.

J'aimerais savoir si il est possible de récupérer ces images, peut-être en remplaçant seulement un dossier dans mon FTP ? (là ou sont hébergé les images?..)

Merci ..
“Si nous prenons la nature pour guide, nous ne nous égarerons jamais.” Cicéron
“Les choses nécessaires coûtent peu, les choses superflues coûtent cher.” Diogène
Ub3r-L
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 05 Aoû 2018 à 19:57

Re: Perte d'images lors du passage en 3.3.0

Messagepar On Stage » 16 Avr 2020 à 19:23

Effectivement, mais j'ai toujours été en automatique enfaite, c'est fou que ça arrive maintenant après plusieurs mise à jours.

Ce n'est pas tant fou que ça. Quand en voiture tu fais tous les jours le même parcours pour aller bosser, il peut arriver qu'un jour tu ait un accident. C'est une image qui peut expliquer ton problème.

Les images en questions sont hébergées en externe ou en interne ?
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 730
Enregistré le: 19 Mar 2018 à 16:04

Re: Perte d'images lors du passage en 3.3.0

Messagepar Ub3r-L » 16 Avr 2020 à 19:37

Ok je vois, j'avais aussi eu de la chance avant alors..

Hum, je dirais en interne, dans le sens ou quand je vais dans le Pca, paramètres des fichiers joints, j'ai comme répertoire de transfert :
logs/_files_forum

Et on avait une politique d'hébergement général d'image propre au forum (sans utiliser d’hébergeur externe), pour justement éviter de perdre du contenu... :cry:

Après je sais pas vraiment comment ça fonctionne.. Je crois que c'est le répertoire Phpbb/Files ?

Si j'écrase ou supprime l'actuel et que j'ajoute celui de la sauvegarde de la semaine dernière, je retrouverais toutes mes images? (Sauf celles hébergés récemment?)

Je préfère demander avant de faire des expériences scabreuses maintenant ..
“Si nous prenons la nature pour guide, nous ne nous égarerons jamais.” Cicéron
“Les choses nécessaires coûtent peu, les choses superflues coûtent cher.” Diogène
Ub3r-L
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 05 Aoû 2018 à 19:57

Re: Perte d'images lors du passage en 3.3.0

Messagepar On Stage » 16 Avr 2020 à 19:40

Cette discussion parle exactement de ton problème : support-mises-a-jour-conversions-phpbb3/sujet205468.html
Avatar de l’utilisateur
On Stage
Roi des posts
Roi des posts
 
Messages: 730
Enregistré le: 19 Mar 2018 à 16:04

Re: Perte d'images lors du passage en 3.3.0

Messagepar Ub3r-L » 16 Avr 2020 à 20:15

Merci !

Pour moi quand j'upload de nouvelles images, elles s'affichent correctement aussi.


Le dossier /files actuel n'a que 21 fichiers, mais mon ancien fichier files en contient 53 alors que le forum à plus de 53 photos.

Est-il vrai que chaque fichier correspond à une image?


Dans la discussion il a du faire un backup complet.

Moi je voulais savoir si il n'y avait pas une méthode plus douce en gérant seulement le dossier files? (Car je viens de mettre prosilver à jours depuis 3.2.7 manuellement, ainsi que toutes les extensions pour avoir le forum en 3.3.0)

Si j'écrase ou supprime l'actuel dossier /files et que j'ajoute celui de la sauvegarde de la semaine dernière, je retrouverais toutes mes images? (Sauf celles hébergés récemment?)

Merci pour ton aide On Stage !
“Si nous prenons la nature pour guide, nous ne nous égarerons jamais.” Cicéron
“Les choses nécessaires coûtent peu, les choses superflues coûtent cher.” Diogène
Ub3r-L
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 05 Aoû 2018 à 19:57

Re: Perte d'images lors du passage en 3.3.0

Messagepar Steph » 16 Avr 2020 à 20:19

Quand tu fais la mise a jour il est demandé de conserver les répertoires images, files, store et le fichier config.php

Et prosilver est mis a jour en même temps que phpBB donc tu as fais ce boulot pour rien.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20582
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Perte d'images lors du passage en 3.3.0

Messagepar Ub3r-L » 16 Avr 2020 à 20:41

Steph a écrit:Quand tu fais la mise a jour il est demandé de conserver les répertoires images, files, store et le fichier config.php

Et prosilver est mis a jour en même temps que phpBB donc tu as fais ce boulot pour rien.


Oui, j'ai bien conservé ces répertoires?

Ub3r-L a écrit:Ce qui m'inquiète car je n'ai pas touché aux fichiers:
Le fichier config.php
Le répertoire ext/
Le répertoire files/
Le répertoire images/
Le répertoire store/


Image

A par ext/ que j'ai mis à jours,
Ya store qui c'est mit en 2020 mais je pense que ça c'est fait tout seul? non?

Les autres sont intacts depuis un moment..

J'ai pas compris pourquoi tu disais ça?..

Enfaite les photos s'enregistre dans: logs/_files_forum pour moi c'est ça? c'est pas plutôt celui là qu'il faut écraser?
“Si nous prenons la nature pour guide, nous ne nous égarerons jamais.” Cicéron
“Les choses nécessaires coûtent peu, les choses superflues coûtent cher.” Diogène
Ub3r-L
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 05 Aoû 2018 à 19:57

Re: Perte d'images lors du passage en 3.3.0

Messagepar Steph » 16 Avr 2020 à 20:46

Je dis ça, car si tu as vraiment pas touché a ces dossiers, les images en pièces jointes ne devraient pas poser de souci.

A moins d'avoir renvoyé des fichiers de ton pc dans le mauvais mode.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20582
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Perte d'images lors du passage en 3.3.0

Messagepar Ub3r-L » 16 Avr 2020 à 21:01

D'accord, mais oui effectivement, j'ai renvoyé l’intégralité de phpBB depuis mon ordi après avoir eu le premier échec concernant la mise à jours et la version Php qui n'était pas bonne, il y a quelques jours.. Je devais être en automatique à ce moment..

Ducoup c'est le fichier /logs ou il y a mes images? ou c'est quand même /files qui est probablement corrompu?
“Si nous prenons la nature pour guide, nous ne nous égarerons jamais.” Cicéron
“Les choses nécessaires coûtent peu, les choses superflues coûtent cher.” Diogène
Ub3r-L
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 05 Aoû 2018 à 19:57

Re: Perte d'images lors du passage en 3.3.0

Messagepar Sylveretour » 16 Avr 2020 à 21:07

Bonjour,

Avec un style pour phpBB 3.2.3 -> http://www.bushcraft.fr/phpBB/styles/bu ... /style.cfg et un forum en 3.3.0, il n'est pas étonnant que des bugs à la pelle soient présents.
Avatar de l’utilisateur
Sylveretour
Floodeur mature
Floodeur mature
 
Messages: 1661
Enregistré le: 21 Nov 2017 à 18:24
Localisation: West Coast

Re: Perte d'images lors du passage en 3.3.0

Messagepar Steph » 16 Avr 2020 à 21:26

Renvoie simplement ta sauvegarde des répertoires images, files et store en mode binaire et peut être que cela suffira.

Et la remarque pour le style est pertinente.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 20582
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Perte d'images lors du passage en 3.3.0

Messagepar Ub3r-L » 16 Avr 2020 à 23:31

Ah oui pour ce style facultatif, c'est un autre sujet ça.. chaque chose en son temps Sylveretour :oops:

Je suis un simple membre taillant des cuillères en bois tout nu dans la forêt qui essaye juste de mettre à jours le forum pour aider un peu la communauté, donc ça veut tout dire aussi. :mrgreen:

Mais j'essaye au moins ! :roll:
Et jusqu'à maintenant ça roulais quand même... Puis j'ai beaucoup appris en faisant ces erreurs, donc tant mieux si j'en fais à la pelle.

Mais oui, je tacherais de le mettre à jours..
Après quand t'y connais rien souvent quand ça fonctionne beh tu touches à rien.. :lol: ( :cry: )

Ok merci Steph, je vais essayer ça.


Edit;

Est-ce que c'est possible que ce soit pendant le premier téléchargement vers mon ordi pour avoir "ma sauvegarde" que les fichiers se soient corrompu ou c'est forcement lors d'un upload vers le FTP?

Parce que ça n'a pas l'air d'avoir fonctionner .. :cry:

Sinon pour comprendre un peu plus, les images hébergées s'enregistrent dans logs/_files_forum ? Mais c'est en lien avec files vu qu'on supprime le logs dans une mise à jours?
Modifié en dernier par Ub3r-L le 17 Avr 2020 à 08:49, modifié 1 fois.
“Si nous prenons la nature pour guide, nous ne nous égarerons jamais.” Cicéron
“Les choses nécessaires coûtent peu, les choses superflues coûtent cher.” Diogène
Ub3r-L
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 05 Aoû 2018 à 19:57

Suivante

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité