[Réglé] Mise à jour 3.2.2 vers 3.2.3 Fatal error

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.2.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar xerius67 » 23 Sep 2018 à 11:22

Bonjour,

J'ai commencé les étapes de mise à jour de mon forum en suivant les étapes décrites dans la page :

http://forums.phpbb-fr.com/documentation/mise-a-jour/mettre-a-jour-un-forum-phpbb-32x-a241-view.html#ancretelechargement

Voici ce que j'ai fait :
1. Backup ftp + base de données
2. Récupération du zip de mise à jour phpBB-3.2.2_to_3.2.3_FR.zip
3. copie des 3 dossiers du zip à la racine de mon forum (j'ai laissé en place les dossiers docs et vendor déjà existant dans mon arborescence

Lorsque je veux lancer l'install et je lance l'url https://mondomaine/forum/install
j'ai le message d'erreur suivant :

Fatal error: Class 'ComposerAutoloaderInitd6a848252e09a20076e6d520792a7d63' not found in /var/www/vhosts/xxxxxxxxxxxxxx.xxx/httpdocs/forum/vendor/autoload.php on line 7

j'ai remplacé le nom de mon domaine par des xxxxx

Que dois-je faire ?
Supprimer préalablement les dossiers docs, vendor et install de mon forum avant de les uploader à nouveau ?

Merci pour votre aide.
Modifié en dernier par xerius67 le 23 Sep 2018 à 15:40, modifié 1 fois.
xerius67
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 18 Jan 2018 à 10:38

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar Zoddo » 23 Sep 2018 à 11:26

Bonjour,

Effectivement, supprimer le dossier vendor avant de l'uploader à nouveau peut-être une bonne idée.

Si ça ne fonctionne toujours pas, supprimez le dossier cache/production/ (et cache/installer s'il existe).
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7043
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar xerius67 » 23 Sep 2018 à 11:46

Merci.
Je viens de supprimer le dossier vendor puis copie du dossier vendor du zip vers mon site.
A présent j'ai le message d'erreur suivant :

Warning: require_once(/var/www/vhosts/xxxxxxxxxxxx.xxx/httpdocs/forum/vendor/composer/autoload_real.php): failed to open stream: No such file or directory in /var/www/vhosts/xxxxxxxxxxxx.xxx/httpdocs/forum/vendor/autoload.php on line 5 Fatal error: require_once(): Failed opening required '/var/www/vhosts/xxxxxxxxxxxx.xxx/httpdocs/forum/vendor/composer/autoload_real.php' (include_path='.:/usr/share/php/') in /var/www/vhosts/xxxxxxxxxxxx.xxx/httpdocs/forum/vendor/autoload.php on line 5

On dirait qu'il manque à présent des fichiers et/ou dossiers
xerius67
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 18 Jan 2018 à 10:38

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar Zoddo » 23 Sep 2018 à 11:59

Ce fichier (vendor/composer/autoload_real.php) existe bien de l'archive. Qu'est-ce que vous utilisez pour envoyer les fichiers ? FileZilla ? Si oui, vérifiez que des transferts n'ont pas échoués (onglet en bas de la fenêtre).
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7043
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar xerius67 » 23 Sep 2018 à 12:02

oui j'utilise filezilla. Je vérifie bien qu'à chaque fois tous les transferts ont bien réussi.
Je vais à nouveau supprimer vendor, relancer filezilla puis refaire l'upload.
xerius67
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 18 Jan 2018 à 10:38

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar Zoddo » 23 Sep 2018 à 12:13

Oui, car c'est vraiment bizarre qu'il ne trouve pas le fichier si il a bien été envoyé…
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7043
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar xerius67 » 23 Sep 2018 à 12:21

Je viens de refaire la copie de l'arborescence. En fait je n'ai pas le dossier "composer" et il est absent du zip..
Bizarre
xerius67
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 18 Jan 2018 à 10:38

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar Zoddo » 23 Sep 2018 à 12:24

L'archive a été téléchargée ici : http://www.phpbb-fr.com/telechargements/ ?

Car je le vois bien dans l'archive de mise à jour :
Image

Ainsi que le fichier :
Image
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7043
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar xerius67 » 23 Sep 2018 à 13:03

Je viens de recontroler mon zip, il contient bien le dossier. J'ai dû faire une mauvaise manip.
Désolé pour cette erreur.

Je vais refaire la manip

EDIT :
J'ai fait une nouvelle décompression du zip. Le dossier composer est à présent bien extrait. L'installation ne plante plus et je peux avancer dans la migration de mon forum.

Je suis désolé, mais je suis à présent bloqué à l'étape "Mettre à jour les fichiers" : des listes de fichiers sont affichées : "Fichiers en conflit", "Fichiers modifiés", "Nouveaux fichiers", "Fichiers non modifiés de l’ancienne version, à mettre à jour".
Je peux juste cliquer sur le bouton "mettre à jour les fichiers" : Si je clique, puis refait une vérification des fichiers, je me retrouve au même stade...
Je précise que je n'ai pas apporté de modifications à aucun des fichiers listés et j'utilise le thème prosilver. Je ne sais pas comment continuer ma migration

Lorsque je télécharge le tar des fichiers en conflits puis je les upload par ftp, je me retrouve avec d'autres fichiers en conflit. Bizarre..
xerius67
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 18 Jan 2018 à 10:38

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar xerius67 » 23 Sep 2018 à 14:15

Finalement, j'ai réussi à terminer la mise à jour. Par contre, je n'accède plus au panneau d'administration (page blanche). J'ai testé en vidant le cache, mais rien n'y fait.

Je crains qu'il subsiste des conflits de fichiers.. Est-il possible d'écraser directement l'arborescence des fichiers d'admin en copiant par ftp les fichiers originaux contenus dans le zip de migration ?
Modifié en dernier par xerius67 le 23 Sep 2018 à 14:39, modifié 1 fois.
xerius67
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 18 Jan 2018 à 10:38

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar Zoddo » 23 Sep 2018 à 14:38

Peux-tu tenter d'activer le mode DEBUG pour voir si des erreurs apparaissent à la place des pages blanches ? support-installation-phpbb32/sujet211963.html#p1658534
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7043
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar xerius67 » 23 Sep 2018 à 14:55

Voici l'erreur qui s'affiche :

Parse error: syntax error, unexpected '<<' (T_SL), expecting ')' in /var/www/vhosts/xxxxxxxxxxxx.xxx/httpdocs/forum/language/fr/acp/common.php on line 444
xerius67
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 18 Jan 2018 à 10:38

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar xerius67 » 23 Sep 2018 à 14:59

Voici ce que j'ai lorsque j'affiche le contenu du fichier en question (j'ai dû faire une bétise lors de la mise à jour en écrasant les fichiers hébergés par ceux issus du .tar en conflit) :
La ligne 444 est : <<<<<<< CURRENT_FILE


Code: Tout sélectionner
	'UPLOAD_DIR_SIZE'	=> 'Taille des fichiers joints',
	'USERS_PER_DAY'		=> 'Moyenne d’utilisateurs enregistrés par jour',

<<<<<<< CURRENT_FILE
	'VALUE'						=> 'Valeur',
	'VERSIONCHECK_FAIL'			=> 'Échec pour obtenir l’information de la dernière version.',
	'VERSIONCHECK_FORCE_UPDATE'	=> 'Re-contrôler la version',
	'VERSION_CHECK'				=> 'Vérification de la version',
	'VERSION_CHECK_EXPLAIN'		=> 'Vérifie si votre installation de phpBB est à jour.',
	'VERSION_NOT_UP_TO_DATE_ACP'	=> 'Votre installation de phpBB n’est pas à jour.<br />Vous trouverez ci-dessous un lien vers l’annonce de publication qui contient davantage d’informations, telles que les instructions de mise à jour',
======= DIFF_SEP_EXPLAIN
	'VALUE'							=> 'Valeur',
	'VERSIONCHECK_FAIL'				=> 'Impossible d’obtenir les informations de la dernière version.',
	'VERSIONCHECK_FORCE_UPDATE'		=> 'Re-contrôler la version',
	'VERSIONCHECK_INVALID_ENTRY'	=> 'Les informations de la dernière version contiennent des données non supportées.',
	'VERSIONCHECK_INVALID_URL'		=> 'Les informations de la dernière version contiennent une URL non valide.',
	'VERSIONCHECK_INVALID_VERSION'	=> 'Les informations de la dernière version contiennent un numéro de version non valide.',
	'VERSION_CHECK'					=> 'Vérification de la version',
	'VERSION_CHECK_EXPLAIN'			=> 'Vérifie si votre installation de phpBB est à jour.',
	'VERSION_NOT_UP_TO_DATE_ACP'	=> 'Votre installation de phpBB n’est pas à jour.<br>Vous trouverez ci-dessous un lien vers l’annonce de publication qui contient davantage d’informations, telles que les instructions de mise à jour.',
>>>>>>> NEW_FILE
	'VERSION_NOT_UP_TO_DATE_TITLE'	=> 'Votre installation phpBB n’est pas à jour.',
	'VERSION_UP_TO_DATE_ACP'	=> 'Votre installation phpBB est à jour.',
	'VIEW_ADMIN_LOG'			=> 'Voir le journal d’administration',
	'VIEW_INACTIVE_USERS'		=> 'Voir les membres inactifs',

	'WELCOME_PHPBB'			=> 'Bienvenue dans phpBB',
	'WRITABLE_CONFIG'		=> 'Votre fichier de configuration (config.php) est actuellement accessible en écriture par tout le monde. Nous vous recommandons fortement de modifier les permissions en 640, ou au moins 644 (par exemple <a href="http://fr.wikipedia.org/wiki/chmod" rel="external">chmod</a> 640 config.php).',
));
xerius67
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 18 Jan 2018 à 10:38

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar Zoddo » 23 Sep 2018 à 15:05

Oui, c'est parce qu'il y avait des conflits qui n'ont pas pu être fusionnés automatiquement.

Le plus simple serait de renvoyer tout le dossier /language/fr/ depuis une archive complète ;)
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7043
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: Mise à jour 3.2.2 vers 3.2.3 Fatal error

Messagepar xerius67 » 23 Sep 2018 à 15:40

Merci pour tes réponses.

J'ai téléchargé le pack complet et écrasé les arborescences qui m'avaient été listées en conflit. A présent tout semble fonctionner correctement.
Merci pour ton aide.

Juste par curiosité, je n'ai pas compris l'étape des fichiers en conflit. Je n'ai pas vu la possibilité permettant d'écraser les fichiers locaux par ceux du package (à moins que j'ai loupé quelque chose ?)
xerius67
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 18 Jan 2018 à 10:38

Suivante

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron