[Réglé] Bbcode ne fonctionne pas sur le sujet depuis la maj en 3.2.2

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.2.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Bbcode ne fonctionne pas sur le sujet depuis la maj en 3.2.2

Messagepar shubnigg » 30 Jan 2018 à 18:16

Salut,
sur mon forum http://forums.trainerscity.org/ dans la liste de mes sujets j'ai mis du bbcode dans le texte et depuis la mise à jour cela n'est plus interprété...

Si je poste un sujet utilisant les bbcodes ceux ci fonctionnent mais pas dans le titre de mon sujet par exemple pour le texte que j'ai mis dans en dessous du règlement je le vois correctement dans l'admin (donc interprété, voir image : https://screenshots.firefox.com/Let8vVm6nYyPmg0Z/forums.trainerscity.org )mais sans le gras ou les couleurs en front j'ai cela comme texte :
Code: Tout sélectionner
Warez, Jeux Pirates, Serials, Crack, noCD, Divx, MP3... Publicité de vos sites, liens en signatures, Politique, Racisme, insultes, Pornos etc... sont [color=#FF0000][u]INTERDIT dans tous les FORUMS de ce site !!![/u][/color]
Merci aussi de respecter les Topics des Forums !
Suite à l'abus de certains vous devez fournir [u]une adresse e-mail valide[/u] pour vous inscrire et pour lire certaines parties du forum!
[b]Avant de poster pensez à lire[/b] [color=red][u][b][url=http://forums.trainerscity.org/viewtopic.php?t=3192][size=200]LE RÈGLEMENT !![/size][/b][/u][/color][/url]
[color=#FF0000][b]SPAM INTERDIT / SPAM VERBOTEN / SPAM PROHIBITED / СПАМ ЗАПРЕЩЕНО / СПАМ ЗАБРАНЕНО in all forums ![/b][/color]


du coup je suis allé regardé comment c'est encodé dans phpmyadmin et voici ce que je vois

Code: Tout sélectionner
<r>Warez, Jeux Pirates, Serials, Crack, noCD, Divx, MP3... Publicité de vos sites, liens en signatures, Politique, Racisme, insultes, Pornos etc... sont <COLOR color="#FF0000"><s>[color=#FF0000]</s><U><s>[u]</s>INTERDIT dans tous les FORUMS de ce site !!!<e>[/u]</e></U><e>[/color]</e></COLOR><br/>
Merci aussi de respecter les Topics des Forums !<br/>
Suite à l'abus de certains vous devez fournir <U><s>[u]</s>une adresse e-mail valide<e>[/u]</e></U> pour vous inscrire et pour lire certaines parties du forum!<br/>
<B><s>[b]</s>Avant de poster pensez à lire<e>[/b]</e></B> <COLOR color="red"><s>[color=red]</s><U><s>[u]</s><B><s>[b]</s><URL url="http://forums.trainerscity.org/viewtopic.php?t=3192"><s>[url=http://forums.trainerscity.org/viewtopic.php?t=3192]</s><SIZE size="200"><s>[size=200]</s>LE RÈGLEMENT !!<e>[/size]</e></SIZE></URL><e>[/b]</e></B><e>[/u]</e></U><e>[/color]</e></COLOR><i>[/url]</i><br/>
<COLOR color="#FF0000"><s>[color=#FF0000]</s><B><s>[b]</s>SPAM INTERDIT / SPAM VERBOTEN / SPAM PROHIBITED / СПАМ ЗАПРЕЩЕНО / СПАМ ЗАБРАНЕНО in all forums !<e>[/b]</e></B><e>[/color]</e></COLOR></r>


si vous avez une idée parce que là je comprend pas.... Merci d'avance
Modifié en dernier par shubnigg le 31 Jan 2018 à 18:29, modifié 2 fois.
shubnigg
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 27 Jan 2007 à 16:18

Re: Bbcode ne fonctionne pas sur le sujet depuis la maj en 3.2.2

Messagepar cocooncrash » 30 Jan 2018 à 18:38

Bonjour, lien vers votre forum?

Avez vous suivi le sujet ici : Problèmes connus
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7699
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Bbcode ne fonctionne pas sur le sujet depuis la maj en 3.2.2

Messagepar shubnigg » 30 Jan 2018 à 22:44

Bonjour,
Votre lien renvoi à un 404... et le lien vers mon forum est déjà dans le texte au dessus http://forums.trainerscity.org/
shubnigg
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 27 Jan 2007 à 16:18

Re: Bbcode ne fonctionne pas sur le sujet depuis la maj en 3.2.2

Messagepar Mazeltof » 30 Jan 2018 à 23:52

'soir ici,

Si je comprends bien ça concerne uniquement les descriptions de forum.
Ce soucis a déjà été évoqué et je ne pense pas que cela soit causé par la mise à jour de ton forum, sauf si tu es intervenu sur l'ancienne version à ce niveau, bien entendu.

Bref, tu peux essayer ce qui suit.

Dans bbcode.html
trouve :
Code: Tout sélectionner
<!-- BEGIN b_open --><strong class="text-strong"><!-- END b_open -->
<!-- BEGIN b_close --></strong><!-- END b_close -->

remplace par :
Code: Tout sélectionner
<!-- BEGIN b_open --><span style="font-weight: bold;"><!-- END b_open -->
<!-- BEGIN b_close --></span><!-- END b_close -->

trouve :
Code: Tout sélectionner
<!-- BEGIN i_open --><em class="text-italics"><!-- END i_open -->
<!-- BEGIN i_close --></em><!-- END i_close -->

remplace par :
Code: Tout sélectionner
<!-- BEGIN i_open --><span style="font-style: italic;"><!-- END i_open -->
<!-- BEGIN i_close --></span><!-- END i_close -->


Cela dit, il semble que tu appliques tes modifications de style directement dans prosilver. Je te suggère vivement de lire et d'appliquer cette doc pour te faciliter les mises a jour à venir (entre autre) :wink:
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2784
Enregistré le: 09 Mar 2009 à 23:02
Localisation: Arras

Re: Bbcode ne fonctionne pas sur le sujet depuis la maj en 3.2.2

Messagepar shubnigg » 31 Jan 2018 à 09:45

Bonjour,
merci cela fonctionne, mais pour info je n'ai rien modifié à part le logo et le fond de page pour éviter justement ce genre de problème et si je compare avec la version 3.2.2 qui est fournis sur le site c'est exactement la même...
Bref c'est un peu étrange.
Merci quand même pour le coup de main :D
shubnigg
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 27 Jan 2007 à 16:18

Re: Bbcode ne fonctionne pas sur le sujet depuis la maj en 3.2.2 [réglé]

Messagepar Mazeltof » 31 Jan 2018 à 11:08

'jour ici,

Effectivement, sur la version précédente le soucis se posait uniquement sur les styles hérités et ça fonctionnait correctement pour prosilver.

Je n'ai pas regardé plus en détail pour trouver les raisons de ce problème mais tu as aussi la possibilité de contourner ce soucis en modifiant uniquement le css (et sans modifier le fichier bbcodes.html)

dans colours.css, ajoute à la fin du fichier :
Code: Tout sélectionner
li.row strong {
    color: inherit;
    font-weight: bold;
}

Cette méthode corrigera également le soucis pour les styles hérités, sauf, bien sur, règles contraires spécifiques à ces derniers.

NB: pour mettre l'attribut [Réglé] il faut selectionner l''attribut dans le menu deroulant "Attribut de sujet :" en editant ton premier message ou juste en dessous sur la droite :wink:
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2784
Enregistré le: 09 Mar 2009 à 23:02
Localisation: Arras

Re: Bbcode ne fonctionne pas sur le sujet depuis la maj en 3.2.2

Messagepar shubnigg » 31 Jan 2018 à 18:34

Bonjour,
Effectivement ça marche aussi ;) Merci beaucoup !
shubnigg
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 27 Jan 2007 à 16:18


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité