The config setting "captcha_plugin" unexpectedly does not exist

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.2.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

The config setting "captcha_plugin" unexpectedly does not exist

Messagepar cosmo14 » 10 Jan 2018 à 16:18

Bonjour à toute la communauté,

je m'attèle à upgrader un forum qui fonctionne encore bien sur son vieux 3.0.4, en suivant le tuto bien détaillé (documentation/mise-a-jour/32x-mise-a-niveau-de-phpbb-30x-vers-32x-a228-view.html )

J'ai tout bien suivi, sauf l'utilisation de l'outil STK car il n'est pas prévu pour 3.0.4 me semble-t-il.

Bref, juste après avoir cliqué sur le bouton update dans /install/ le script se bloque et j'ai ce message d'erreur :

The config setting "captcha_plugin" unexpectedly does not exist.

Reverting Schema: \phpbb\db\migration\data\v30x\release_3_0_6_rc1.


Et donc je sèche :mrgreen:

Merci d'avance pour vos lumières... :wink:
Modifié en dernier par cosmo14 le 11 Jan 2018 à 09:11, modifié 1 fois.
cosmo14
Posteur néophyte
Posteur néophyte
 
Messages: 4
Enregistré le: 10 Jan 2018 à 16:11

Re: Merci de modifier le titre du sujet afin qu'il soit plus explicite.

Messagepar Steph » 10 Jan 2018 à 17:17

Salut,

Tout d'abord, merci d'être plus inventif dans le choix du titre de ton sujet. Nous savons que tu as un problème donc inutile de l'indiquer, tout comme le message d'erreur est plus explicite que d'indiquer simplement "problème de mise à jour de XX à XX". Au delà de cela, un bon titre permettra une recherche plus efficace par les autres membres.

Pour ton message d'erreur regarde ce sujet : https://www.phpbb.com/community/viewtop ... &t=2409386
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18521
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Merci de modifier le titre du sujet afin qu'il soit plus explicite.

Messagepar Sylveretour » 10 Jan 2018 à 18:29

Bonjour,

Le stk pour les version 3.0 de phpBB est ici => https://www.phpbb.com/customise/db/official_tool/stk/
Version: 1.0.7-PL3
Released: Wed, May 6th 2015
Supported phpBB versions: 3.0.0 - 3.0.14
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 512
Enregistré le: 21 Nov 2017 à 18:24
Localisation: West Coast

Re: The config setting "captcha_plugin" unexpectedly does not exist

Messagepar cosmo14 » 11 Jan 2018 à 09:12

Merci pour vos réponses, je vais regarder si je peux corriger quelque chose avec le bon outil :wink:
cosmo14
Posteur néophyte
Posteur néophyte
 
Messages: 4
Enregistré le: 10 Jan 2018 à 16:11

Re: Merci de modifier le titre du sujet afin qu'il soit plus explicite.

Messagepar cosmo14 » 11 Jan 2018 à 09:14

Steph a écrit:Pour ton message d'erreur regarde ce sujet : https://www.phpbb.com/community/viewtop ... &t=2409386

Donc a priori l'upgrade direct ne serait pas possible comme indiqué dans le tuto que j'ai mentionné ? :?
cosmo14
Posteur néophyte
Posteur néophyte
 
Messages: 4
Enregistré le: 10 Jan 2018 à 16:11

Re: The config setting "captcha_plugin" unexpectedly does not exist

Messagepar Sylveretour » 11 Jan 2018 à 10:31

Dans l'explication, il est indiqué le point 4: https://www.phpbb.com/community/viewtop ... #p14466101
4. Ensure that the activated spambot countermeasure is one of the standard phpBB plugins (Simple image, GD image, GD 3D image, Q&A, reCaptacha).

Tu doit donc avant tout choisir une captcha d'origine à phpBB dans ton 3.0.4 avant de lancer la conversion
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 512
Enregistré le: 21 Nov 2017 à 18:24
Localisation: West Coast


Retourner vers Mises à jour/Conversions

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron