[Réglé] Message d'erreur administration du forum.

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.2.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Message d'erreur administration du forum.

Messagepar ikvat » 22 Aoû 2017 à 16:45

Bonjour
Il y a quelques mois de cela, j'ai migré mon forum vers phpbb 3.2.0. Même si la migration n'avait pas été de tout repos, je n'avais alors pas constaté de problèmes particuliers et tout était opérationnel. Il y a quelques semaines, histoire de vérifier si une nouvelle mise à jour de phpbb était disponible, je me suis connecté au panneau d'administration et là, catastrophe, j'ai lemessage d'erreur suivant :

Code: Tout sélectionner
 [phpBB Debug] PHP Warning: in file [ROOT]/phpbb/db/driver/mysql.php on line 275: mysql_fetch_assoc(): 21 is not a valid MySQL result resource
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3257)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3257)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3257)


Je profite donc de quelques jours de vacances pour tenter de résoudre ce problème, mais je ne sais pas trop par où commencer.
Je sollicite votre patience et vos connaissances afin de m'aider.
Merci
Olivier
Modifié en dernier par ikvat le 23 Aoû 2017 à 08:55, modifié 1 fois.
ikvat
Posteur néophyte
Posteur néophyte
 
Messages: 59
Enregistré le: 22 Juin 2002 à 10:19

Re: Message d'erreur administration du forum.

Messagepar galixte » 22 Aoû 2017 à 18:44

Salut,

tu as un sujet similaire sur .com : https://www.phpbb.com/community/viewtop ... &t=2423181.

D’après le sujet sur .com Il semble que cela soit un problème avec un élément de la base de données qui n’est pas dans l’état attendu par phpBB. Peut-être qu’une réparation des tables, un nettoyage avec l’outil « Support Toolkit » pourraient corriger ce problème.

L’affichage de tes erreurs est similaire à cette page ? http://webcache.googleusercontent.com/s ... ient=opera mais uniquement dans ton panneau d’administration, c’est bien ça ? Sur toutes les pages ?

Tu pourrais commencer par :
  1. supprimer les répertoires suivant de ton espace FTP :
    • ./phpbb/
    • ./includes/
  2. envoyer ces mêmes répertoires en prenant comme source l’archive original de phpBB 3.2.x (je ne sais quelle version tu utilises 3.2.0 ou 3.2.1)
  3. purger le contenu du répertoire ./cache/ de ton forum (sauf les fichiers ./cache/index.htm et ./cache/.htaccess).

J’ai un doute sur le contenu de ton fichier ./config.php, peux-tu nous partager son contenu (en prenant soin de modifier tes identifiants) ?
Modifié en dernier par galixte le 06 Déc 2017 à 03:22, modifié 1 fois.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Message d'erreur administration du forum.

Messagepar ikvat » 22 Aoû 2017 à 19:55

Hello galixte
Le message n'apparait que sur les deux premiers onglets de l'administration. Pour le troisième onglet, j'ai une page blanche mais par contre, les autres onglets s'affichent normalement.
Autrement, j'ai également un message qui s'affiche en partie utilisateur quand on clique sur le lien Voir plus de smileys :
Code: Tout sélectionner
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/db/driver/mysql.php on line 275: mysql_fetch_assoc(): 21 is not a valid MySQL result resource
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/db/driver/mysql.php on line 275: mysql_fetch_assoc(): 22 is not a valid MySQL result resource


Mon fichier config<?php

Code: Tout sélectionner
// phpBB 3.0.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'mysql';
$dbhost = 'localhost';
$dbport = '80';
$dbname = 'dbmachin';
$dbuser = 'moi';
$dbpasswd = 'mdp';
$table_prefix = 'ici_';
$acm_type = 'file';
$load_extensions = '';

@define('PHPBB_INSTALLED', true);
// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);


Je me demande si le problème n'est pas lié aux smileys
ikvat
Posteur néophyte
Posteur néophyte
 
Messages: 59
Enregistré le: 22 Juin 2002 à 10:19

Re: Message d'erreur administration du forum.

Messagepar papajoke » 22 Aoû 2017 à 21:02

bonjour,

c'est en effet un message d'avertissement car php n'a pas pu libérer de la mémoire le résultat d'une requete sql qui a retournée une ressource non valide.

A voir effectivement si ta table phpbb_smilies est intacte, sinon tu peux aussi dévalider tes extensions pour voir si cela viendrais d'une.
modérateur forum manjaro.fr
Avatar de l’utilisateur
papajoke
Apprenti-posteur
Apprenti-posteur
 
Messages: 121
Enregistré le: 23 Juil 2017 à 12:45

Re: Message d'erreur administration du forum.

Messagepar galixte » 22 Aoû 2017 à 21:49

Remplace le contenu de ton fichier ./config.php par ça :

Code: Tout sélectionner
<?php
// phpBB 3.2.x auto-generated configuration file
// Do not change anything in this file!
$dbhost = 'localhost';
$dbport = '';
$dbname = 'nomdelaBDD';
$dbuser = 'nomdutilisateurBDD';
$dbpasswd = 'motdepasseBDD';
$table_prefix = 'tonprefixeBDD_';
$dbms = 'phpbb\\db\\driver\\mysql';
$acm_type = 'phpbb\\cache\\driver\\file';
$phpbb_adm_relative_path = 'adm/';

@define('PHPBB_INSTALLED', true);
//@define('DEBUG', true);
@define('PHPBB_ENVIRONMENT', 'production');
//@define('DEBUG_CONTAINER', true);
//@define('PHPBB_DISPLAY_LOAD_TIME', true);


MySQLi n’est pas disponible sur ton hébergement ? Auquel cas tu peux remplacer la ligne $dbms = 'phpbb\\db\\driver\\mysql'; par $dbms = 'phpbb\\db\\driver\\mysqli';.

Faire un test ne va pas causer de dommage, tu peux donc essayer. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Message d'erreur administration du forum.

Messagepar ikvat » 23 Aoû 2017 à 07:13

Bonjour galixte
J'ai purgé le cache et le problème a disparu. J'ai toutefois un autre souci de taille. Quand je purge le cache, Mon serveur surcharge et tous les services s’arrêtent.
ikvat
Posteur néophyte
Posteur néophyte
 
Messages: 59
Enregistré le: 22 Juin 2002 à 10:19

Re: Message d'erreur administration du forum.

Messagepar Steph » 23 Aoû 2017 à 08:10

Salut,

Autre souci = autre demande = un autre sujet = un auteur

Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17622
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Message d'erreur administration du forum.

Messagepar ikvat » 23 Aoû 2017 à 08:59

Merci pour ton aide galixte
Mon problème est en partie réglé grâce à toi. J'ai vidé le cache et changé mysql en mysqli
J'ouvre donc un nouveau sujet pour continuer mes investigations.

Suite
support-mises-a-jour-conversions-phpbb32/sujet210568.html
ikvat
Posteur néophyte
Posteur néophyte
 
Messages: 59
Enregistré le: 22 Juin 2002 à 10:19

Re: Message d'erreur administration du forum.

Messagepar galixte » 23 Aoû 2017 à 14:39

Salut,

d’après ce que je lis tu as modifié ton fichier config uniquement pour la ligne de MySQL. As-tu aussi mis à jour les autres lignes ? C’est important d’avoir un fichier config pleinement conforme à phpBB 3.2.x. ;)

C’est un problème récurrent depuis phpBB 3.1.x, phpBB ne met pas à jour ce fichier et c’est bien dommage. :?

À ce propos, ABDev parlait de publier une mise à jour de son outil, il y a-t-il des nouvelles de ce projet ?
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité