Erreur upgrade 3.2.0 -> 3.2.1

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.2.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

Erreur upgrade 3.2.0 -> 3.2.1

Messagepar Aurelienazerty » 17 Juil 2017 à 14:18

Bonjour,

Ayant été confronté à des problèmes pour upgrader ma version, je partage mon expérience :
  1. Pensez à supprimer le répertoire vendor avant de copier les fichiers du "Automatic Update Package"
  2. Penez à purger le cache
    • Soit via le panneau d'administration
    • Soit à l'ancienne en supprimer le répertoire cache/production/

Et si vraiment ça ne fonctionne pas, si vous avez une version non modifiée de phpbb, récupérez les package complet, et faites comme une installation complète ne garder que :
  • config.php file
  • images/ directory
  • files/ directory
  • store/ directory
  • ext/ directory
puis uploadez le "Automatic Update Package" et ne faites que la MAJ de la bdd. C'est violent, mais ça passe.

Bonne mise à jour à tous.
http://www.team-azerty.com Association organisatrice de LAN "fun" au sud de Lyon
Aurelienazerty
Apprenti-posteur
Apprenti-posteur
 
Messages: 141
Enregistré le: 20 Avr 2004 à 18:31

Re: Erreur upgrade 3.2.0 -> 3.2.1

Messagepar spitfrog » 17 Juil 2017 à 23:50

Bonjour,

Je suis un peu novice, aussi, merci de remettre à ma place si ce n'est pas le bon endroit. :)

J'ai eu très chaud lors du passage à phpBB 3.2, plus grand-chose ne fonctionnait (styles, extensions, etc.) j'ai du passer une semaine à remettre de l'ordre dans un charabia dont je me dis à chaque fois, j'ai eu de la chance de m'en sortir indemne.
J'ai vu dans PCA la mise à jour 3.2.1, j'ai téléchargé l'archive automatique de mise à jour comme indiqué, je l'ai décompressée au bon endroit (sans supprimer "vendor" et "docs" car ce n'était pas demandé). Je reviens pour la suite de l'installation, et là, plus rien, page vide ! Heureusement que l'hébergeur avait des snapshots du site, sinon je n'aurais pas pu faire marche arrière.

Ma question double est : est-ce parce que je n'ai pas supprimé ces dossiers avant ("vendor" et "docs") ? Est-ce dû à la langue du forum, faut-il attendre la traduction sur phpBB-fr pour chaque mise à jour ?

Merci
spitfrog
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 29 Aoû 2002 à 07:36

Re: Erreur upgrade 3.2.0 -> 3.2.1

Messagepar Aurelienazerty » 18 Juil 2017 à 03:30

C'est bien là le problème, c'est que ce n'est pas clairement écrit qu'il faut supprimer le dossier vendor avant la maj. Le dossier docs, on s'en fiche.
http://www.team-azerty.com Association organisatrice de LAN "fun" au sud de Lyon
Aurelienazerty
Apprenti-posteur
Apprenti-posteur
 
Messages: 141
Enregistré le: 20 Avr 2004 à 18:31

Re: Erreur upgrade 3.2.0 -> 3.2.1

Messagepar cabot » 18 Juil 2017 à 06:38

Décidément, entre ce problème et les erreurs de style, c'est encore une belle réussite cette MàJ...

Pour éviter le chevauchement de la pagination dans la liste des sujets :
Image

Ouvrir prosilver/theme/common.css

Trouver :
Code: Tout sélectionner
.row .pagination {
	display: block;
	margin-top: -12px;
}

Remplacer margin-top: -12px; par margin-top: 0.3em;.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Erreur upgrade 3.2.0 -> 3.2.1

Messagepar galixte » 18 Juil 2017 à 08:39

Salut,

Oh non… :( cabot ne nous dit pas qu’elle est foireuse cette mise à jour ? :?

Peut-on s’attendre à une publication des packs de langue dans la journée ? Histoire de s’organiser. Merci pour la rustine. :wink:
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9882
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

MAJ de style

Messagepar Aurelienazerty » 18 Juil 2017 à 11:07

Perso j'ai mis à jour les styles, je n'ai pas eu de soucis de ce côté là.
http://www.team-azerty.com Association organisatrice de LAN "fun" au sud de Lyon
Aurelienazerty
Apprenti-posteur
Apprenti-posteur
 
Messages: 141
Enregistré le: 20 Avr 2004 à 18:31

Re: Erreur upgrade 3.2.0 -> 3.2.1

Messagepar Skouat » 18 Juil 2017 à 12:37

Bonjour,

Message à ceux qui utiliserait le pack de langue de phpBB-fr.com.
=> Ne procédez pas à la mise à jour de votre forum. Attendez que nos packs soient publiés.

Inutile de vous précipiter ;)

@Galixte : Non pas dans la journée car, comme d'habitude, nous testons les packs avant publication et nous le faisons sur notre temps libre.

++
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13395
Enregistré le: 02 Avr 2008 à 19:47

Re: Erreur upgrade 3.2.0 -> 3.2.1

Messagepar tomberaid » 18 Juil 2017 à 19:42

Hello
@ Cabot, l'erreur de position de la pagination n'est pas pour prosilver (style par défaut) mais pour le style présent sur phpbb.com. Je pense que cela sera bientôt corrigé, avec la rapidité de leur staff :mrgreen: :arrow:
Image
Avatar de l’utilisateur
tomberaid
Roi des posts
Roi des posts
 
Messages: 691
Enregistré le: 17 Juin 2009 à 23:27

Re: Erreur upgrade 3.2.0 -> 3.2.1

Messagepar Aurelienazerty » 19 Juil 2017 à 07:42

Sur le forum phpbb.com, il suffit de faire un F5 pour charger le style mis à jour.
http://www.team-azerty.com Association organisatrice de LAN "fun" au sud de Lyon
Aurelienazerty
Apprenti-posteur
Apprenti-posteur
 
Messages: 141
Enregistré le: 20 Avr 2004 à 18:31

Re: Erreur upgrade 3.2.0 -> 3.2.1

Messagepar gpinpin » 27 Juil 2017 à 12:48

Bonjour
Ce qui est sur c'est que je ferai des tests en local avant mais aussi je profite de votre expérience en vous lisant
Merci à tous
Gpinpin
Forum en 3.21 et PHP 7.19
gpinpin
Posteur habitué
Posteur habitué
 
Messages: 228
Enregistré le: 12 Mar 2008 à 10:28


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité