3.0.13 -> 3.2, erreurs lors d'accès à certains onglets du PCA

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.2.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

3.0.13 -> 3.2, erreurs lors d'accès à certains onglets du PCA

Messagepar Tom23mj » 10 Mai 2017 à 10:44

Bonjour,

Je gère un forum dont l'ancien webmaster ne peut plus s'occuper.
Souhaitant le mettre à jour vers la version 3.2, j'ai suivi le tuto trouvé sur le forum, et tout s'est bien passé pour les utilisateurs.
Comme je voulais me passer du mod breizh shoutbox 1.5 pour passer à quelque chose de toujours soutenu, donc mchat 2, je me suis rendu dans le PCA, et c'est là que je suis tombé sur des erreurs en allant dans des onglets.

Pour "Extensions" j'ai l'erreur suivante :

Code: Tout sélectionner
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_portal.php on line 28: include(./../portal/includes/constants.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_portal.php on line 28: include(): Failed opening './../portal/includes/constants.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear')
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_portal.php on line 32: include(./../PORTAL_ROOT_PATHincludes/functions_modules.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_portal.php on line 32: include(): Failed opening './../PORTAL_ROOT_PATHincludes/functions_modules.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear')
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_portal.php on line 37: include(./../PORTAL_ROOT_PATHincludes/functions_version_check.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_portal.php on line 37: include(): Failed opening './../PORTAL_ROOT_PATHincludes/functions_version_check.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear')
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_portal.php on line 42: include(./../PORTAL_ROOT_PATHincludes/functions.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_portal.php on line 42: include(): Failed opening './../PORTAL_ROOT_PATHincludes/functions.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear')


Et pour l'onglet "ACP_SHOUTBOX" j'ai celle-ci :

Code: Tout sélectionner
Erreur générale
Impossible de trouver le module « ./../includes/acp/acp_shoutbox.php »

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()


Ce dernier onglet étant celui qui permettait de gérer breizh shoutbox, donc il m'importe peu.

Mon problème est que je ne peux pas gérer d'extension à cause de ces erreurs. En passant, j'avais désactivé breizh shoutbox sur l'ancien forum avant de faire la mise à jour.

Les paramètres du serveurs sont :

apache 2.2.22
mysql 5.5.55
PHP 5.4.45

Merci d'avance pour votre aide.
Modifié en dernier par Tom23mj le 10 Mai 2017 à 14:47, modifié 1 fois.
Tom23mj
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 21 Fév 2012 à 17:26

Re: 3.0.13 -> 3.2, soucis dans le PCA

Messagepar galixte » 10 Mai 2017 à 11:03

Salut,

recommence ta mise à niveau vers phpBB 3.2.x, mais avant de procéder tu dois nettoyer la base de données de toute trace d’anciens MOD installés au moyen de l’outil STK.
Modifié en dernier par galixte le 18 Mai 2017 à 04:34, modifié 1 fois.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9918
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: 3.0.13 -> 3.2, erreurs lors d'accès à certains onglets du PCA

Messagepar Tom23mj » 10 Mai 2017 à 14:49

Merci de ta réponse, mais quand je vais dans le stk, il me dit que seuls les fondateurs peuvent l'utiliser.
Je ne suis pas fondateur mais seulement admin.
Tom23mj
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 21 Fév 2012 à 17:26

Re: 3.0.13 -> 3.2, erreurs lors d'accès à certains onglets du PCA

Messagepar galixte » 10 Mai 2017 à 15:47

Utilise le compte de ton amis ou demande lui de te mettre fondateur ou encore, accède à la base de données et modifie ton compte pour le champ user_type avec la valeur 3.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9918
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: 3.0.13 -> 3.2, erreurs lors d'accès à certains onglets du PCA

Messagepar Tom23mj » 10 Mai 2017 à 18:03

Merci pour cette seconde réponse, je vais tester tout ça et je reviens vers vous pour vous dire ce qu'il en est.

Edit :

Je me suis mis le titre de fondateur via la base de données pour pouvoir utiliser le stk.

J'ai bien utilisé le database cleaner cette fois. La première fois j'ai eu pas mal de choses à nettoyer, et comme il est conseillé de multiplier les passes, je l'ai fait 3 ou 4 fois par la suite.
Sur ces passes, je n'ai eu aucune proposition de nettoyage contrairement à la première fois.

J'ai donc retenté la mise à jour, et j'ai le message d'erreur suivant :
Code: Tout sélectionner
UCP_AUTH_LINK_MANAGE


J'ai tenté de refaire chaque étape, mais ans succès, j'ai toujours la même erreur. Je ne vois pas ce qui peut poser problème.
Quand je tente malgré tout d'accéder au forum et à l'ACP, j'ai un message me disant que la mise à jour s'est mal passée et que le forum est en version 3.2 mais la base de donnée en version 3.1
Tom23mj
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 21 Fév 2012 à 17:26

Re: 3.0.13 -> 3.2, erreurs lors d'accès à certains onglets du PCA

Messagepar galixte » 11 Mai 2017 à 00:34

  1. Puisque tu t’es rendu dans le panneau d’administration, vide le cache de ton forum (préfère la méthode 2 via le FTP).
  2. Il reste encore des traces car UCP_AUTH_LINK_MANAGER est un module à supprimer et puisque l’outil STK ne s’en est pas chargé, tu te rends dans la base de données via l’outil phpMyAdmin. De souvenir, ce module se trouve dans la table phpbb_modules (où le préfixe phpbb_ de tes tables est peut-être différent, auquel cas tu adaptes). Si tu ne trouves pas dans cette table le module, c’est que j’ai dû me tromper, dès lors, lance un recherche globale dans ta base de données).
  3. Après la suppression de ce module, relance le processus de mise à niveau et si d’autres erreurs de même type apparaissent, procède de la même manière. À contrario, si les erreurs diffèrent, présente-les nous à nouveau.

Source de mes dires basé sur un sujet similaire : support-mises-a-jour-conversions-phpbb32/sujet210139.html#p1644349.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9918
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron