[Réglé] 3.014 --> 3.2

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.2.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] 3.014 --> 3.2

Messagepar stpere » 06 Mai 2017 à 15:30

Bonjour a tous

Je me suis lancé dans ma mise a jour de mon forum. resté en 3.0.14 a cause de soucis de mise a jour justement...
J'ai donc suivi les étapes données dans votre sujet ici : http://forums.phpbb-fr.com/documentation/mise-a-jour/32x-mise-a-niveau-de-phpbb-30x-vers-32x-a228-view.html

-sauvegarde ftp et bd
-désactiver tous les mods
-remettre le style prosilver
-nettoyage de la base avec stk
-sauvegarde bd

effacer tous les fichiers du serveur sauf
config.php
/images/
/files/
/store/

uploader le 3.2 sans les éléments ci dessus.

j'ai lancé /install/app.php/update puis mise à jour bd

Et ici, le message suivant apparait :

Code: Tout sélectionner
Un module porte déjà ce nom : UCP_AUTH_LINK_MANAGE
Mettre à jour la base de données…


j'ai supprimé dans ma BDD le module en question, tout comme les 2 autres mod remontés ensuite.

Mais ensuite la mise a jour plante :
http://www.hostingpics.net/viewer.php?id=830928Capture.jpg

Code: Tout sélectionner
General Error:SQL ERROR [ mysql4 ]MySQL server has gone away [2006]SQLALTER TABLE phpbb_search_wordmatch ADD UNIQUE INDEX un_mtch(word_id, post_id, title_match) in file /home/passionh/www/forum_hockey/phpbb/db/driver/driver.php on line 999BACKTRACEFILE: (not given by php)LINE: (not given by php)CALL: installer_msg_handler()FILE: [ROOT]/phpbb/db/driver/driver.phpLINE: 999CALL: trigger_error()FILE: [ROOT]/phpbb/db/driver/mysql.phpLINE: 191CALL: phpbb\db\driver\driver->sql_error()FILE: [ROOT]/phpbb/db/tools/tools.phpLINE: 1061CALL: phpbb\db\driver\mysql->sql_query()FILE: [ROOT]/phpbb/db/tools/tools.phpLINE: 1505CALL: phpbb\db\tools\tools->_sql_run_sql()FILE: [ROOT]/phpbb/db/tools/tools.phpLINE: 649CALL: phpbb\db\tools\tools->sql_create_unique_index()FILE: (not given by php)LINE: (not given by php)CALL: phpbb\db\tools\tools->perform_schema_changes()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 711CALL: call_user_func_array()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 658CALL: phpbb\db\migrator->run_step()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 400CALL: phpbb\db\migrator->process_data_step()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 288CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 241CALL: phpbb\db\migrator->update_do()FILE: [ROOT]/phpbb/install/module/update_database/task/update.phpLINE: 160CALL: phpbb\db\migrator->update()FILE: [ROOT]/phpbb/install/module_base.phpLINE: 149CALL: phpbb\install\module\update_database\task\update->run()FILE: [ROOT]/phpbb/install/installer.phpLINE: 219CALL: phpbb\install\module_base->run()FILE: [ROOT]/phpbb/install/controller/update.phpLINE: 133CALL: phpbb\install\installer->run()FILE: (not given by php)LINE: (not given by php)CALL: phpbb\install\controller\update->phpbb\install\controller\{closure}()FILE: [ROOT]/vendor/symfony/http-foundation/StreamedResponse.phpLINE: 113CALL: call_user_func()FILE: [ROOT]/vendor/symfony/http-foundation/Response.phpLINE: 374CALL: Symfony\Component\HttpFoundation\StreamedResponse->sendContent()FILE: [ROOT]/install/app.phpLINE: 57CALL: Symfony\Component\HttpFoundation\Response->send()



Avez vous une idée de ce qui bloque ?

Merci de votre aide

Pierre
Modifié en dernier par stpere le 07 Mai 2017 à 11:47, modifié 1 fois.
----------------------------------------------------
http://www.pierre-barthelemy.fr

https://www.passionhockey.com
https://forum.passionhockey.com
----------------------------------------------------
stpere
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 11 Jan 2007 à 12:16

Re: 3.014 --> 3.2

Messagepar galixte » 06 Mai 2017 à 21:18

Salut,

ton serveur MySQL semble mettre trop de temps durant la mise à jour de la base de données, sans doute que le contenu des tables de la recherche de ton forum est trop important.

Ainsi :
  1. vide les tables de la recherche suivantes depuis phpMyAdmin : phpbb_search_wordlist phpbb_search_wordmatch - Le prefixe de tes tables n’est peut être pas : phpbb (Tu reconstruiras ton index une fois la mise à jour terminée, depuis le panneau d’administration du forum) ;
  2. relance le script de mise à jour.
Modifié en dernier par galixte le 07 Mai 2017 à 03:27, modifié 1 fois.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9543
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: 3.014 --> 3.2

Messagepar stpere » 07 Mai 2017 à 02:03

Merci ! Bonne remarque, c'était effectivement ça qui bloquait.
J'ai donc réussi a installer la 3.2, mais il me reste un soucis. Pour le moment je reste en php 5.6 car des que je passe en 7.0 il me plante mon forum... a voir ce qui cloque ici (toujours un affichage mysql 4 que je n'utilise pas puisqu'en 5.5)
----------------------------------------------------
http://www.pierre-barthelemy.fr

https://www.passionhockey.com
https://forum.passionhockey.com
----------------------------------------------------
stpere
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 11 Jan 2007 à 12:16

Re: 3.014 --> 3.2

Messagepar galixte » 07 Mai 2017 à 03:29

Ouvre un autre sujet puisque tu es parvenu à mettre à jour vers phpBB 3.2.x. En passant, tu parles de PHP 5.6, puis de 5.5, relis-toi c’est pas comestible. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9543
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: 3.014 --> 3.2

Messagepar stpere » 07 Mai 2017 à 11:47

galixte a écrit:Ouvre un autre sujet puisque tu es parvenu à mettre à jour vers phpBB 3.2.x. En passant, tu parles de PHP 5.6, puis de 5.5, relis-toi c’est pas comestible. ;)



J'allais le faire mais je compte d'abord tenter de me débrouiller ;)
Pour le php 5.6, je parle ensuite de Mysql 5.5 (alors que l'alerte affichée est en mysql4)
Bref, je ferme ce sujet, et j'en ouvrirai un autre si je n'arrive pas a passer en PHP 7.0

Merci encore !
----------------------------------------------------
http://www.pierre-barthelemy.fr

https://www.passionhockey.com
https://forum.passionhockey.com
----------------------------------------------------
stpere
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 11 Jan 2007 à 12:16

Re: 3.014 --> 3.2

Messagepar galixte » 08 Mai 2017 à 13:46

Pardon, mal lu, il était tard lorsque j’ai répondu. :oops:

Ouvre un sujet avec les erreurs constatées sous PHP 7, sans quoi, on ne pourra pas t’aiguiller. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9543
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.


Retourner vers Mises à jour/Conversions

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité