[Réglé] Problème ACP depuis mise à jour 3.2.0

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.2.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Problème ACP depuis mise à jour 3.2.0

Messagepar silenus » 11 Fév 2017 à 13:14

Bonjour.

Je rencontre une série de problèmes depuis la mise à jour 3.1.10 -> 3.2.0.

Initialement 3.1.10 avec thème Subsilver2 sans le moindre problème.

Mise à jour 3.2.0 (via automatic update package).

Deux problèmes sont apparus :
- quote qui dysfonctionnent, m'a été répondu que cela venait du fait que subsilver2 n'était plus supporté depuis 3.2.0
- des problèmes de non traduction, uniquement dans la zone d'administration, des variables affichées en brut genre , même avec le thème prosilver : ACP_HELP_PHPBB SEND_STATISTICS_LONG ...), où il m'a été demandé de faire un sujet dédié, ce que je fait présentement.
(lien vers le sujet de demande d'assistance pour les deux points ci-dessus : support-utilisation-phpbb32/sujet209586.html ).

J'ai donc modifié mon forum pour le thème prosilver (modification des paramètres de thème par défaut, désactivation de subsilver2, activation de prosilver, vidé le cache (via ftp, en supprimant tout dans /cache sauf index.htm et .htaccess tel indiqué dans la doc).

1. Le problème des non traduction persiste
2. Certaines fonctionnalités d'administration ne marchent pas. Par exemple, "administrer un membre" (lien type /adm/index.php?i=users&mode=overview&u=69123&sid= ), me renvoie une page blanche (édition de code de la page : rien).

En vous remerciant d'avance pour bien vouloir m'aider dans la poursuite du diagnostic et de la résolution.

Cordialement.
Modifié en dernier par silenus le 13 Fév 2017 à 09:51, modifié 1 fois.
silenus
Posteur néophyte
Posteur néophyte
 
Messages: 26
Enregistré le: 09 Fév 2017 à 19:40

Re: Problème ACP depuis mise à jour 3.2.0

Messagepar tomberaid » 11 Fév 2017 à 17:32

Hello,

La clé de langue que tu mentionnes n'est pas présente dans les fichiers de langue originaux de phpBB.

Comment as tu fait ta mise à jour ?
Avant la mise à jour as-tu désactivé tous les styles sauf prosilver, ainsi que toutes les extensions ? Et si forum ancien (branche 3.0.x) avec Mods, les as-tu désinstallé ?

Attention avant de faire la mise à jour, prosilver doit le seul style et par défaut. Il ne faut pas qu'il y ait de Mods ou d'extensions d'installées sur ton forum.

La meilleur façon de mettre à jour vers une nouvelle branche est d'abord de faire une sauvegarde complète de ta base de données puis de renommer ton dossier contenant ton forum et enfin de transférer un répertoire complet avec la nouvelle version sauf le fichier config.php ainsi que les dossiers images, download et files. Ensuite tu recopies dans l'ancien forum le fichier et les dossiers non transférés (config.php, images, download, files) afin de les coller pour compléter ce nouveau répertoire. Si tu as déjà fait la mise à jour de la base de données, tu peux aussi supprimer le dossier install sinon tu te rends par ton navigateur sur ce dossier pour faire la mise à jour.
Il ne te reste plus qu'à tester et si tout est OK alors tu peux supprimer l'ancien répertoire du forum (celui que tu as précédemment renommé). Tu peux réinstaller une à une les extensions et styles que tu souhaites sous réserve que cela soit compatible avec la nouvelle version de ton forum.

Cordialement
Image
Avatar de l’utilisateur
tomberaid
Roi des posts
Roi des posts
 
Messages: 714
Enregistré le: 18 Juin 2009 à 00:27

Re: Problème ACP depuis mise à jour 3.2.0

Messagepar silenus » 11 Fév 2017 à 17:43

Bonjour.

Merci pour ces explications.
J'ai procédé par automatic update.
Et je n'ai pas désactivé les styles avant cela.

J'avais fait une sauvegarde base + fichiers avant la mise à jour, et maintenant, depuis il y a eu des posts, créations de comptes.

Comment rétablir la situation?

Est-il possible de remplacer l'existant migré en 3.2.0 et repartir avec une installation "neuve" de phpbb 3.2.0 ? (dans ce cas là quelle est la procédure à suivre? Car normalement une nouvelle installation requiert la création d'une base, etc... Sauvegarder la base actuelle, la vider, lancer une installation neuve (config similaire : mysql..), vider la base créée par la nouvelle install et réinjecter la base sauvegardée serait correct? ).

Merci.
silenus
Posteur néophyte
Posteur néophyte
 
Messages: 26
Enregistré le: 09 Fév 2017 à 19:40

Re: Problème ACP depuis mise à jour 3.2.0

Messagepar tomberaid » 12 Fév 2017 à 01:16

silenus a écrit:Sauvegarder la base actuelle, la vider, lancer une installation neuve (config similaire : mysql..), vider la base créée par la nouvelle install et réinjecter la base sauvegardée serait correct?


Hello
Autant remplacer les fichiers de ton forum par ceux d'origine de phpbb-3.2.0, sauf ceux mentionnés dans mon précédent message. Si c'est pour réinjecter ta base actuelle, il ne sert à rien d'en créer une nouvelle.

La procédure est simple (quand on le fait soi-même), l'expliquer est plus complexe, désolé de ne pas pouvoir t'aider plus.

Cordialement
Image
Avatar de l’utilisateur
tomberaid
Roi des posts
Roi des posts
 
Messages: 714
Enregistré le: 18 Juin 2009 à 00:27

Re: Problème ACP depuis mise à jour 3.2.0

Messagepar silenus » 13 Fév 2017 à 09:52

Merci.
silenus
Posteur néophyte
Posteur néophyte
 
Messages: 26
Enregistré le: 09 Fév 2017 à 19:40

Re: Problème ACP depuis mise à jour 3.2.0

Messagepar silenus » 13 Fév 2017 à 21:42

Problème résolu en réinstallant le forum totalement avec les instructions indiquées.

Merci pour tout.
silenus
Posteur néophyte
Posteur néophyte
 
Messages: 26
Enregistré le: 09 Fév 2017 à 19:40


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités