[Réglé] Erreur PCA onglet Extensions

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Erreur PCA onglet Extensions

Messagepar Leon73 » 16 Fév 2018 à 12:48

Bonjour à tous,
Nous venons de passer notre forum en version 3.1.12, forum qui fonctionne correctement. Vient maintenant le temps de la mise en place des extensions.
A l'ouverture du PCA, il y a un onglet "RSS" et un onglet "Extensions" alors qu'aucune extension n'existe dans le répertoire forum/ext.
Je vais dans l'onglet "Système" puis "Gestion des modules" pour supprimer le module "RSS", ça fonctionne. Idem pour l'onglet "Extensions" et là, c'est plus compliqué car il y a plusieurs niveaux de sous-modules, visiblement un reste de MODS qui ont été mal supprimés. Mais bon, j'arrive à tout supprimer, plus d'onglet RSS ni Extensions.
Seulement, après copie du répertoire phpbb (qui contient Board Announcements) et qui apparait bien dans l'onglet "Personnaliser", lorsque je veux l'activer, j'obtiens ce message d'erreur :
Un problème a été rencontré durant l’opération de mise à jour de la base de données. Les modifications déjà appliquées ont été annulées du mieux possible, veuillez vérifier que votre forum ne comporte pas d’erreur.
Un module requis est manquant : ACP_CAT_DOT_MODS

Aie aie aie.... Comment dois-je faire pour me sortir de ce mauvais pas ?

Bonne journée :)
Leon73
Posteur néophyte
Posteur néophyte
 
Messages: 29
Enregistré le: 05 Mai 2015 à 09:44

Re: Erreur PCA onglet Extensions

Messagepar pierredu » 16 Fév 2018 à 12:54

Il faut aller faire la suppression de cette ligne à la main dans la table phpbb(3)_modules.
Après une sauvegarde de sécurité, naturellement.
Et sans oublier de vider le cache ensuite.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1092
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Erreur PCA onglet Extensions

Messagepar Leon73 » 16 Fév 2018 à 13:16

Wow, réponse rapide, merci Pierredu :)

Je ne vois pas "ACP_CAT_DOT_MODS" dans la table "phpbb3_modules", ni dans le champ "module-name", non plus dans le champ "module_langname", ni ailleurs.

J'ai fais une recherche dans la base complète, 0 correspondance.
Leon73
Posteur néophyte
Posteur néophyte
 
Messages: 29
Enregistré le: 05 Mai 2015 à 09:44

Re: Erreur PCA onglet Extensions

Messagepar Sylveretour » 16 Fév 2018 à 16:26

Bonjour,

Nous venons de passer notre forum en version 3.1.12, forum qui fonctionne correctement

Vu que les versions 3.1.X de phpBB ne seront plus supportées à partir de Juillet, autant pousser la mise à jour en 3.2.2

Pour le problème de module en trop, il date de ta version 3.0
Un fois en 3.2.2, tu pourra nettoyer la bdd avec le STK => https://github.com/AlexSheer/phpBB3.2-STK
Avatar de l’utilisateur
Sylveretour
Maître-posteur
Maître-posteur
 
Messages: 444
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Erreur PCA onglet Extensions

Messagepar Leon73 » 16 Fév 2018 à 19:33

Remarque judicieuse...

Je clos le sujet sachant que s'il y a un souci, ce sera en 3.2.2 ;)

Merci de votre aide.
Leon73
Posteur néophyte
Posteur néophyte
 
Messages: 29
Enregistré le: 05 Mai 2015 à 09:44


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité