3.0.11=>3.1.10 erreur 500

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

3.0.11=>3.1.10 erreur 500

Messagepar Pruls » 14 Nov 2016 à 00:14

Bonjour,

j'ai voulu mettre à jour mon forum (en suivant ces consignes, sauf stk) mais je viens de me rendre compte que cela n'a pas complètement fonctionné.

En effet, je peux naviguer dans la structure du forum, administrer les utilisateurs, mais les sujets génèrent une erreur 500.

En renommant le .htaccess en .htaccess.bak , une erreur 404 apparaît.

Suis je sur la bonne voie, et si oui, que dois je ajuster dans le htaccess?

Merci par avance pour les éléments de réponse que vous pourrez me donner.

PS: j'ai sauvegardé ma bdd ainsi que les fichiers qui se trouvaient sur le ftp.
Modifié en dernier par Pruls le 14 Nov 2016 à 16:27, modifié 1 fois.
Pruls
Posteur néophyte
Posteur néophyte
 
Messages: 3
Enregistré le: 14 Nov 2016 à 00:08

Re: 3.0.x=>3.1.10 erreur 500

Messagepar galixte » 14 Nov 2016 à 05:09

Bienvenue !

Pruls a écrit:Bonjour,

j'ai voulu mettre à jour mon forum (en suivant ces consignes, sauf stk) mais je viens de me rendre compte que cela n'a pas complètement fonctionné.

En effet, je peux naviguer dans la structure du forum, administrer les utilisateurs, mais les sujets génèrent une erreur 500.
Quel est l’erreur 500 (son contenu) ?

Pruls a écrit:En renommant le .htaccess en .htaccess.bak , une erreur 404 apparaît.
Même question.

Pruls a écrit:Suis je sur la bonne voie, et si oui, que dois je ajuster dans le htaccess?
Il nous faut savoir si c’est utile auparavant de réaliser une telle action (CF. questions précédentes).

Pruls a écrit:Merci par avance pour les éléments de réponse que vous pourrez me donner.

PS: j'ai sauvegardé ma bdd ainsi que les fichiers qui se trouvaient sur le ftp.
… avant de procéder à la mise à jour, j’espère ?
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10097
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: 3.0.11=>3.1.10 erreur 500

Messagepar Pruls » 14 Nov 2016 à 16:33

Bonjour,

merci pour le temps consacré à ma demande.

Je commence par la fin: De désespoir, j'ai écrasé la bdd par ma sauvegarde + remis les fichiers de départ. Tout est fonctionnel, dans la version passée: 3.0.11 (j'en profite pour mettre à jour le titre).

c/c du .htaccess v3.1.10 installé : (Il s'agit de la version dispo sur https://www.phpbb.com )

Code: Tout sélectionner
<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>


Je n'ai pas mémoire du détail de l'erreur 500. Je pourrais compléter lorsque je tenterai une nouvelle mise à jour.
Pruls
Posteur néophyte
Posteur néophyte
 
Messages: 3
Enregistré le: 14 Nov 2016 à 00:08


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité