[Réglé] 3.0.12->3.1.9 Images jointes non affichées

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] 3.0.12->3.1.9 Images jointes non affichées

Messagepar buzuc » 10 Aoû 2016 à 16:26

Bonjour,

je viens vers vous suite à la migration de mon forum d'une version 3.0.12 à 3.1.9

J'ai testé la migration en local et tout va bien. Les fichiers sont bien transférés en binaire et non pas en ASCII.

Pourtant en faisant la migration sur le serveur "live" les fichiers et images ne sont pas affichées... Les fichiers sur le serveur sont bon puisque je peut les visualiser en entrant leur adresse directement.
J'ai tout essayé: renvoi du répertoire files sur le serveur (en binaire), purge du cache par l'ACP et en ftp,purge du cache de mon navigateur, vérification de la base de données... Rien n'y fait

J'ai 44000 fichiers qui ne sont plus affichables ou téléchargeables.

HELP!

[Edit] Les avatars des membres ne s'affichent pas non plus et pourtant ils sont accessibles
Modifié en dernier par buzuc le 11 Aoû 2016 à 10:26, modifié 1 fois.
http://www.maquettes-papier.net/forumenpapier en version 3.1.9 hébergé chez infomaniak
Avatar de l’utilisateur
buzuc
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 20 Sep 2005 à 13:26
Localisation: Saint-Nazaire (44) / Carrières sur Seine (78)

Re: 3.0.12->3.1.9 Images jointes non affichées

Messagepar Manard » 10 Aoû 2016 à 17:01

Bonjour,

Depuis le panneau d'administration en sélectionnant l'onglet "Message" +

"Paramètres des fichiers joints" : "Autorisez les fichiers joints" est-il à Oui ?

"Gérer les fichiers joints" , en vois-tu ? sinon

"Fichiers joints orphelins" sont-ils là ?

Bonne résolution

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 897
Enregistré le: 31 Mar 2012 à 08:24

Re: 3.0.12->3.1.9 Images jointes non affichées

Messagepar buzuc » 10 Aoû 2016 à 17:04

Manard a écrit:Bonjour,

Depuis le panneau d'administration en sélectionnant l'onglet "Message" +

"Paramètres des fichiers joints" : "Autorisez les fichiers joints" est-il à Oui ?
Oui

"Gérer les fichiers joints" , en vois-tu ? sinon
oui et le nombre correspond bien au nombre d'enregistrements de la bdd

"Fichiers joints orphelins" sont-ils là ?
Il y en a mais ce ne sont pas les fichiers joints des messages

Bonne résolution

Bernard
http://www.maquettes-papier.net/forumenpapier en version 3.1.9 hébergé chez infomaniak
Avatar de l’utilisateur
buzuc
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 20 Sep 2005 à 13:26
Localisation: Saint-Nazaire (44) / Carrières sur Seine (78)

Re: 3.0.12->3.1.9 Images jointes non affichées

Messagepar Manard » 10 Aoû 2016 à 17:55

Bonsoir,

Les droits du répertoire Files ont-ils été changés sur le serveur ? normalement le CHMOD doit-être à 777.

Bonne soirée

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 897
Enregistré le: 31 Mar 2012 à 08:24

Re: 3.0.12->3.1.9 Images jointes non affichées

Messagepar buzuc » 11 Aoû 2016 à 08:42

Oui bien sûr. C'est pourquoi je pose la question ici. Je ne sais plus quoi faire
http://www.maquettes-papier.net/forumenpapier en version 3.1.9 hébergé chez infomaniak
Avatar de l’utilisateur
buzuc
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 20 Sep 2005 à 13:26
Localisation: Saint-Nazaire (44) / Carrières sur Seine (78)

Re: 3.0.12->3.1.9 Images jointes non affichées

Messagepar ABDev » 11 Aoû 2016 à 08:49

Bonjour,
Vous avez la possibilité de me faire parvenir un compte administrateur ?
Je n'ai pas spécialement d'idée, on verra bien.

Edit : Le message d'erreur dont je vous avais évoqué en message privé m'a mis sur la piste ;).

Warning: require(./../includes/acm/acm_file.php): failed to open stream: No such file or directory in /home/clients/41231ba1f4ee800f1d4f310e20e3e3dd/web/forumenpapier/download/file.php on line 42

Warning: require(./../includes/acm/acm_file.php): failed to open stream: No such file or directory in /home/clients/41231ba1f4ee800f1d4f310e20e3e3dd/web/forumenpapier/download/file.php on line 42

Fatal error: require(): Failed opening required './../includes/acm/acm_file.php' (include_path='.:/opt/php5.6/lib/php') in /home/clients/41231ba1f4ee800f1d4f310e20e3e3dd/web/forumenpapier/download/file.php on line 42

En fait, le dossier download/ et son contenu n'était pas bon (fichier file.php de la version 3.0.x).
Maintenant, ça fonctionne mieux 8).
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15689
Enregistré le: 12 Mai 2005 à 22:54

Re: 3.0.12->3.1.9 Images jointes non affichées

Messagepar buzuc » 11 Aoû 2016 à 10:25

Excellent!

Et pourtant j'ai tout effacé sauf "files","images"... deux fois avec upload des fichiers de base de la version 3.1.9. Comment le répertoire download a pu échapper à ça? Aucune idée.

Encore merci.
J'ai plus besoin de votre adresse :mrgreen:
http://www.maquettes-papier.net/forumenpapier en version 3.1.9 hébergé chez infomaniak
Avatar de l’utilisateur
buzuc
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 20 Sep 2005 à 13:26
Localisation: Saint-Nazaire (44) / Carrières sur Seine (78)

Re: 3.0.12->3.1.9 Images jointes non affichées

Messagepar ABDev » 11 Aoû 2016 à 10:26

Y'a pas de quoi ;).
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15689
Enregistré le: 12 Mai 2005 à 22:54

Re: 3.0.12->3.1.9 Images jointes non affichées

Messagepar Skouat » 11 Aoû 2016 à 11:12

Bonjour,

buzuc a écrit:Et pourtant j'ai tout effacé sauf "files","images"... deux fois avec upload des fichiers de base de la version 3.1.9. Comment le répertoire download a pu échapper à ça? Aucune idée.


Si vous utilisez FileZilla, ce dernier utilise un cache. On crois qu'on fait des choses sur le serveur distant mais en fait non... tout est fait au niveau du cache jusqu'à ce que le cache soit envoyé sur le serveur.
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13488
Enregistré le: 02 Avr 2008 à 19:47


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités