[Réglé] Upgrade 3.1.4 à 3.1.9 : petit souci de pages blanches...

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Upgrade 3.1.4 à 3.1.9 : petit souci de pages blanches...

Messagepar antier » 26 Juil 2016 à 22:57

Bonsoir,

Grande première pour moi, je viens de procéder à la mise à jour de mon forum de la version 3.1.4 à la version 3.1.9 (Prosilver) J'ai bien suivi toutes les indications pour la procédure (modifications manuelles, pas via ftp), en particulier les précisions apportées par cabot (20 juin). Tout s'est bien passé, j'ai relancé mon forum et tout semble fonctionner correctement, je n'ai aucun message d'erreur (pour l'instant). :D

Mais - car il y a un mais ! - quand je vais dans le PCA, deux onglets présentent des pages totalement blanches : l'onglet "MESSAGES" et l'onglet "SYSTÈME" (tous les autres onglets fonctionnent normalement, y compris "Extensions"). :(

Je suis preneur de toute solution pour résoudre ce problème, merci d'avance (petite précision : j'ai gardé une copie complète de mon forum en 3.1.4... à tout hasard).

PS : je précise que je suis bien passé en version 3.1.9 (je m'en suis aperçu en cherchant à refaire la mise à jour de 1.4 à la 1.9, ce qui m'a été refusé puisque... je suis déjà en 3.1.9)

Edit : après vérifications, j'obtiens aussi des pages blanches dans un certain nombre de rubriques de l'onglet "GÉNÉRAL" : Informations PHP, Paramètres des Messages, Paramètres de signature, des Enregistrements, des Flux, de la page de Contacts, des Emails, de Cookie, etc. et dans d'autres onglets... :cry: Je constate également que l'onglet "MESSAGES" est nouveau pour moi, il n'existait pas dans la 3.1.4 (c'était "PUBLICATION").
antier
Posteur néophyte
Posteur néophyte
 
Messages: 80
Enregistré le: 29 Aoû 2010 à 18:12
Localisation: Colombes

Re: Upgrade 3.1.4 à 3.1.9 : petit souci de pages blanches...

Messagepar Manard » 27 Juil 2016 à 08:37

Bonjour,

Tu sembles être passé directement de 3.1.4 à 3.1.9 je pense qu'il aurait fallu installer toutes les mises à jour depuis la 3.1.4.

A ta place je prendrais une installation complète en 3.1.9 et remplacerai le fichier config.php par celui de ton forum actuel et mettrais toute cette nouvelle installation à la place de l'ancienne.

Fais une sauvegarde de ta base de données avant ces opérations au cas où, bien qu'elle ne devrait pas trop être affectée.

Bonne mise à jour

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 931
Enregistré le: 31 Mar 2012 à 09:24

Re: Upgrade 3.1.4 à 3.1.9 : petit souci de pages blanches...

Messagepar antier » 27 Juil 2016 à 12:32

Manard a écrit:Tu sembles être passé directement de 3.1.4 à 3.1.9 je pense qu'il aurait fallu installer toutes les mises à jour depuis la 3.1.4. Bernard


Merci, Bernard, pour ta réponse rapide. :D

Réponse qui me laisse toutefois un peu perplexe... Dans la mesure où il existe un programme dédié pour passer directement de la 3.1.4 à la 3.1.9, on peut supposer qu'il n'y a pas besoin de passer par toutes les versions intermédiaires ? Je dis cela, je ne dis rien, car dans ce domaine je n'y connais pas grand-chose. :roll:

Pour plus de sécurité, j'ai remis en place la 3.1.4 dont j'avais eu la bonne idée de faire une sauvegarde totale et complète, et tout fonctionne comme avant. En attendant d'avoir confirmation de ta réponse et/ou d'autres explications.
antier
Posteur néophyte
Posteur néophyte
 
Messages: 80
Enregistré le: 29 Aoû 2010 à 18:12
Localisation: Colombes

Re: Upgrade 3.1.4 à 3.1.9 : petit souci de pages blanches...

Messagepar cocooncrash » 28 Juil 2016 à 14:57

Bonjour,
Vous avez bien verifier que vos fichiers sont en utf 8 sans bom?

Quel mode de transfert utilisez vous sur votre logiciel de ftp?
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7701
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Upgrade 3.1.4 à 3.1.9 : petit souci de pages blanches...

Messagepar antier » 28 Juil 2016 à 16:33

cocooncrash a écrit:Bonjour,
Vous avez bien verifier que vos fichiers sont en utf 8 sans bom?
> Que signifie "sans bom" ?
Quel mode de transfert utilisez vous sur votre logiciel de ftp?


Merci de vous pencher sur mon petit problème.

J'utilise FileZilla (3.19.0) : dans l'onglet "Paramètres de transfert", la case "Par défaut" est cochée, et dans l'onglet "jeu de caractères", la case "Détection automatique" est cochée. Cela dit, lors de la mise à jour, je n'ai pas utilisé la modification par logiciel ftp, mais la modification manuelle qui est recommandée. Et je n'ai jamais eu aucun problème d'upload avec FileZilla...
antier
Posteur néophyte
Posteur néophyte
 
Messages: 80
Enregistré le: 29 Aoû 2010 à 18:12
Localisation: Colombes

Re: Upgrade 3.1.4 à 3.1.9 : petit souci de pages blanches...

Messagepar cocooncrash » 29 Juil 2016 à 14:53

utf8 sans bom est le format du fichier, ouvrez vos fichiers avec notepad++, vous trouverez ce format.

le transfert est a faire en mod binaire.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7701
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Upgrade 3.1.4 à 3.1.9 : petit souci de pages blanches...

Messagepar cocooncrash » 28 Aoû 2016 à 09:10

Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7701
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Upgrade 3.1.4 à 3.1.9 : petit souci de pages blanches...

Messagepar antier » 28 Aoû 2016 à 12:03

Oui, pardon, ça m'était sorti de la tête.
Cela dit, le problème n'est pas résolu car je reste en 3.1.4, mais je vais tout même ajouter le tag [réglé] car c'est réglé... provisoirement.
antier
Posteur néophyte
Posteur néophyte
 
Messages: 80
Enregistré le: 29 Aoû 2010 à 18:12
Localisation: Colombes


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron